summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-05-28 02:55:24 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-05-28 02:55:24 +0000
commit4993a22762f18f16a6e4799cce3b4bdf7ee4b5fe (patch)
tree5b90c747eb6a224c5b36899f778b52ce68e8f101 /media-sound/amarok-utils
parent[package.mask] Masked media-sound/amarok{-utils}-2.3.1 until the tarballs are... (diff)
downloadgentoo-2-4993a22762f18f16a6e4799cce3b4bdf7ee4b5fe.tar.gz
gentoo-2-4993a22762f18f16a6e4799cce3b4bdf7ee4b5fe.tar.bz2
gentoo-2-4993a22762f18f16a6e4799cce3b4bdf7ee4b5fe.zip
[media-sound/amarok-utils] Bumped to the 2.3.1 release.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/amarok-utils')
-rw-r--r--media-sound/amarok-utils/ChangeLog8
-rw-r--r--media-sound/amarok-utils/amarok-utils-2.3.1.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/media-sound/amarok-utils/ChangeLog b/media-sound/amarok-utils/ChangeLog
index 7a6d1edb86bd..1ed21bf22ca7 100644
--- a/media-sound/amarok-utils/ChangeLog
+++ b/media-sound/amarok-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/amarok-utils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok-utils/ChangeLog,v 1.22 2010/04/19 13:37:58 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok-utils/ChangeLog,v 1.23 2010/05/28 02:55:24 jmbsvicetto Exp $
+
+*amarok-utils-2.3.1 (28 May 2010)
+
+ 28 May 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +amarok-utils-2.3.1.ebuild:
+ [media-sound/amarok-utils] Bumped to the 2.3.1 release.
19 Apr 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
amarok-utils-2.3.0.90.ebuild:
diff --git a/media-sound/amarok-utils/amarok-utils-2.3.1.ebuild b/media-sound/amarok-utils/amarok-utils-2.3.1.ebuild
new file mode 100644
index 000000000000..edaea39b754f
--- /dev/null
+++ b/media-sound/amarok-utils/amarok-utils-2.3.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok-utils/amarok-utils-2.3.1.ebuild,v 1.1 2010/05/28 02:55:24 jmbsvicetto Exp $
+
+EAPI="2"
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git"
+ EGIT_PROJECT="amarok"
+ EGIT_REPO_URI="git://gitorious.org/amarok/amarok.git"
+fi
+
+inherit base cmake-utils ${GIT_ECLASS}
+
+MY_PN="amarok"
+
+DESCRIPTION="Various utility programs for Amarok."
+HOMEPAGE="http://amarok.kde.org/"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="mirror://kde/stable/${MY_PN}/${PV}/src/${MY_PN}-${PV}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="4"
+IUSE="debug"
+
+DEPEND="
+ >=media-libs/taglib-1.6.1[asf,mp4]
+ >=media-libs/taglib-extras-1.0.1
+ >=x11-libs/qt-core-4.4:4
+ >=x11-libs/qt-dbus-4.4:4
+"
+RDEPEND="${DEPEND}
+ !<media-sound/amarok-2.1.80:2
+ !<media-sound/amarok-2.1.80:${SLOT}
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DOCS="TODO README ChangeLog AUTHORS"
+
+src_prepare() {
+ # Disable po processing
+ sed -e "s:include(MacroOptionalAddSubdirectory)::" \
+ -i "${S}/CMakeLists.txt" \
+ || die "Removing include of MacroOptionalAddSubdirectory failed."
+ sed -e "s:macro_optional_add_subdirectory( po )::" \
+ -i "${S}/CMakeLists.txt" \
+ || die "Removing include of MacroOptionalAddSubdirectory failed."
+
+ base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_PLAYER=OFF
+ -DWITH_UTILITIES=ON
+ )
+
+ cmake-utils_src_configure
+}