summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-03-09 01:16:54 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-03-09 01:16:54 +0000
commit4307cce245086e2dddecdac71c8c0d64605e35ba (patch)
treeb5a00665e937e28a88fdefbbedf440f8f8fe69bd /media-sound/amp/amp-0.7.6.ebuild
parentNew version (diff)
downloadgentoo-2-4307cce245086e2dddecdac71c8c0d64605e35ba.tar.gz
gentoo-2-4307cce245086e2dddecdac71c8c0d64605e35ba.tar.bz2
gentoo-2-4307cce245086e2dddecdac71c8c0d64605e35ba.zip
New ebuild (~x86 masked) closes #15355
Diffstat (limited to 'media-sound/amp/amp-0.7.6.ebuild')
-rw-r--r--media-sound/amp/amp-0.7.6.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-sound/amp/amp-0.7.6.ebuild b/media-sound/amp/amp-0.7.6.ebuild
new file mode 100644
index 000000000000..2807b84f39c8
--- /dev/null
+++ b/media-sound/amp/amp-0.7.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amp/amp-0.7.6.ebuild,v 1.1 2003/03/09 01:16:54 jje Exp $
+
+DESCRIPTION="AMP - the Audio Mpeg Player"
+LICENSE="as-is"
+
+SRC_URI="http://distro.ibiblio.org/pub/Linux/distributions/slackware/slackware_source/ap/amp/${P}.tar.gz"
+KEYWORDS='~x86'
+SLOT="0"
+S=${WORKDIR}/${P}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ patch -p0 <${FILESDIR}/${P}-gentoo.diff || die
+ emake || die
+}
+
+src_install() {
+ dobin amp || die
+ dodoc BUGS CHANGES README TODO doc/*
+}