summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2005-09-14 02:07:02 +0000
committerEldad Zack <eldad@gentoo.org>2005-09-14 02:07:02 +0000
commit1c1aadda89b31809576513ac8cbe42eecf285697 (patch)
tree78d23e5b7ca828005c3bf9d965dd2bbbfb1c665d /media-sound/ardour/ardour-0.9_beta30.ebuild
parentadded get_libdir fix for bug #105782 (diff)
downloadgentoo-2-1c1aadda89b31809576513ac8cbe42eecf285697.tar.gz
gentoo-2-1c1aadda89b31809576513ac8cbe42eecf285697.tar.bz2
gentoo-2-1c1aadda89b31809576513ac8cbe42eecf285697.zip
Version bump. added sse useflag. bug #105726.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-sound/ardour/ardour-0.9_beta30.ebuild')
-rw-r--r--media-sound/ardour/ardour-0.9_beta30.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/media-sound/ardour/ardour-0.9_beta30.ebuild b/media-sound/ardour/ardour-0.9_beta30.ebuild
new file mode 100644
index 000000000000..731dd760521f
--- /dev/null
+++ b/media-sound/ardour/ardour-0.9_beta30.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-0.9_beta30.ebuild,v 1.1 2005/09/14 02:07:02 eldad Exp $
+
+inherit eutils
+
+DESCRIPTION="multi-track hard disk recording software"
+HOMEPAGE="http://ardour.org/"
+SRC_URI="http://ardour.org/releases/${P/_/}.tar.bz2"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="nls debug sse"
+
+# From beta30 release notes:
+# plugin latency compensation now working correctly (we believe)
+# This really requires JACK 0.100.0 or above to work
+# properly, but even without that, they result in notable improvements
+# in the way Ardour aligns newly recorded material.
+#
+# As media-sound/jack-audio-connection-kit-0.100.0 is still -arch and it is not required for beta30
+# only suggested, RDEPEND needs to be updated as media-sound/jack-audio-connection-kit-0.100.0 gets
+# into ~arch. (2005 Sep 14 eldad)
+
+RDEPEND="dev-util/pkgconfig
+ >=media-libs/liblrdf-0.3.6
+ >=media-libs/raptor-1.2.0
+ >=media-sound/jack-audio-connection-kit-0.98.1
+ =dev-libs/glib-1.2*
+ =x11-libs/gtk+-1.2*
+ >=media-libs/libsndfile-1.0.4
+ sys-libs/gdbm
+ >=media-libs/ladspa-sdk-1.12
+ >=media-libs/libsamplerate-0.0.14
+ >=dev-libs/libxml2-2.5.7
+ >=media-libs/libart_lgpl-2.3.16
+ >=dev-util/scons-0.96.1"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}/${P/_/}"
+
+src_compile() {
+ # Required for scons to "see" intermediate install location
+ mkdir -p ${D}
+ DBUG=no ; if useq debug ; then DBUG=yes ; fi
+ ENABLE_SSE=0 ; if useq sse ; then ENABLE_SSE=1 ; fi
+
+ scons DEBUG=${DBUG} USE_SSE_EVERYWHERE=${ENABLE_SSE} DESTDIR=${D} PREFIX=/usr KSI=0 -j2
+}
+
+src_install() {
+ scons install || die "make install failed"
+
+ # Workaround for xorg bug concerning lucida fonts. bug 73056. (2004 Dec 3 eldad)
+ # This workaround is no longer required as of ardour-0.9_beta29
+ # as it is already implemented in ardour_ui.rc
+ #sed -e 's/lucida[^-]*-/helvetica-/' -i ${D}/etc/ardour/ardour_ui.rc
+
+ dodoc DOCUMENTATION/*
+}