summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2009-04-30 16:41:54 +0000
committerTony Vroon <chainsaw@gentoo.org>2009-04-30 16:41:54 +0000
commit36a24f09d19bae637dcf1f9cfb25fc368517ed3d (patch)
treefe5351fc0abaa12db119c539ebb271448c17c8e6 /media-sound/audacious
parentSecond developer alpha. This uses GIO instead of standard POSIX I/O, so files... (diff)
downloadgentoo-2-36a24f09d19bae637dcf1f9cfb25fc368517ed3d.tar.gz
gentoo-2-36a24f09d19bae637dcf1f9cfb25fc368517ed3d.tar.bz2
gentoo-2-36a24f09d19bae637dcf1f9cfb25fc368517ed3d.zip
Version bump to second developer alpha. This is masked software, unmask at your own risk, bugs go upstream.
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/audacious')
-rw-r--r--media-sound/audacious/ChangeLog8
-rw-r--r--media-sound/audacious/audacious-2.0_alpha2.ebuild76
2 files changed, 83 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 57c31c30a9fb..bee1d25656df 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.157 2009/04/17 12:13:41 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.158 2009/04/30 16:41:54 chainsaw Exp $
+
+*audacious-2.0_alpha2 (30 Apr 2009)
+
+ 30 Apr 2009; <chainsaw@gentoo.org> +audacious-2.0_alpha2.ebuild:
+ Version bump to second developer alpha. This is masked software, unmask at
+ your own risk, bugs go upstream.
*audacious-2.0_alpha1 (17 Apr 2009)
diff --git a/media-sound/audacious/audacious-2.0_alpha2.ebuild b/media-sound/audacious/audacious-2.0_alpha2.ebuild
new file mode 100644
index 000000000000..9dc62a031835
--- /dev/null
+++ b/media-sound/audacious/audacious-2.0_alpha2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-2.0_alpha2.ebuild,v 1.1 2009/04/30 16:41:54 chainsaw Exp $
+
+inherit flag-o-matic
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="altivec chardet nls libsamplerate session sse2"
+
+RDEPEND=">=dev-libs/dbus-glib-0.60
+ >=dev-libs/glib-2.16
+ >=dev-libs/libmcs-0.7.1-r2
+ >=dev-libs/libmowgli-0.7.0
+ dev-libs/libxml2
+ >=x11-libs/cairo-1.2.6
+ >=x11-libs/gtk+-2.14
+ >=x11-libs/pango-1.8.0
+ libsamplerate? ( media-libs/libsamplerate )
+ session? ( x11-libs/libSM )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ nls? ( dev-util/intltool )"
+
+PDEPEND=">=media-plugins/audacious-plugins-2.0_alpha2"
+
+src_compile() {
+ # This is masked in the portage tree, so I'll save you the
+ # popup. Be good, bugs go upstream and we like patches.
+ append-flags -DNOT_ALPHA_RELEASE
+
+ # D-Bus is a mandatory dependency, remote control,
+ # session management and some plugins depend on this.
+ # Building without D-Bus is *unsupported* and a USE-flag
+ # will not be added due to the bug reports that will result.
+ # Bugs #197894, #199069, #207330, #208606
+ # Disabling XSPF playlists would make startup *very* slow as
+ # all plugins will then have to re-probed each time.
+ econf \
+ --enable-dbus \
+ --enable-xspf \
+ $(use_enable altivec) \
+ $(use_enable chardet) \
+ $(use_enable nls) \
+ $(use_enable session sm) \
+ $(use_enable sse2) \
+ $(use_enable libsamplerate samplerate) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}
+
+pkg_postinst() {
+ elog "Note that you need to recompile *all* third-party plugins for Audacious 2.0"
+ elog "Plugins compiled against 1.X will not be loaded."
+}