summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2006-10-24 21:15:13 +0000
committerTony Vroon <chainsaw@gentoo.org>2006-10-24 21:15:13 +0000
commit613c8a1b37480e3ddcc4bf2b6bed3ebce47ba6f8 (patch)
tree9951ed449f9ee44a481a2ba152580bdabde47ce3 /media-sound/audacious
parentAdded quake3-ra3 to the games-mods quake3 mask. (diff)
downloadgentoo-2-613c8a1b37480e3ddcc4bf2b6bed3ebce47ba6f8.tar.gz
gentoo-2-613c8a1b37480e3ddcc4bf2b6bed3ebce47ba6f8.tar.bz2
gentoo-2-613c8a1b37480e3ddcc4bf2b6bed3ebce47ba6f8.zip
And let nobody say that audacious upstream is slow. The "KDE OMG memleak" from bug #152001 has been resolved. We even bumped the release number for you!
(Portage version: 2.1.2_pre3-r7)
Diffstat (limited to 'media-sound/audacious')
-rw-r--r--media-sound/audacious/ChangeLog9
-rw-r--r--media-sound/audacious/audacious-1.2.1.ebuild54
-rw-r--r--media-sound/audacious/files/digest-audacious-1.2.16
3 files changed, 68 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 70cc41fd5486..03d3baa02177 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.84 2006/10/24 09:56:53 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.85 2006/10/24 21:15:13 chainsaw Exp $
+
+*audacious-1.2.1 (24 Oct 2006)
+
+ 24 Oct 2006; Tony Vroon <chainsaw@gentoo.org> -audacious-1.2.0.ebuild,
+ +audacious-1.2.1.ebuild:
+ And let nobody say that audacious upstream is slow. The KDE OMG memleak from
+ bug #152001 has been resolved. We even bumped the release number for you!
*audacious-1.2.0 (24 Oct 2006)
diff --git a/media-sound/audacious/audacious-1.2.1.ebuild b/media-sound/audacious/audacious-1.2.1.ebuild
new file mode 100644
index 000000000000..3ed2f3cdbf9d
--- /dev/null
+++ b/media-sound/audacious/audacious-1.2.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.2.1.ebuild,v 1.1 2006/10/24 21:15:13 chainsaw Exp $
+
+inherit flag-o-matic
+
+MY_P=${P/_/-}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://audacious-media-player.org/release/${MY_P}.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="chardet nls gnome"
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2.3.1
+ dev-libs/libxml2
+ gnome? ( >=gnome-base/gconf-2.6.0 )"
+
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )
+ >=dev-util/pkgconfig-0.9.0"
+
+PDEPEND=">=media-plugins/audacious-plugins-1.2.2"
+
+src_compile() {
+ # Bug #42893
+ replace-flags "-Os" "-O2"
+ # Bug #86689
+ is-flag "-O*" || append-flags -O
+
+ econf \
+ $(use_enable chardet) \
+ $(use_enable nls) \
+ $(use_enable gnome gconf) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}
diff --git a/media-sound/audacious/files/digest-audacious-1.2.1 b/media-sound/audacious/files/digest-audacious-1.2.1
new file mode 100644
index 000000000000..94e302a31397
--- /dev/null
+++ b/media-sound/audacious/files/digest-audacious-1.2.1
@@ -0,0 +1,6 @@
+MD5 f718f66ec0cab46bf6210d2243d12be1 audacious-1.2.1.tgz 1844989
+RMD160 fc52f845bea32b184ea7f34790c811cff11514f1 audacious-1.2.1.tgz 1844989
+SHA256 8029c23074fde0501ff055cecd3549c96dd28f251c845023973f50573b91f805 audacious-1.2.1.tgz 1844989
+MD5 41eababfa8bad11e9e34e467cdfb86be gentoo_ice-xmms-0.2.tar.bz2 51839
+RMD160 11439cbebf8c6dc5745c8593a79e88303d094544 gentoo_ice-xmms-0.2.tar.bz2 51839
+SHA256 d1be63368b76f4a8b1d5b0e955cd7a77177f56a7f0b828c6603d8fd2836422b1 gentoo_ice-xmms-0.2.tar.bz2 51839