summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2012-12-16 16:58:10 +0000
committerJeff Horelick <jdhore@gentoo.org>2012-12-16 16:58:10 +0000
commite18216a34af61d34529760bfb391c21db57ac2da (patch)
tree9f28a214027a154ce817e56d6cf1595ea7ded8cb /media-sound/audacious
parentStable for x86, wrt bug #311797 (diff)
downloadgentoo-2-e18216a34af61d34529760bfb391c21db57ac2da.tar.gz
gentoo-2-e18216a34af61d34529760bfb391c21db57ac2da.tar.bz2
gentoo-2-e18216a34af61d34529760bfb391c21db57ac2da.zip
Version bump
(Portage version: 2.2.0_alpha149/cvs/Linux i686, signed Manifest commit with key 23E9E900)
Diffstat (limited to 'media-sound/audacious')
-rw-r--r--media-sound/audacious/ChangeLog7
-rw-r--r--media-sound/audacious/audacious-3.3.3.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 81460c577199..ee00943d398d 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.282 2012/10/20 14:47:28 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.283 2012/12/16 16:58:10 jdhore Exp $
+
+*audacious-3.3.3 (16 Dec 2012)
+
+ 16 Dec 2012; Jeff Horelick <jdhore@gentoo.org> +audacious-3.3.3.ebuild:
+ Version bump
*audacious-3.3.2 (20 Oct 2012)
diff --git a/media-sound/audacious/audacious-3.3.3.ebuild b/media-sound/audacious/audacious-3.3.3.ebuild
new file mode 100644
index 000000000000..40d674f21e46
--- /dev/null
+++ b/media-sound/audacious/audacious-3.3.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-3.3.3.ebuild,v 1.1 2012/12/16 16:58:10 jdhore Exp $
+
+EAPI=4
+inherit eutils
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.audacious-media-player.org/${MY_P}.tar.bz2
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux"
+
+IUSE="chardet nls"
+
+RDEPEND=">=dev-libs/dbus-glib-0.60
+ >=dev-libs/glib-2.30
+ dev-libs/libxml2
+ >=x11-libs/cairo-1.2.6
+ >=x11-libs/pango-1.8.0
+ x11-libs/gtk+:3"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ chardet? ( >=app-i18n/libguess-1.1 )
+ nls? ( dev-util/intltool )"
+
+PDEPEND=">=media-plugins/audacious-plugins-3.3"
+
+src_configure() {
+ # D-Bus is a mandatory dependency, remote control,
+ # session management and some plugins depend on this.
+ # Building without D-Bus is *unsupported* and a USE-flag
+ # will not be added due to the bug reports that will result.
+ # Bugs #197894, #199069, #207330, #208606
+ econf \
+ --enable-dbus \
+ $(use_enable chardet) \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+ dodoc AUTHORS
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}