summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-11-29 13:02:12 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-11-29 13:02:12 +0000
commitf85605083f3603bfd7bbeaf69c5f9d0696a24265 (patch)
tree70bda64e925ba0494c2f7bb5dac7bb5815cb9185 /media-sound/audacity
parentMove *sys-devel/sparc32 to the root packages file. (diff)
downloadgentoo-2-f85605083f3603bfd7bbeaf69c5f9d0696a24265.tar.gz
gentoo-2-f85605083f3603bfd7bbeaf69c5f9d0696a24265.tar.bz2
gentoo-2-f85605083f3603bfd7bbeaf69c5f9d0696a24265.zip
Version bump closes bug #72290.
Diffstat (limited to 'media-sound/audacity')
-rw-r--r--media-sound/audacity/ChangeLog8
-rw-r--r--media-sound/audacity/Manifest12
-rw-r--r--media-sound/audacity/audacity-1.2.3.ebuild89
-rw-r--r--media-sound/audacity/files/digest-audacity-1.2.31
4 files changed, 99 insertions, 11 deletions
diff --git a/media-sound/audacity/ChangeLog b/media-sound/audacity/ChangeLog
index 83d43e84a2ff..c3839f54c598 100644
--- a/media-sound/audacity/ChangeLog
+++ b/media-sound/audacity/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/audacity
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.27 2004/10/31 10:37:32 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.28 2004/11/29 13:02:12 eradicator Exp $
+
+*audacity-1.2.3 (29 Nov 2004)
+
+ 29 Nov 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ +audacity-1.2.3.ebuild:
+ Version bump closes bug #72290.
*audacity-1.2.2 (31 Oct 2004)
diff --git a/media-sound/audacity/Manifest b/media-sound/audacity/Manifest
index 6fad004f964e..2927ed7671d8 100644
--- a/media-sound/audacity/Manifest
+++ b/media-sound/audacity/Manifest
@@ -1,17 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 79f1d89e1f30415eaab6846fdbf5afd2 ChangeLog 5696
+MD5 55397049da8bf71d20f78ab5733aff65 audacity-1.2.3.ebuild 2186
MD5 a4b9a9c19045d3e0455e825217505db8 audacity-1.2.1.ebuild 2277
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
MD5 55397049da8bf71d20f78ab5733aff65 audacity-1.2.2.ebuild 2186
+MD5 bf35b35e84d0c0be6fa8e87acf085294 files/digest-audacity-1.2.3 71
MD5 8332a9c72a43ed19ab1904a935a25e03 files/audacity.desktop 155
MD5 8f1e5073472cee2da1987db62e7db3a9 files/digest-audacity-1.2.1 72
MD5 a150eb16468631b07901c6ca01451679 files/digest-audacity-1.2.2 71
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBhMQyArHZZzCEUG0RAv5dAJ9IB30MMSjC18TB57NskO66X0QeiwCdEyxF
-3sqenaRQaZyMUmLjel4ebLU=
-=GHEW
------END PGP SIGNATURE-----
diff --git a/media-sound/audacity/audacity-1.2.3.ebuild b/media-sound/audacity/audacity-1.2.3.ebuild
new file mode 100644
index 000000000000..e30b4bc324c3
--- /dev/null
+++ b/media-sound/audacity/audacity-1.2.3.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.2.3.ebuild,v 1.1 2004/11/29 13:02:12 eradicator Exp $
+
+IUSE="encode flac mad oggvorbis"
+
+MY_PV="${PV/_/-}"
+MY_P="${PN}-src-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A free, crossplatform audio editor."
+HOMEPAGE="http://audacity.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+# Do not unmask on amd64 without talking to eradicator
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=x11-libs/wxGTK-2.2.9
+ >=app-arch/zip-2.3
+ >=media-libs/id3lib-3.8.0
+ media-libs/libid3tag
+ >=media-libs/libsndfile-1.0.0
+ >=media-libs/libsamplerate-0.0.14
+ >=media-libs/ladspa-sdk-1.12
+ flac? ( media-libs/flac )
+ oggvorbis? ( >=media-libs/libvorbis-1.0 )
+ mad? ( >=media-sound/madplay-0.14 )
+ encode? ( >=media-sound/lame-3.92 )"
+
+pkg_setup() {
+ if wx-config --cppflags | grep gtk2u >& /dev/null; then
+ einfo "Audacity will not build if wxGTK was compiled"
+ einfo "with unicode support. If you are using a version of"
+ einfo "wxGTK <= 2.4.2, you must set USE=-gtk2. In newer versions,"
+ einfo "you must set USE=-unicode."
+ die "wxGTK must be re-emerged without unicode suport"
+ fi
+}
+
+src_compile() {
+ local myconf;
+
+ myconf="--with-libsndfile=system --with-id3tag=system"
+
+ # MAD support
+ if use mad; then
+ myconf="${myconf} --with-libmad=system"
+ else
+ myconf="${myconf} --with-libmad=none"
+ fi
+
+ # FLAC support
+ if use flac; then
+ myconf="${myconf} --with-libflac=system"
+ else
+ myconf="${myconf} --with-libflac=none"
+ fi
+
+ # Ogg Vorbis support
+ if use oggvorbis; then
+ myconf="${myconf} --with-vorbis=system"
+ else
+ myconf="${myconf} --with-vorbis=none"
+ fi
+
+ econf ${myconf} || die
+
+ # parallel borks
+ emake -j1 || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ # Install our docs
+ dodoc LICENSE.txt README.txt audacity-1.2-help.htb
+
+ # Remove bad doc install
+ rm -rf ${D}/share/doc
+
+ insinto /usr/share/pixmaps
+ newins images/AudacityLogo48x48.xpm audacity.xpm
+
+ insinto /usr/share/applications
+ doins ${FILESDIR}/audacity.desktop
+}
diff --git a/media-sound/audacity/files/digest-audacity-1.2.3 b/media-sound/audacity/files/digest-audacity-1.2.3
new file mode 100644
index 000000000000..e3ad05e9d285
--- /dev/null
+++ b/media-sound/audacity/files/digest-audacity-1.2.3
@@ -0,0 +1 @@
+MD5 dbfc1b401420aa694753d35acb5a8a28 audacity-src-1.2.3.tar.gz 4175943