summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-02-15 12:47:18 +0000
committerSamuli Suominen <drac@gentoo.org>2008-02-15 12:47:18 +0000
commit91154bd2230ef6af8e00967b5ba802931d30dd40 (patch)
tree2fdb374a337d8999d84e699e3aa27de1404f09e1 /media-sound/audiotag
parentJack is not optional wrt #209298 by Sven Müller. (diff)
downloadgentoo-2-91154bd2230ef6af8e00967b5ba802931d30dd40.tar.gz
gentoo-2-91154bd2230ef6af8e00967b5ba802931d30dd40.tar.bz2
gentoo-2-91154bd2230ef6af8e00967b5ba802931d30dd40.zip
Version bump with fix from bug 209437 for metaflac parameters by Wai Ling.
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-sound/audiotag')
-rw-r--r--media-sound/audiotag/ChangeLog10
-rw-r--r--media-sound/audiotag/audiotag-0.17.ebuild31
-rw-r--r--media-sound/audiotag/files/audiotag-0.17-metaflac-parameters.patch14
3 files changed, 53 insertions, 2 deletions
diff --git a/media-sound/audiotag/ChangeLog b/media-sound/audiotag/ChangeLog
index 7fd6bf7c0e13..965d5698a890 100644
--- a/media-sound/audiotag/ChangeLog
+++ b/media-sound/audiotag/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/audiotag
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audiotag/ChangeLog,v 1.22 2007/07/30 11:08:33 corsair Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audiotag/ChangeLog,v 1.23 2008/02/15 12:47:17 drac Exp $
+
+*audiotag-0.17 (15 Feb 2008)
+
+ 15 Feb 2008; Samuli Suominen <drac@gentoo.org>
+ +files/audiotag-0.17-metaflac-parameters.patch, +audiotag-0.17.ebuild:
+ Version bump with fix from bug 209437 for metaflac parameters by Wai Ling.
30 Jul 2007; Markus Rothe <corsair@gentoo.org> audiotag-0.16.ebuild:
Stable on ppc64; bug #186785
diff --git a/media-sound/audiotag/audiotag-0.17.ebuild b/media-sound/audiotag/audiotag-0.17.ebuild
new file mode 100644
index 000000000000..eec1116b7d28
--- /dev/null
+++ b/media-sound/audiotag/audiotag-0.17.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audiotag/audiotag-0.17.ebuild,v 1.1 2008/02/15 12:47:17 drac Exp $
+
+inherit eutils
+
+DESCRIPTION="a command-line tool for mass tagging/renaming of audio files."
+HOMEPAGE="http://www.tempestgames.com/ryan"
+SRC_URI="http://tempestgames.com/ryan/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="aac flac mp3 vorbis"
+
+RDEPEND="flac? ( media-libs/flac )
+ vorbis? ( media-sound/vorbis-tools )
+ mp3? ( media-libs/id3lib )
+ aac? ( media-video/atomicparsley )"
+DEPEND="dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-metaflac-parameters.patch
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc ChangeLog README
+}
diff --git a/media-sound/audiotag/files/audiotag-0.17-metaflac-parameters.patch b/media-sound/audiotag/files/audiotag-0.17-metaflac-parameters.patch
new file mode 100644
index 000000000000..478e25b9b48a
--- /dev/null
+++ b/media-sound/audiotag/files/audiotag-0.17-metaflac-parameters.patch
@@ -0,0 +1,14 @@
+diff -ur audiotag-0.17.orig/audiotag audiotag-0.17/audiotag
+--- audiotag-0.17.orig/audiotag 2007-09-26 16:02:31.000000000 +0300
++++ audiotag-0.17/audiotag 2008-02-15 14:43:44.000000000 +0200
+@@ -455,8 +455,8 @@
+ foreach (sort { $a cmp $b } keys %$info) {
+ $plus_tags{$_} ||= "===";
+ push @result, "$plus_tags{$_} $_: $info->{$_}";
+- push @cmd, "--remove-vc-field", $_;
+- push @cmd, "--set-vc-field", "$_=$info->{$_}";
++ push @cmd, "--remove-tag", $_;
++ push @cmd, "--set-tag", "$_=$info->{$_}";
+ }
+ push @cmd, $file;
+ }