summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-09-03 10:13:53 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-09-03 10:13:53 +0000
commitb20c40bb12b10d849f91780ea6477487d57c2cfc (patch)
tree91eac5a66393fed2e63b816e06a16d1c9a848158 /media-sound/banshee
parentfix #236417 (diff)
downloadgentoo-2-b20c40bb12b10d849f91780ea6477487d57c2cfc.tar.gz
gentoo-2-b20c40bb12b10d849f91780ea6477487d57c2cfc.tar.bz2
gentoo-2-b20c40bb12b10d849f91780ea6477487d57c2cfc.zip
Add patch for bug 233869. Kudos to Salah Coronya <salahx@yahoo.com>, who produced this.
(Portage version: 2.2_rc8/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'media-sound/banshee')
-rw-r--r--media-sound/banshee/ChangeLog10
-rw-r--r--media-sound/banshee/banshee-1.0.0-r1.ebuild4
-rw-r--r--media-sound/banshee/banshee-1.2.1-r1.ebuild99
-rw-r--r--media-sound/banshee/banshee-1.2.1.ebuild4
-rw-r--r--media-sound/banshee/files/banshee-1.2.1-libmtp-0.3.0-API.patch85
5 files changed, 197 insertions, 5 deletions
diff --git a/media-sound/banshee/ChangeLog b/media-sound/banshee/ChangeLog
index 375791cd7171..7c0c8f4080a8 100644
--- a/media-sound/banshee/ChangeLog
+++ b/media-sound/banshee/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/banshee
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/ChangeLog,v 1.69 2008/08/31 20:39:24 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/ChangeLog,v 1.70 2008/09/03 10:13:52 loki_val Exp $
+
+*banshee-1.2.1-r1 (03 Sep 2008)
+
+ 03 Sep 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/banshee-1.2.1-libmtp-0.3.0-API.patch, banshee-1.0.0-r1.ebuild,
+ banshee-1.2.1.ebuild, +banshee-1.2.1-r1.ebuild:
+ Add patch for bug 233869. Kudos to Salah Coronya <salahx@yahoo.com>, who
+ produced this.
*banshee-1.2.1 (31 Aug 2008)
diff --git a/media-sound/banshee/banshee-1.0.0-r1.ebuild b/media-sound/banshee/banshee-1.0.0-r1.ebuild
index aeb35e0ad6a6..4f520db61c88 100644
--- a/media-sound/banshee/banshee-1.0.0-r1.ebuild
+++ b/media-sound/banshee/banshee-1.0.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/banshee-1.0.0-r1.ebuild,v 1.5 2008/08/02 20:52:44 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/banshee-1.0.0-r1.ebuild,v 1.6 2008/09/03 10:13:52 loki_val Exp $
EAPI=1
@@ -60,7 +60,7 @@ RDEPEND=">=dev-lang/mono-1.2.4
>=media-plugins/gst-plugins-mad-${GVER}
)
mtp? (
- >=media-libs/libmtp-0.2.5-r1
+ <media-libs/libmtp-0.3
)
vorbis? (
>=media-plugins/gst-plugins-ogg-${GVER}
diff --git a/media-sound/banshee/banshee-1.2.1-r1.ebuild b/media-sound/banshee/banshee-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..d4d220964c1f
--- /dev/null
+++ b/media-sound/banshee/banshee-1.2.1-r1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/banshee-1.2.1-r1.ebuild,v 1.1 2008/09/03 10:13:52 loki_val Exp $
+
+EAPI=1
+
+inherit base gnome2 mono
+
+GVER=0.10.3
+
+DESCRIPTION="Import, organize, play, and share your music using a simple and powerful interface."
+HOMEPAGE="http://banshee-project.org"
+SRC_URI="http://download.banshee-project.org/${PN}/${PN}-1-${PV}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+aac +boo daap doc +encode +flac ipod +mad mtp +podcast test +vorbis"
+
+RDEPEND=">=dev-lang/mono-1.2.6
+ >=dev-dotnet/gtk-sharp-2.10
+ >=dev-dotnet/gconf-sharp-2.8
+ >=dev-dotnet/gnome-sharp-2.8
+ >=media-libs/gst-plugins-bad-${GVER}
+ >=media-libs/gst-plugins-good-${GVER}
+ >=media-libs/gst-plugins-ugly-${GVER}
+ >=media-plugins/gst-plugins-alsa-${GVER}
+ >=media-plugins/gst-plugins-gnomevfs-${GVER}
+ >=media-plugins/gst-plugins-gconf-${GVER}
+ || (
+ >=media-plugins/gst-plugins-cdparanoia-${GVER}
+ >=media-plugins/gst-plugins-cdio-${GVER}
+ )
+ media-libs/musicbrainz:1
+ >=dev-dotnet/dbus-glib-sharp-0.3
+ >=dev-dotnet/dbus-sharp-0.5
+ >=dev-dotnet/mono-addins-0.3.1
+ >=dev-dotnet/taglib-sharp-2.0.3
+ >=dev-db/sqlite-3.4
+ aac? (
+ >=media-plugins/gst-plugins-faad-${GVER}
+ )
+ boo? (
+ >=dev-lang/boo-0.8.1
+ )
+ daap? (
+ >=dev-dotnet/mono-zeroconf-0.7.3
+ )
+ doc? (
+ dev-util/monodoc
+ )
+ encode? (
+ >=media-plugins/gst-plugins-lame-${GVER}
+ >=media-plugins/gst-plugins-taglib-${GVER}
+ )
+ flac? (
+ >=media-plugins/gst-plugins-flac-${GVER}
+ )
+ ipod? (
+ >=dev-dotnet/ipod-sharp-0.8.0
+ )
+ mad? (
+ >=media-plugins/gst-plugins-mad-${GVER}
+ )
+ mtp? (
+ >=media-libs/libmtp-0.3
+ )
+ vorbis? (
+ >=media-plugins/gst-plugins-ogg-${GVER}
+ >=media-plugins/gst-plugins-vorbis-${GVER}
+ )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+S=${WORKDIR}/${PN}-1-${PV}
+
+PATCHES=( "${FILESDIR}/${P}-libmtp-0.3.0-API.patch" )
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable doc docs)
+ $(use_enable boo)
+ $(use_enable mtp)
+ $(use_enable daap)
+ $(use_enable ipod)
+ $(use_enable podcast)
+ $(use_enable test tests)"
+
+ MAKEOPTS="${MAKEOPTS} -j1"
+}
+
+src_unpack() {
+ base_src_unpack
+ gnome2_omf_fix
+ elibtoolize
+}
diff --git a/media-sound/banshee/banshee-1.2.1.ebuild b/media-sound/banshee/banshee-1.2.1.ebuild
index f3a1effbb281..ad18498fa6ce 100644
--- a/media-sound/banshee/banshee-1.2.1.ebuild
+++ b/media-sound/banshee/banshee-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/banshee-1.2.1.ebuild,v 1.1 2008/08/31 20:39:24 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/banshee-1.2.1.ebuild,v 1.2 2008/09/03 10:13:52 loki_val Exp $
EAPI=1
@@ -63,7 +63,7 @@ RDEPEND=">=dev-lang/mono-1.2.6
>=media-plugins/gst-plugins-mad-${GVER}
)
mtp? (
- >=media-libs/libmtp-0.2.5-r1
+ <media-libs/libmtp-0.3
)
vorbis? (
>=media-plugins/gst-plugins-ogg-${GVER}
diff --git a/media-sound/banshee/files/banshee-1.2.1-libmtp-0.3.0-API.patch b/media-sound/banshee/files/banshee-1.2.1-libmtp-0.3.0-API.patch
new file mode 100644
index 000000000000..e97766ab166f
--- /dev/null
+++ b/media-sound/banshee/files/banshee-1.2.1-libmtp-0.3.0-API.patch
@@ -0,0 +1,85 @@
+diff -u -r banshee-1-1.2.1.old/src/Libraries/Mtp/Mtp/Album.cs banshee-1-1.2.1/src/Libraries/Mtp/Mtp/Album.cs
+--- banshee-1-1.2.1.old/src/Libraries/Mtp/Mtp/Album.cs 2008-05-21 09:17:47.000000000 -0500
++++ banshee-1-1.2.1/src/Libraries/Mtp/Mtp/Album.cs 2008-09-03 00:57:00.000000000 -0500
+@@ -131,7 +131,7 @@
+ if (saved) {
+ saved = LIBMTP_Update_Album (device.Handle, ref album) == 0;
+ } else {
+- saved = LIBMTP_Create_New_Album (device.Handle, ref album, 0) == 0;
++ saved = LIBMTP_Create_New_Album (device.Handle, ref album) == 0;
+ }
+
+ if (album.tracks != IntPtr.Zero) {
+@@ -190,7 +190,7 @@
+
+ public static Album GetById (MtpDevice device, uint id)
+ {
+- IntPtr ptr = Album.LIBMTP_Get_Album (device.Handle, id);
++ IntPtr ptr = Album.LIBMTP_Get_Album (device.Handle);
+ if (ptr == IntPtr.Zero) {
+ return null;
+ } else {
+@@ -208,10 +208,10 @@
+ internal static extern IntPtr LIBMTP_Get_Album_List (MtpDeviceHandle handle); // LIBMTP_album_t*
+
+ [DllImport("libmtp.dll")]
+- internal static extern IntPtr LIBMTP_Get_Album (MtpDeviceHandle handle, uint albumId); // LIBMTP_album_t*
++ internal static extern IntPtr LIBMTP_Get_Album (MtpDeviceHandle handle); // LIBMTP_album_t*
+
+ [DllImport("libmtp.dll")]
+- internal static extern int LIBMTP_Create_New_Album (MtpDeviceHandle handle, ref AlbumStruct album, uint parentId);
++ internal static extern int LIBMTP_Create_New_Album (MtpDeviceHandle handle, ref AlbumStruct album);
+
+ [DllImport("libmtp.dll")]
+ internal static extern int LIBMTP_Update_Album (MtpDeviceHandle handle, ref AlbumStruct album);
+@@ -221,6 +221,8 @@
+ internal struct AlbumStruct
+ {
+ public uint album_id;
++ public uint parent_id;
++ public uint storage_id;
+
+ [MarshalAs(UnmanagedType.LPStr)]
+ public string name;
+diff -u -r banshee-1-1.2.1.old/src/Libraries/Mtp/Mtp/Folder.cs banshee-1-1.2.1/src/Libraries/Mtp/Mtp/Folder.cs
+--- banshee-1-1.2.1.old/src/Libraries/Mtp/Mtp/Folder.cs 2008-04-07 22:59:11.000000000 -0500
++++ banshee-1-1.2.1/src/Libraries/Mtp/Mtp/Folder.cs 2008-09-03 00:11:53.000000000 -0500
+@@ -210,6 +210,7 @@
+ {
+ public uint folder_id;
+ public uint parent_id;
++ public uint storage_id;
+ [MarshalAs(UnmanagedType.LPStr)] public string name;
+ public IntPtr sibling; // LIBMTP_folder_t*
+ public IntPtr child; // LIBMTP_folder_t*
+diff -u -r banshee-1-1.2.1.old/src/Libraries/Mtp/Mtp/Track.cs banshee-1-1.2.1/src/Libraries/Mtp/Mtp/Track.cs
+--- banshee-1-1.2.1.old/src/Libraries/Mtp/Mtp/Track.cs 2008-04-23 14:20:58.000000000 -0500
++++ banshee-1-1.2.1/src/Libraries/Mtp/Mtp/Track.cs 2008-09-03 00:14:10.000000000 -0500
+@@ -195,7 +195,7 @@
+
+ internal static void SendTrack (MtpDeviceHandle handle, string path, ref TrackStruct metadata, ProgressFunction callback, IntPtr data, uint parent)
+ {
+- if (LIBMTP_Send_Track_From_File (handle, path, ref metadata, callback, data, parent) != 0)
++ if (LIBMTP_Send_Track_From_File (handle, path, ref metadata, callback, data) != 0)
+ {
+ LibMtpException.CheckErrorStack (handle);
+ throw new LibMtpException (ErrorCode.General, "Could not upload the track");
+@@ -227,7 +227,7 @@
+ private static extern int LIBMTP_Get_Track_To_File (MtpDeviceHandle handle, uint trackId, string path, ProgressFunction callback, IntPtr data);
+
+ [DllImport("libmtp.dll")]
+- private static extern int LIBMTP_Send_Track_From_File (MtpDeviceHandle handle, string path, ref TrackStruct track, ProgressFunction callback, IntPtr data, uint parentHandle);
++ private static extern int LIBMTP_Send_Track_From_File (MtpDeviceHandle handle, string path, ref TrackStruct track, ProgressFunction callback, IntPtr data);
+
+ [DllImport("libmtp.dll")]
+ private static extern int LIBMTP_Update_Track_Metadata (MtpDeviceHandle handle, ref TrackStruct metadata);
+@@ -244,7 +244,8 @@
+ {
+ public uint item_id;
+ public uint parent_id;
+-
++ public uint storage_id;
++
+ [MarshalAs(UnmanagedType.LPStr)] public string title;
+ [MarshalAs(UnmanagedType.LPStr)] public string artist;
+ [MarshalAs(UnmanagedType.LPStr)] public string genre;