summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-09-24 06:46:40 +0000
committerMike Frysinger <vapier@gentoo.org>2012-09-24 06:46:40 +0000
commitc845dc7511a16d4880150829e98d3fcd0a1586f3 (patch)
tree7d302f1576b8b17abe3f9a710400e9b82e1a79ee /media-sound/cdtool
parentold (diff)
downloadgentoo-2-c845dc7511a16d4880150829e98d3fcd0a1586f3.tar.gz
gentoo-2-c845dc7511a16d4880150829e98d3fcd0a1586f3.tar.bz2
gentoo-2-c845dc7511a16d4880150829e98d3fcd0a1586f3.zip
Update to EAPI=4, fix HOMEPAGE/SRC_URI, and fix install behavior when /lib is not the native libdir.
(Portage version: 2.2.0_alpha131/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/cdtool')
-rw-r--r--media-sound/cdtool/ChangeLog8
-rw-r--r--media-sound/cdtool/cdtool-2.1.8-r1.ebuild23
2 files changed, 17 insertions, 14 deletions
diff --git a/media-sound/cdtool/ChangeLog b/media-sound/cdtool/ChangeLog
index 72d1fbca20bf..219382e7abfe 100644
--- a/media-sound/cdtool/ChangeLog
+++ b/media-sound/cdtool/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/cdtool
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cdtool/ChangeLog,v 1.23 2010/01/05 03:29:40 josejx Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cdtool/ChangeLog,v 1.24 2012/09/24 06:46:40 vapier Exp $
+
+ 24 Sep 2012; Mike Frysinger <vapier@gentoo.org> cdtool-2.1.8-r1.ebuild:
+ Update to EAPI=4, fix HOMEPAGE/SRC_URI, and fix install behavior when /lib is
+ not the native libdir.
05 Jan 2010; Joseph Jezak <josejx@gentoo.org> cdtool-2.1.8-r1.ebuild:
Marked ppc stable for bug #290197.
diff --git a/media-sound/cdtool/cdtool-2.1.8-r1.ebuild b/media-sound/cdtool/cdtool-2.1.8-r1.ebuild
index e0744b8b9fc6..00755a7d9b5f 100644
--- a/media-sound/cdtool/cdtool-2.1.8-r1.ebuild
+++ b/media-sound/cdtool/cdtool-2.1.8-r1.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cdtool/cdtool-2.1.8-r1.ebuild,v 1.6 2010/01/05 03:29:40 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cdtool/cdtool-2.1.8-r1.ebuild,v 1.7 2012/09/24 06:46:40 vapier Exp $
-EAPI=2
+EAPI="4"
inherit eutils
-DESCRIPTION="Collection of command-line utilities to control cdrom devices."
-HOMEPAGE="http://www.gentoo.org"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
+DESCRIPTION="collection of command-line utilities to control cdrom devices"
+HOMEPAGE="http://hinterhof.net/cdtool/"
+SRC_URI="http://hinterhof.net/cdtool/dist/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -15,13 +15,12 @@ KEYWORDS="amd64 ppc sparc x86"
IUSE=""
RDEPEND="!media-sound/cdplay"
-DEPEND="${RDEPEND}"
src_prepare() {
epatch "${FILESDIR}"/${P}-glibc-2.10.patch
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc CHANGES CREDITS README TODO
+ sed -i \
+ -e '/INSTALL/s:-o root::' \
+ -e '/LINKTARGET/s:/lib/:/$(notdir $(libdir))/:' \
+ -e '/^install-links:/s:$: install-files:' \
+ Makefile.in || die
}