summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-02-13 12:07:27 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-02-13 12:07:27 +0000
commitcce4f074112047629094679df138eb983ee8d828 (patch)
tree4bf3619bf8da6b3daba8c58fae365d20679d8250 /media-sound/cm
parentStable on ppc64; bug #146422 (diff)
downloadgentoo-2-cce4f074112047629094679df138eb983ee8d828.tar.gz
gentoo-2-cce4f074112047629094679df138eb983ee8d828.tar.bz2
gentoo-2-cce4f074112047629094679df138eb983ee8d828.zip
fix emacs support
(Portage version: 2.1.2-r9)
Diffstat (limited to 'media-sound/cm')
-rw-r--r--media-sound/cm/ChangeLog6
-rw-r--r--media-sound/cm/cm-2.10.0.ebuild8
-rw-r--r--media-sound/cm/files/71cm-gentoo.el3
3 files changed, 13 insertions, 4 deletions
diff --git a/media-sound/cm/ChangeLog b/media-sound/cm/ChangeLog
index d768422bf016..1cefa1078ff5 100644
--- a/media-sound/cm/ChangeLog
+++ b/media-sound/cm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/cm
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cm/ChangeLog,v 1.12 2007/02/12 18:54:10 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cm/ChangeLog,v 1.13 2007/02/13 12:07:27 hkbst Exp $
+
+ 13 Feb 2007; Marijn Schouten <hkBst@gentoo.org> +files/71cm-gentoo.el,
+ cm-2.10.0.ebuild:
+ fix emacs support
*cm-2.10.0 (12 Feb 2007)
diff --git a/media-sound/cm/cm-2.10.0.ebuild b/media-sound/cm/cm-2.10.0.ebuild
index 5c4262e82351..4e8173f1b5cf 100644
--- a/media-sound/cm/cm-2.10.0.ebuild
+++ b/media-sound/cm/cm-2.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cm/cm-2.10.0.ebuild,v 1.1 2007/02/12 18:54:10 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cm/cm-2.10.0.ebuild,v 1.2 2007/02/13 12:07:26 hkbst Exp $
inherit elisp-common
@@ -22,13 +22,15 @@ INTERPRETERS="dev-lisp/ecls
dev-scheme/gauche"
DEPEND="|| ( ${COMPILERS} ${INTERPRETERS} )
- emacs? ( virtual/emacs )"
+ emacs? ( virtual/emacs app-emacs/slime )"
RDEPEND="${DEPEND}"
IUSE="doc emacs"
S="${WORKDIR}/${PN}"
+SITEFILE="71cm-gentoo.el"
+
# for easy testing of any implementation
#FORCEIMPL="guile"
FORCEIMPL=""
@@ -103,7 +105,7 @@ src_install() {
if use emacs; then
elisp-install ${PN} etc/xemacs/*.el
- elisp-site-file-install etc/xemacs/cm.el
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
}
diff --git a/media-sound/cm/files/71cm-gentoo.el b/media-sound/cm/files/71cm-gentoo.el
new file mode 100644
index 000000000000..d4f5fefae3fa
--- /dev/null
+++ b/media-sound/cm/files/71cm-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "cm.el")
+(enable-cm-commands) \ No newline at end of file