summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-03-11 04:47:21 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-03-11 04:47:21 +0000
commit6479098a53db002e9b72f0173bb118430e7fbf82 (patch)
tree29db6ca0c0053c00cc03f3736d5d2b487a5355e1 /media-sound/esound
parentStable on sparc. (Manifest recommit) (diff)
downloadgentoo-2-6479098a53db002e9b72f0173bb118430e7fbf82.tar.gz
gentoo-2-6479098a53db002e9b72f0173bb118430e7fbf82.tar.bz2
gentoo-2-6479098a53db002e9b72f0173bb118430e7fbf82.zip
gcc2 patch submitted by Tristan Henderson <T.Henderson@cs.ucl.ac.uk> in bug #44168.
Diffstat (limited to 'media-sound/esound')
-rw-r--r--media-sound/esound/ChangeLog7
-rw-r--r--media-sound/esound/esound-0.2.33.ebuild4
-rw-r--r--media-sound/esound/files/esound-0.2.33-gcc2_fix.patch34
3 files changed, 42 insertions, 3 deletions
diff --git a/media-sound/esound/ChangeLog b/media-sound/esound/ChangeLog
index 5128d92dc56f..7fa582ed276a 100644
--- a/media-sound/esound/ChangeLog
+++ b/media-sound/esound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/esound
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/ChangeLog,v 1.35 2004/03/07 12:12:04 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/ChangeLog,v 1.36 2004/03/11 04:47:21 eradicator Exp $
+
+ 10 Mar 2004; Jeremy Huddleston <eradicator@gentoo.org> esound-0.2.33.ebuild,
+ files/esound-0.2.33-gcc2_fix.patch:
+ gcc2 patch submitted by Tristan Henderson <T.Henderson@cs.ucl.ac.uk> in bug
+ #44168.
*esound-0.2.33 (07 Mar 2004)
diff --git a/media-sound/esound/esound-0.2.33.ebuild b/media-sound/esound/esound-0.2.33.ebuild
index e3a492f9e9ce..61fbca6ac81f 100644
--- a/media-sound/esound/esound-0.2.33.ebuild
+++ b/media-sound/esound/esound-0.2.33.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/esound-0.2.33.ebuild,v 1.2 2004/03/07 12:12:04 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/esound-0.2.33.ebuild,v 1.3 2004/03/11 04:47:21 eradicator Exp $
inherit libtool gnome.org eutils
@@ -22,7 +22,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${PN}-0.2.32-amd64.patch
-
+ epatch ${FILESDIR}/${P}-gcc2_fix.patch
}
src_compile() {
diff --git a/media-sound/esound/files/esound-0.2.33-gcc2_fix.patch b/media-sound/esound/files/esound-0.2.33-gcc2_fix.patch
new file mode 100644
index 000000000000..6c3dcad9a242
--- /dev/null
+++ b/media-sound/esound/files/esound-0.2.33-gcc2_fix.patch
@@ -0,0 +1,34 @@
+diff -Naur esound-0.2.33.orig/audio_alsa09.c esound-0.2.33/audio_alsa09.c
+--- esound-0.2.33.orig/audio_alsa09.c 2004-03-01 13:32:49.000000000 -0500
++++ esound-0.2.33/audio_alsa09.c 2004-03-09 14:43:27.000000000 -0500
+@@ -94,6 +94,10 @@
+ snd_pcm_hw_params_t *hwparams;
+ int err;
+ int periods;
++#ifdef DRIVER_ALSA_09_NEW_PCM_API
++ int t_dir, t_speed;
++ snd_pcm_uframes_t t_bufsize;
++#endif
+
+ err = snd_pcm_open(&handle, dev, mode, SND_PCM_NONBLOCK);
+ if (err < 0) {
+@@ -139,8 +143,8 @@
+ #ifndef DRIVER_ALSA_09_NEW_PCM_API
+ err = snd_pcm_hw_params_set_rate_near(handle, hwparams, speed, 0);
+ #else
+- int t_dir=0;
+- int t_speed=speed;
++ t_dir=0;
++ t_speed=speed;
+ err = snd_pcm_hw_params_set_rate_near(handle, hwparams, &t_speed, &t_dir);
+ #endif
+ if (err < 0) {
+@@ -188,7 +192,7 @@
+ #ifndef DRIVER_ALSA_09_NEW_PCM_API
+ err = snd_pcm_hw_params_set_buffer_size_near(handle, hwparams, BUFFERSIZE);
+ #else
+- snd_pcm_uframes_t t_bufsize=BUFFERSIZE;
++ t_bufsize=BUFFERSIZE;
+ err = snd_pcm_hw_params_set_buffer_size_near(handle, hwparams, &t_bufsize);
+ #endif
+ if (err < 0) {