summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-02 14:49:31 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-02 14:49:31 +0000
commitbe68112c797bf45889d49dcf9b2c31e585785458 (patch)
tree9c9a09a329af7c231113b5dbc8190be262db144e /media-sound/esound
parentNew version, remove _rc (diff)
downloadgentoo-2-be68112c797bf45889d49dcf9b2c31e585785458.tar.gz
gentoo-2-be68112c797bf45889d49dcf9b2c31e585785458.tar.bz2
gentoo-2-be68112c797bf45889d49dcf9b2c31e585785458.zip
gcc2 happy patch
Diffstat (limited to 'media-sound/esound')
-rw-r--r--media-sound/esound/files/esound-0.2.32-new-alsa.patch38
1 files changed, 27 insertions, 11 deletions
diff --git a/media-sound/esound/files/esound-0.2.32-new-alsa.patch b/media-sound/esound/files/esound-0.2.32-new-alsa.patch
index 66d50ee1fb4c..fdbceb35e161 100644
--- a/media-sound/esound/files/esound-0.2.32-new-alsa.patch
+++ b/media-sound/esound/files/esound-0.2.32-new-alsa.patch
@@ -1,5 +1,6 @@
---- acconfig.h-dist 2003-08-01 06:56:21.000000000 -0700
-+++ acconfig.h 2004-01-09 23:01:42.620951280 -0800
+diff -Naur esound-0.2.32.orig/acconfig.h esound-0.2.32/acconfig.h
+--- esound-0.2.32.orig/acconfig.h 2003-08-01 09:56:21.000000000 -0400
++++ esound-0.2.32/acconfig.h 2004-02-02 08:53:54.000000000 -0500
@@ -8,6 +8,7 @@
#undef DRIVER_ALSA
#undef DRIVER_NEWALSA
@@ -8,9 +9,23 @@
#undef DRIVER_DART
#undef DRIVER_COREAUDIO
#undef DRIVER_NONE
---- audio_alsa09.c-dist 2003-03-20 00:34:19.000000000 -0800
-+++ audio_alsa09.c 2004-01-09 23:08:55.405986649 -0800
-@@ -136,15 +136,24 @@
+diff -Naur esound-0.2.32.orig/audio_alsa09.c esound-0.2.32/audio_alsa09.c
+--- esound-0.2.32.orig/audio_alsa09.c 2003-03-20 03:34:19.000000000 -0500
++++ esound-0.2.32/audio_alsa09.c 2004-02-02 08:58:18.000000000 -0500
+@@ -94,7 +94,11 @@
+ snd_pcm_hw_params_t *hwparams;
+ int err;
+ int periods;
+-
++#ifdef DRIVER_ALSA_09_AFTER_RC4
++ int t_dir, t_speed;
++ snd_pcm_uframes_t t_bufsize;
++#endif
++
+ err = snd_pcm_open(&handle, dev, mode, SND_PCM_NONBLOCK);
+ if (err < 0) {
+ if (alsadbg)
+@@ -136,15 +140,24 @@
alsaerr = -1;
return handle;
}
@@ -18,8 +33,8 @@
+#ifndef DRIVER_ALSA_09_AFTER_RC4
err = snd_pcm_hw_params_set_rate_near(handle, hwparams, speed, 0);
+#else
-+ int t_dir=0;
-+ int t_speed=speed;
++ t_dir=0;
++ t_speed=speed;
+ err = snd_pcm_hw_params_set_rate_near(handle, hwparams, &t_speed, &t_dir);
+#endif
if (err < 0) {
@@ -36,7 +51,7 @@
if (alsadbg)
fprintf(stderr, "Rate not avaliable %i != %i\n", speed, err);
alsaerr = -1;
-@@ -176,8 +185,12 @@
+@@ -176,8 +189,12 @@
alsaerr = -1;
return handle;
}
@@ -44,14 +59,15 @@
+#ifndef DRIVER_ALSA_09_AFTER_RC4
err = snd_pcm_hw_params_set_buffer_size_near(handle, hwparams, BUFFERSIZE);
+#else
-+ snd_pcm_uframes_t t_bufsize=BUFFERSIZE;
++ t_bufsize=BUFFERSIZE;
+ err = snd_pcm_hw_params_set_buffer_size_near(handle, hwparams, &t_bufsize);
+#endif
if (err < 0) {
if (alsadbg)
fprintf(stderr, "Buffersize:%s\n", snd_strerror(err));
---- configure.in-dist 2003-09-03 09:23:23.000000000 -0700
-+++ configure.in 2004-01-09 23:50:32.092247517 -0800
+diff -Naur esound-0.2.32.orig/configure.in esound-0.2.32/configure.in
+--- esound-0.2.32.orig/configure.in 2003-09-03 12:23:23.000000000 -0400
++++ esound-0.2.32/configure.in 2004-02-02 08:53:54.000000000 -0500
@@ -269,6 +269,22 @@
AC_CHECK_FUNC(snd_cards,,[AC_CHECK_LIB(sound,snd_cards)])
AC_CHECK_FUNC(snd_cards,,[AC_CHECK_LIB(asound,snd_cards)])