summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-10-12 14:30:46 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-10-12 14:30:46 +0000
commitdf72c758b1eda1c4d26f3b97502157515c7dac9f (patch)
tree3d161675e6955fc4a103995c3c2cd81bf11a0b37 /media-sound/esound
parentA=-fix (diff)
downloadgentoo-2-df72c758b1eda1c4d26f3b97502157515c7dac9f.tar.gz
gentoo-2-df72c758b1eda1c4d26f3b97502157515c7dac9f.tar.bz2
gentoo-2-df72c758b1eda1c4d26f3b97502157515c7dac9f.zip
updated to 0.2.23, thanks alpha for notifying me
Diffstat (limited to 'media-sound/esound')
-rw-r--r--media-sound/esound/esound-0.2.23.ebuild60
-rw-r--r--media-sound/esound/files/digest-esound-0.2.231
2 files changed, 61 insertions, 0 deletions
diff --git a/media-sound/esound/esound-0.2.23.ebuild b/media-sound/esound/esound-0.2.23.ebuild
new file mode 100644
index 000000000000..9225c391ec2a
--- /dev/null
+++ b/media-sound/esound/esound-0.2.23.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/esound-0.2.23.ebuild,v 1.1 2001/10/12 14:30:46 hallski Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="esound"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/esound/${A}
+ ftp://download.sourceforge.net/pub/mirrors/gnome/stable/sources/esound/${A}"
+HOMEPAGE="http://www.tux.org/~ricdude/EsounD.html"
+
+DEPEND="virtual/glibc
+ alsa? ( >=media-libs/alsa-lib-0.5.9 )
+ >=media-libs/audiofile-0.1.9
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+
+RDEPEND="virtual/glibc
+ alsa? ( >=media-libs/alsa-lib-0.5.9 )
+ >=media-libs/audiofile-0.1.9"
+
+src_compile() {
+
+ local myconf
+ if [ "`use tcpd`" ]
+ then
+ myconf="--with-libwrap"
+ else
+ myconf="--without-libwrap"
+ fi
+
+ if [ "`use alsa`" ]
+ then
+ myconf="$myconf --enable-alsa"
+ else
+ myconf="$myconf --enable-alsa=no"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/usr \
+ --sysconfdir=/etc/esd $myconf
+ try pmake
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/usr sysconfdir=${D}/etc/esd install
+ dodoc AUTHORS COPYING* ChangeLog README TODO
+ dodoc NEWS TIPS
+ dodoc docs/esound.ps
+ docinto html
+ dodoc docs/html/*.html docs/html/*.css
+ docinto html/stylesheet-images
+ dodoc docs/html/stylesheet-images/*.gif
+}
+
+
+
+
+
+
diff --git a/media-sound/esound/files/digest-esound-0.2.23 b/media-sound/esound/files/digest-esound-0.2.23
new file mode 100644
index 000000000000..36734704abd6
--- /dev/null
+++ b/media-sound/esound/files/digest-esound-0.2.23
@@ -0,0 +1 @@
+MD5 d68c49951a932fad36727ab6b3ccb457 esound-0.2.23.tar.gz