summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-02 17:42:50 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-02 17:42:50 +0000
commit9139071e8b543538b6b4c3b52f0d9c8fc6978785 (patch)
tree1abae0f5d2a3e98415d19cd9053b7ff3ea0194e1 /media-sound/exaile
parentversion bump. 9999 version now is the same as 0.4.2 (diff)
downloadgentoo-2-9139071e8b543538b6b4c3b52f0d9c8fc6978785.tar.gz
gentoo-2-9139071e8b543538b6b4c3b52f0d9c8fc6978785.tar.bz2
gentoo-2-9139071e8b543538b6b4c3b52f0d9c8fc6978785.zip
Version bump wrt #295542, thanks to Wicher Minnaard for reporting.
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/exaile')
-rw-r--r--media-sound/exaile/ChangeLog10
-rw-r--r--media-sound/exaile/exaile-0.3.1_beta.ebuild70
-rw-r--r--media-sound/exaile/files/exaile-0.3.1_beta-Makefile.patch46
3 files changed, 124 insertions, 2 deletions
diff --git a/media-sound/exaile/ChangeLog b/media-sound/exaile/ChangeLog
index 50199e04e6ab..4a0805a3ff9b 100644
--- a/media-sound/exaile/ChangeLog
+++ b/media-sound/exaile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/exaile
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.63 2009/10/20 14:47:17 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.64 2010/03/02 17:42:49 ssuominen Exp $
+
+*exaile-0.3.1_beta (02 Mar 2010)
+
+ 02 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +exaile-0.3.1_beta.ebuild, +files/exaile-0.3.1_beta-Makefile.patch:
+ Version bump wrt #295542, thanks to Wicher Minnaard for reporting.
*exaile-0.3.0.1 (20 Oct 2009)
diff --git a/media-sound/exaile/exaile-0.3.1_beta.ebuild b/media-sound/exaile/exaile-0.3.1_beta.ebuild
new file mode 100644
index 000000000000..5be6294f9335
--- /dev/null
+++ b/media-sound/exaile/exaile-0.3.1_beta.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.3.1_beta.ebuild,v 1.1 2010/03/02 17:42:49 ssuominen Exp $
+
+EAPI=2
+inherit eutils fdo-mime multilib python
+
+MY_PV=${PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="a media player aiming to be similar to AmaroK, but for GTK+"
+HOMEPAGE="http://www.exaile.org/"
+SRC_URI="http://launchpad.net/exaile/${PV/_beta}/${MY_PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="cddb hal libnotify +libsexy nls"
+
+RDEPEND="dev-python/dbus-python
+ >=media-libs/mutagen-1.10
+ >=dev-python/pygtk-2.14
+ >=dev-lang/python-2.5[sqlite]
+ dev-python/gst-python:0.10
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-meta:0.10
+ libnotify? ( dev-python/notify-python )
+ libsexy? ( dev-python/sexy-python )
+ hal? ( sys-apps/hal )
+ cddb? ( dev-python/cddb-py )"
+DEPEND="nls? ( dev-util/intltool
+ sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+}
+
+src_compile() {
+ if use nls; then
+ emake locale || die
+ fi
+}
+
+src_install() {
+ local _no_locale
+ use nls || _no_locale=_no_locale
+
+ emake PREFIX="/usr" LIBINSTALLDIR="/$(get_libdir)" DESTDIR="${D}" \
+ install${_no_locale} || die
+
+ dodoc README
+
+ insinto /usr/share/exaile/data
+ doins -r data/migrations || die
+}
+
+pkg_postinst() {
+ python_need_rebuild
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/media-sound/exaile/files/exaile-0.3.1_beta-Makefile.patch b/media-sound/exaile/files/exaile-0.3.1_beta-Makefile.patch
new file mode 100644
index 000000000000..757411cdf454
--- /dev/null
+++ b/media-sound/exaile/files/exaile-0.3.1_beta-Makefile.patch
@@ -0,0 +1,46 @@
+--- Makefile.orig 2010-02-06 04:05:48.000000000 +0200
++++ Makefile 2010-03-02 19:45:11.000000000 +0200
+@@ -19,7 +19,7 @@
+ compile:
+ python -m compileall -q xl xlgui
+ -python -O -m compileall -q xl xlgui
+- make -C plugins compile
++ $(MAKE) -C plugins compile
+
+ make-install-dirs:
+ mkdir -p $(DESTDIR)$(PREFIX)/bin
+@@ -55,7 +55,7 @@
+ rm -rf $(EXAILECONFDIR)/exaile
+ rm -f $(DESTDIR)$(PREFIX)/share/applications/exaile.desktop
+ rm -f $(DESTDIR)$(PREFIX)/share/pixmaps/exaile.png
+- make -C plugins uninstall
++ $(MAKE) -C plugins uninstall
+
+ install: install-target install-locale
+
+@@ -104,7 +104,7 @@
+ --datadir=$(PREFIX)/share/exaile/data --startgui \"\$$@\"" \
+ > exaile && \
+ chmod 755 exaile
+- make -C plugins install
++ $(MAKE) -C plugins install
+
+ locale:
+ cd po && find . -name "*.po" -exec ../tools/compilepo.sh {} \; && cd ..
+@@ -119,14 +119,14 @@
+ done
+
+ plugins_dist:
+- make -C plugins dist
++ $(MAKE) -C plugins dist
+
+
+ clean:
+ -find . -name "*.~[0-9]~" -exec rm -f {} \;
+ -find . -name "*.py[co]" -exec rm -f {} \;
+ find po/* -depth -type d -exec rm -r {} \;
+- make -C plugins clean
++ $(MAKE) -C plugins clean
+
+ pot:
+ @echo "[encoding: UTF-8]" > po/POTFILES.in