summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-08-13 09:24:43 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-08-13 09:24:43 +0000
commit8fa6d9f5ff9d3f2830f4cb199f4f5ba6b74db7b7 (patch)
tree16201da113ba85cbb2007f3050228f21f0bfe5b8 /media-sound/fapg/fapg-0.41.ebuild
parentamd64 stable wrt bug #234482 (diff)
downloadgentoo-2-8fa6d9f5ff9d3f2830f4cb199f4f5ba6b74db7b7.tar.gz
gentoo-2-8fa6d9f5ff9d3f2830f4cb199f4f5ba6b74db7b7.tar.bz2
gentoo-2-8fa6d9f5ff9d3f2830f4cb199f4f5ba6b74db7b7.zip
version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'media-sound/fapg/fapg-0.41.ebuild')
-rw-r--r--media-sound/fapg/fapg-0.41.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-sound/fapg/fapg-0.41.ebuild b/media-sound/fapg/fapg-0.41.ebuild
new file mode 100644
index 000000000000..583b917bf6f7
--- /dev/null
+++ b/media-sound/fapg/fapg-0.41.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fapg/fapg-0.41.ebuild,v 1.1 2008/08/13 09:24:43 aballier Exp $
+
+DESCRIPTION="Fast Audio Playlist Generator"
+HOMEPAGE="http://royale.zerezo.com/fapg/"
+SRC_URI="http://royale.zerezo.com/fapg/${P}.tar.gz"
+IUSE="xspf"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+RDEPEND="xspf? ( >=dev-libs/uriparser-0.6.3 )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ local myconf=""
+ use xspf || myconf="${myconf} --disable-xspf"
+ econf ${myconf}
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README
+}