summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-02-14 18:20:17 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-02-14 18:20:17 +0000
commitf420e36b1708d6b555944203a771e1e73945cc27 (patch)
tree3944e36cddfa8a7ef7b4154700e69e557c122250 /media-sound/freqtweak/freqtweak-0.7.0_pre20070214.ebuild
parentversion bump (diff)
downloadgentoo-2-f420e36b1708d6b555944203a771e1e73945cc27.tar.gz
gentoo-2-f420e36b1708d6b555944203a771e1e73945cc27.tar.bz2
gentoo-2-f420e36b1708d6b555944203a771e1e73945cc27.zip
Version bump. CVS snapshot for bug #164153.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'media-sound/freqtweak/freqtweak-0.7.0_pre20070214.ebuild')
-rw-r--r--media-sound/freqtweak/freqtweak-0.7.0_pre20070214.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-sound/freqtweak/freqtweak-0.7.0_pre20070214.ebuild b/media-sound/freqtweak/freqtweak-0.7.0_pre20070214.ebuild
new file mode 100644
index 000000000000..2b999a98dc68
--- /dev/null
+++ b/media-sound/freqtweak/freqtweak-0.7.0_pre20070214.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/freqtweak/freqtweak-0.7.0_pre20070214.ebuild,v 1.1 2007/02/14 18:20:17 dirtyepic Exp $
+
+WX_GTK_VER="2.6"
+
+inherit eutils autotools wxwidgets flag-o-matic
+
+DESCRIPTION="FFT-based realtime audio spectral manipulation and display"
+HOMEPAGE="http://freqtweak.sourceforge.net"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/wxGTK-2.6
+ >=sci-libs/fftw-3.0
+ =dev-libs/libsigc++-1.2*
+ dev-libs/libxml2
+ media-sound/jack-audio-connection-kit"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ eautoreconf
+}
+
+src_compile() {
+ need-wxwidgets gtk2 || die "No gtk2 version of x11-libs/wxGTK found"
+
+ append-flags "-fno-strict-aliasing"
+
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}