summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-12 20:06:01 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-12 20:06:01 +0000
commit61663e056d4494875994f845b9eb78d24b02157c (patch)
tree6d5b146e648bfaf2a2bb3923954e3e913bbbd10c /media-sound/gramofile
parentStable on x86 (#269579) (diff)
downloadgentoo-2-61663e056d4494875994f845b9eb78d24b02157c.tar.gz
gentoo-2-61663e056d4494875994f845b9eb78d24b02157c.tar.bz2
gentoo-2-61663e056d4494875994f845b9eb78d24b02157c.zip
Apply Debian patchset wrt #137756, #131209 and #214442.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/gramofile')
-rw-r--r--media-sound/gramofile/ChangeLog11
-rw-r--r--media-sound/gramofile/files/gramofile-1.6-strlen_and_exit.patch60
-rw-r--r--media-sound/gramofile/files/gramofile-1.6_p3-64bit.patch41
-rw-r--r--media-sound/gramofile/files/gramofile-1.6_p3-implicit-declarations.patch224
-rw-r--r--media-sound/gramofile/gramofile-1.6-r1.ebuild40
-rw-r--r--media-sound/gramofile/gramofile-1.6.ebuild21
-rw-r--r--media-sound/gramofile/gramofile-1.6_p3.ebuild47
7 files changed, 119 insertions, 325 deletions
diff --git a/media-sound/gramofile/ChangeLog b/media-sound/gramofile/ChangeLog
index 2915ab2926ee..714906a9d22b 100644
--- a/media-sound/gramofile/ChangeLog
+++ b/media-sound/gramofile/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/gramofile
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gramofile/ChangeLog,v 1.16 2007/08/19 08:55:05 drac Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gramofile/ChangeLog,v 1.17 2009/05/12 20:06:01 ssuominen Exp $
+
+ 12 May 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +gramofile-1.6-r1.ebuild, -gramofile-1.6_p3.ebuild,
+ +files/gramofile-1.6-strlen_and_exit.patch,
+ -files/gramofile-1.6_p3-64bit.patch,
+ -files/gramofile-1.6_p3-implicit-declarations.patch:
+ Apply Debian patchset wrt #137756, #131209 and #214442.
*gramofile-1.6_p3 (19 Aug 2007)
diff --git a/media-sound/gramofile/files/gramofile-1.6-strlen_and_exit.patch b/media-sound/gramofile/files/gramofile-1.6-strlen_and_exit.patch
new file mode 100644
index 000000000000..0b6c4dcb999d
--- /dev/null
+++ b/media-sound/gramofile/files/gramofile-1.6-strlen_and_exit.patch
@@ -0,0 +1,60 @@
+diff -ur gramofile-1.6.orig/bplaysrc/Makefile gramofile-1.6/bplaysrc/Makefile
+--- gramofile-1.6.orig/bplaysrc/Makefile 2009-05-12 22:39:32.000000000 +0300
++++ gramofile-1.6/bplaysrc/Makefile 2009-05-12 22:45:53.000000000 +0300
+@@ -6,13 +6,12 @@
+ ../clrscr.o ../secshms.o
+ #SRCS = bplay.c sndfunc.o shmbuf.c
+
+-CC = gcc
+-LDFLAGS =
++CC ?= gcc
+
+ ########## CHOOSE YOUR ARCHITECTURE: (NOTE: also see ../Makefile!)
+
+ # For Linux (and maybe others), use these:
+-CFLAGS = -Wall -O2 -DUSEBUFFLOCK -DLP2CD -DVUMETER # -DDEBUG
++CFLAGS += -Wall -DUSEBUFFLOCK -DLP2CD -DVUMETER
+ LIBS = -lncurses
+
+ # For FreeBSD (and maybe others), use these:
+diff -ur gramofile-1.6.orig/gramofile.c gramofile-1.6/gramofile.c
+--- gramofile-1.6.orig/gramofile.c 2009-05-12 22:39:32.000000000 +0300
++++ gramofile-1.6/gramofile.c 2009-05-12 22:41:25.000000000 +0300
+@@ -11,6 +11,7 @@
+ #include "splashscr.h"
+ #include <signal.h>
+ #include <unistd.h>
++#include <stdlib.h>
+ #include <string.h>
+ #ifndef OLD_CURSES
+ #include <ncurses.h>
+diff -ur gramofile-1.6.orig/Makefile gramofile-1.6/Makefile
+--- gramofile-1.6.orig/Makefile 2009-05-12 22:39:32.000000000 +0300
++++ gramofile-1.6/Makefile 2009-05-12 22:45:28.000000000 +0300
+@@ -14,13 +14,12 @@
+ OBJS = $(SRCS:.c=.o)
+ SHELL = /bin/sh
+
+-CC = gcc
+-LDFLAGS =
++CC ?= gcc
+
+ ########## CHOOSE YOUR ARCHITECTURE: (NOTE: also see bplaysrc/Makefile!)
+
+ # For Linux (and maybe others), use these:
+-CFLAGS = -Wall -O2 -funroll-loops -DTURBO_MEDIAN -DTURBO_BUFFER
++CFLAGS += -Wall -DTURBO_MEDIAN -DTURBO_BUFFER
+ DEPS = $(OBJS) makebplay
+ LIBS = -lncurses -lrfftw -lfftw -lm
+ COPY_A = -a
+diff -ur gramofile-1.6.orig/signpr_cmf3.c gramofile-1.6/signpr_cmf3.c
+--- gramofile-1.6.orig/signpr_cmf3.c 2009-05-12 22:39:32.000000000 +0300
++++ gramofile-1.6/signpr_cmf3.c 2009-05-12 22:41:09.000000000 +0300
+@@ -34,6 +34,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <math.h>
++#include <string.h>
+ #ifndef OLD_CURSES
+ #include <ncurses.h>
+ #else
diff --git a/media-sound/gramofile/files/gramofile-1.6_p3-64bit.patch b/media-sound/gramofile/files/gramofile-1.6_p3-64bit.patch
deleted file mode 100644
index 6d127ae1a667..000000000000
--- a/media-sound/gramofile/files/gramofile-1.6_p3-64bit.patch
+++ /dev/null
@@ -1,41 +0,0 @@
---- fmtheaders.h.old 2005-10-08 12:40:53.000000000 +0200
-+++ fmtheaders.h 2005-10-08 12:41:38.000000000 +0200
-@@ -2,6 +2,7 @@
- #define _FMTHEADERS_H 1
-
- #include <sys/types.h>
-+#include <asm/types.h>
-
- /* Definitions for .VOC files */
-
-@@ -62,21 +63,21 @@
- */
- typedef struct wavhead
- {
-- u_long main_chunk; /* 'RIFF' */
-- u_long length; /* Length of rest of file */
-- u_long chunk_type; /* 'WAVE' */
-+ __u32 main_chunk; /* 'RIFF' */
-+ __u32 length; /* Length of rest of file */
-+ __u32 chunk_type; /* 'WAVE' */
-
-- u_long sub_chunk; /* 'fmt ' */
-- u_long sc_len; /* length of sub_chunk, =16 (rest of chunk) */
-+ __u32 sub_chunk; /* 'fmt ' */
-+ __u32 sc_len; /* length of sub_chunk, =16 (rest of chunk) */
- u_short format; /* should be 1 for PCM-code */
- u_short modus; /* 1 Mono, 2 Stereo */
-- u_long sample_fq; /* frequence of sample */
-- u_long byte_p_sec;
-+ __u32 sample_fq; /* frequence of sample */
-+ __u32 byte_p_sec;
- u_short byte_p_spl; /* samplesize; 1 or 2 bytes */
- u_short bit_p_spl; /* 8, 12 or 16 bit */
-
-- u_long data_chunk; /* 'data' */
-- u_long data_length; /* samplecount (lenth of rest of block?) */
-+ __u32 data_chunk; /* 'data' */
-+ __u32 data_length; /* samplecount (lenth of rest of block?) */
- }
- wavhead;
-
diff --git a/media-sound/gramofile/files/gramofile-1.6_p3-implicit-declarations.patch b/media-sound/gramofile/files/gramofile-1.6_p3-implicit-declarations.patch
deleted file mode 100644
index 378f7f894d18..000000000000
--- a/media-sound/gramofile/files/gramofile-1.6_p3-implicit-declarations.patch
+++ /dev/null
@@ -1,224 +0,0 @@
-diff -ur gramofile-1.6P.orig/clrscr.c gramofile-1.6P/clrscr.c
---- gramofile-1.6P.orig/clrscr.c 2000-03-29 00:07:25.000000000 +0300
-+++ gramofile-1.6P/clrscr.c 2007-08-19 11:33:41.000000000 +0300
-@@ -13,7 +13,7 @@
- #else
- #include <curses.h>
- #endif
--
-+#include <string.h>
-
- void
- header (char *headertext)
-diff -ur gramofile-1.6P.orig/errorwindow.c gramofile-1.6P/errorwindow.c
---- gramofile-1.6P.orig/errorwindow.c 2000-11-26 02:55:58.000000000 +0200
-+++ gramofile-1.6P/errorwindow.c 2007-08-19 11:32:53.000000000 +0300
-@@ -20,6 +20,7 @@
- #else
- #include <stdio.h>
- #endif
-+#include <string.h>
-
- void
- error_window_display (char *text, char *buttontext)
-diff -ur gramofile-1.6P.orig/gramofile.c gramofile-1.6P/gramofile.c
---- gramofile-1.6P.orig/gramofile.c 2000-03-29 00:07:25.000000000 +0300
-+++ gramofile-1.6P/gramofile.c 2007-08-19 11:32:24.000000000 +0300
-@@ -12,6 +12,7 @@
- #include <signal.h>
- #include <unistd.h>
- #include <string.h>
-+#include <stdlib.h>
- #ifndef OLD_CURSES
- #include <ncurses.h>
- #else
-diff -ur gramofile-1.6P.orig/mainmenu.c gramofile-1.6P/mainmenu.c
---- gramofile-1.6P.orig/mainmenu.c 2000-03-29 00:07:25.000000000 +0300
-+++ gramofile-1.6P/mainmenu.c 2007-08-19 11:45:08.000000000 +0300
-@@ -21,6 +21,7 @@
- #include "tracksplit.h"
- #include <stdlib.h>
- #include <unistd.h>
-+#include <string.h>
- #ifndef OLD_CURSES
- #include <ncurses.h>
- #else
-Only in gramofile-1.6P.orig/perl-swig: errorwindow.c
-diff -ur gramofile-1.6P.orig/perl-swig/signpr_cmf2.c gramofile-1.6P/perl-swig/signpr_cmf2.c
---- gramofile-1.6P.orig/perl-swig/signpr_cmf2.c 2007-08-19 11:30:54.000000000 +0300
-+++ gramofile-1.6P/perl-swig/signpr_cmf2.c 2007-08-19 11:35:42.000000000 +0300
-@@ -35,6 +35,7 @@
- #include <stdlib.h>
- #include <stdio.h>
- #include <math.h>
-+#include <string.h>
- #ifndef SWIG
- #ifndef OLD_CURSES
- #include <ncurses.h>
-diff -ur gramofile-1.6P.orig/perl-swig/signpr_cmf.c gramofile-1.6P/perl-swig/signpr_cmf.c
---- gramofile-1.6P.orig/perl-swig/signpr_cmf.c 2000-11-26 02:56:00.000000000 +0200
-+++ gramofile-1.6P/perl-swig/signpr_cmf.c 2007-08-19 11:34:23.000000000 +0300
-@@ -33,6 +33,7 @@
- #include <stdlib.h>
- #include <stdio.h>
- #include <math.h>
-+#include <string.h>
- #ifndef SWIG
- #ifndef OLD_CURSES
- #include <ncurses.h>
-diff -ur gramofile-1.6P.orig/perl-swig/signpr_doubmed.c gramofile-1.6P/perl-swig/signpr_doubmed.c
---- gramofile-1.6P.orig/perl-swig/signpr_doubmed.c 2000-11-26 02:56:02.000000000 +0200
-+++ gramofile-1.6P/perl-swig/signpr_doubmed.c 2007-08-19 11:35:08.000000000 +0300
-@@ -19,6 +19,7 @@
- #endif
- #include <stdlib.h>
- #include <stdio.h>
-+#include <string.h>
- #ifndef SWIG
- #ifndef OLD_CURSES
- #include <ncurses.h>
-diff -ur gramofile-1.6P.orig/perl-swig/signpr_mean.c gramofile-1.6P/perl-swig/signpr_mean.c
---- gramofile-1.6P.orig/perl-swig/signpr_mean.c 2000-11-26 02:56:04.000000000 +0200
-+++ gramofile-1.6P/perl-swig/signpr_mean.c 2007-08-19 11:34:54.000000000 +0300
-@@ -19,6 +19,7 @@
- #endif
- #include <stdlib.h>
- #include <stdio.h>
-+#include <string.h>
- #ifndef SWIG
- #ifndef OLD_CURSES
- #include <ncurses.h>
-diff -ur gramofile-1.6P.orig/perl-swig/signpr_median.c gramofile-1.6P/perl-swig/signpr_median.c
---- gramofile-1.6P.orig/perl-swig/signpr_median.c 2000-11-26 02:56:05.000000000 +0200
-+++ gramofile-1.6P/perl-swig/signpr_median.c 2007-08-19 11:34:04.000000000 +0300
-@@ -19,6 +19,7 @@
- #endif
- #include <stdlib.h>
- #include <stdio.h>
-+#include <string.h>
- #ifndef SWIG
- #ifndef OLD_CURSES
- #include <ncurses.h>
-diff -ur gramofile-1.6P.orig/perl-swig/signpr_rms.c gramofile-1.6P/perl-swig/signpr_rms.c
---- gramofile-1.6P.orig/perl-swig/signpr_rms.c 2000-11-26 02:56:05.000000000 +0200
-+++ gramofile-1.6P/perl-swig/signpr_rms.c 2007-08-19 11:36:13.000000000 +0300
-@@ -20,6 +20,7 @@
- #include <stdlib.h>
- #include <stdio.h>
- #include <math.h>
-+#include <string.h>
- #ifndef SWIG
- #ifndef OLD_CURSES
- #include <ncurses.h>
-diff -ur gramofile-1.6P.orig/signpr_cmf2.c gramofile-1.6P/signpr_cmf2.c
---- gramofile-1.6P.orig/signpr_cmf2.c 2007-08-19 11:30:54.000000000 +0300
-+++ gramofile-1.6P/signpr_cmf2.c 2007-08-19 11:35:42.000000000 +0300
-@@ -35,6 +35,7 @@
- #include <stdlib.h>
- #include <stdio.h>
- #include <math.h>
-+#include <string.h>
- #ifndef SWIG
- #ifndef OLD_CURSES
- #include <ncurses.h>
-diff -ur gramofile-1.6P.orig/signpr_cmf3.c gramofile-1.6P/signpr_cmf3.c
---- gramofile-1.6P.orig/signpr_cmf3.c 2007-08-19 11:30:59.000000000 +0300
-+++ gramofile-1.6P/signpr_cmf3.c 2007-08-19 11:36:03.000000000 +0300
-@@ -36,6 +36,7 @@
- #include <stdlib.h>
- #include <stdio.h>
- #include <math.h>
-+#include <string.h>
- #ifndef SWIG
- #ifndef OLD_CURSES
- #include <ncurses.h>
-diff -ur gramofile-1.6P.orig/signpr_cmf.c gramofile-1.6P/signpr_cmf.c
---- gramofile-1.6P.orig/signpr_cmf.c 2000-11-26 02:56:00.000000000 +0200
-+++ gramofile-1.6P/signpr_cmf.c 2007-08-19 11:34:23.000000000 +0300
-@@ -33,6 +33,7 @@
- #include <stdlib.h>
- #include <stdio.h>
- #include <math.h>
-+#include <string.h>
- #ifndef SWIG
- #ifndef OLD_CURSES
- #include <ncurses.h>
-diff -ur gramofile-1.6P.orig/signpr_doubmed.c gramofile-1.6P/signpr_doubmed.c
---- gramofile-1.6P.orig/signpr_doubmed.c 2000-11-26 02:56:02.000000000 +0200
-+++ gramofile-1.6P/signpr_doubmed.c 2007-08-19 11:35:08.000000000 +0300
-@@ -19,6 +19,7 @@
- #endif
- #include <stdlib.h>
- #include <stdio.h>
-+#include <string.h>
- #ifndef SWIG
- #ifndef OLD_CURSES
- #include <ncurses.h>
-diff -ur gramofile-1.6P.orig/signpr_mean.c gramofile-1.6P/signpr_mean.c
---- gramofile-1.6P.orig/signpr_mean.c 2000-11-26 02:56:04.000000000 +0200
-+++ gramofile-1.6P/signpr_mean.c 2007-08-19 11:34:54.000000000 +0300
-@@ -19,6 +19,7 @@
- #endif
- #include <stdlib.h>
- #include <stdio.h>
-+#include <string.h>
- #ifndef SWIG
- #ifndef OLD_CURSES
- #include <ncurses.h>
-diff -ur gramofile-1.6P.orig/signpr_median.c gramofile-1.6P/signpr_median.c
---- gramofile-1.6P.orig/signpr_median.c 2000-11-26 02:56:05.000000000 +0200
-+++ gramofile-1.6P/signpr_median.c 2007-08-19 11:34:04.000000000 +0300
-@@ -19,6 +19,7 @@
- #endif
- #include <stdlib.h>
- #include <stdio.h>
-+#include <string.h>
- #ifndef SWIG
- #ifndef OLD_CURSES
- #include <ncurses.h>
-diff -ur gramofile-1.6P.orig/signpr_rms.c gramofile-1.6P/signpr_rms.c
---- gramofile-1.6P.orig/signpr_rms.c 2000-11-26 02:56:05.000000000 +0200
-+++ gramofile-1.6P/signpr_rms.c 2007-08-19 11:36:13.000000000 +0300
-@@ -20,6 +20,7 @@
- #include <stdlib.h>
- #include <stdio.h>
- #include <math.h>
-+#include <string.h>
- #ifndef SWIG
- #ifndef OLD_CURSES
- #include <ncurses.h>
-diff -ur gramofile-1.6P.orig/stringinput.c gramofile-1.6P/stringinput.c
---- gramofile-1.6P.orig/stringinput.c 2000-03-29 00:07:26.000000000 +0300
-+++ gramofile-1.6P/stringinput.c 2007-08-19 11:33:08.000000000 +0300
-@@ -13,7 +13,7 @@
- #else
- #include <curses.h>
- #endif
--
-+#include <string.h>
-
- void
- stringinput_display (stringinput_t * data)
-diff -ur gramofile-1.6P.orig/tracksplit_parammenu.c gramofile-1.6P/tracksplit_parammenu.c
---- gramofile-1.6P.orig/tracksplit_parammenu.c 2000-03-29 00:07:26.000000000 +0300
-+++ gramofile-1.6P/tracksplit_parammenu.c 2007-08-19 11:35:27.000000000 +0300
-@@ -16,6 +16,7 @@
- #include "helpline.h"
- #include <stdlib.h>
- #include <stdio.h>
-+#include <string.h>
- #ifndef OLD_CURSES
- #include <ncurses.h>
- #else
-diff -ur gramofile-1.6P.orig/yesnowindow.c gramofile-1.6P/yesnowindow.c
---- gramofile-1.6P.orig/yesnowindow.c 2000-03-29 00:07:26.000000000 +0300
-+++ gramofile-1.6P/yesnowindow.c 2007-08-19 11:33:28.000000000 +0300
-@@ -16,7 +16,7 @@
- #else
- #include <curses.h>
- #endif
--
-+#include <string.h>
-
- int
- yesno_window (char *text, char *yestext, char *notext, int preselected)
diff --git a/media-sound/gramofile/gramofile-1.6-r1.ebuild b/media-sound/gramofile/gramofile-1.6-r1.ebuild
new file mode 100644
index 000000000000..146a2dc9db46
--- /dev/null
+++ b/media-sound/gramofile/gramofile-1.6-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gramofile/gramofile-1.6-r1.ebuild,v 1.5 2009/05/12 20:06:01 ssuominen Exp $
+
+EAPI=2
+PATCH_LEVEL=8
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Transfer sound from gramophone records to CD"
+HOMEPAGE="http://www.opensourcepartners.nl/~costar/gramofile"
+SRC_URI="mirror://debian/pool/main/g/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/g/${PN}/${PN}_${PV}-${PATCH_LEVEL}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses
+ sci-libs/fftw:2.1"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${WORKDIR}"/${PN}_${PV}-${PATCH_LEVEL}.diff
+ EPATCH_SUFFIX="dpatch" EPATCH_FORCE="yes" epatch ${P}/debian
+ epatch "${FILESDIR}"/${P}-strlen_and_exit.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed"
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe bplay_gramo brec_gramo || die "doexe failed"
+ dodoc ChangeLog README TODO *.txt
+ newdoc ${P}/debian/changelog ChangeLog.debian
+}
diff --git a/media-sound/gramofile/gramofile-1.6.ebuild b/media-sound/gramofile/gramofile-1.6.ebuild
index 1ef82851ebd5..41654fe51ed8 100644
--- a/media-sound/gramofile/gramofile-1.6.ebuild
+++ b/media-sound/gramofile/gramofile-1.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gramofile/gramofile-1.6.ebuild,v 1.17 2006/02/11 20:31:04 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gramofile/gramofile-1.6.ebuild,v 1.18 2009/05/12 20:06:01 ssuominen Exp $
inherit eutils
@@ -12,26 +12,25 @@ SRC_URI="http://www.opensourcepartners.nl/~costar/${PN}/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="amd64 ~ppc sparc x86"
IUSE=""
-DEPEND="sys-libs/ncurses
+RDEPEND="sys-libs/ncurses
=sci-libs/fftw-2*"
+DEPEND="${RDEPEND}"
src_unpack() {
unpack ${P}.tar.gz
- cd ${S}
- epatch ${DISTDIR}/tappin3a.patch
- epatch ${DISTDIR}/tappin3b.patch
+ cd "${S}"
+ epatch "${DISTDIR}"/tappin3a.patch
+ epatch "${DISTDIR}"/tappin3b.patch
}
src_compile() {
- sed -i -e "s/CFLAGS = -Wall -O2 -DTURBO_MEDIAN -DTURBO_BUFFER/CFLAGS \= -Wall `echo ${CFLAGS}` -DTURBO_MEDIAN -DTURBO_BUFFER/" Makefile
- make || die
+ emake || die "emake failed"
}
src_install() {
- dobin gramofile bplay_gramo brec_gramo
- dodoc Signproc.txt Tracksplit2.txt README ChangeLog TODO
+ dobin gramofile bplay_gramo brec_gramo || die "dobin failed"
+ dodoc ChangeLog README TODO *.txt
}
diff --git a/media-sound/gramofile/gramofile-1.6_p3.ebuild b/media-sound/gramofile/gramofile-1.6_p3.ebuild
deleted file mode 100644
index f1389c43fd23..000000000000
--- a/media-sound/gramofile/gramofile-1.6_p3.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gramofile/gramofile-1.6_p3.ebuild,v 1.1 2007/08/19 08:55:05 drac Exp $
-
-inherit eutils toolchain-funcs
-
-MY_P=${PN}-1.6P
-
-DESCRIPTION="An audio program for analog to digital remastering."
-HOMEPAGE="http://www.opensourcepartners.nl/~costar/gramofile"
-SRC_URI="http://www.opensourcepartners.nl/~costar/${PN}/${MY_P}.tar.gz
- http://www.opensourcepartners.nl/~costar/${PN}/tappin3a.patch
- http://www.opensourcepartners.nl/~costar/${PN}/tappin3c.patch"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE=""
-
-RDEPEND="sys-libs/ncurses
- =sci-libs/fftw-2*"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}"/${MY_P}
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
- cd "${S}"
- epatch "${DISTDIR}"/tappin3a.patch
- epatch "${DISTDIR}"/tappin3c.patch
- epatch "${FILESDIR}"/${P}-64bit.patch
- epatch "${FILESDIR}"/${P}-implicit-declarations.patch
-}
-
-src_compile() {
- # We need the prototype on amd64 or basename defaults to returning int -
- # causint segfault... bug #128378
- sed -i -e "s/-DREDHAT50//" bplaysrc/Makefile
-
- emake CFLAGS="${CFLAGS} -Wall -DTURBO_MEDIAN -DTURBO_BUFFER" \
- CC="$(tc-getCC)" || die "emake failed."
-}
-
-src_install() {
- dobin gramofile bplay_gramo brec_gramo
- dodoc ChangeLog README TODO *.txt
-}