summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-08-19 15:50:18 +0000
committerSamuli Suominen <drac@gentoo.org>2007-08-19 15:50:18 +0000
commit9dd66c9bccacbc80c31a1b15cd4b8054d6f99438 (patch)
tree28170fd87f854278df2a8f94fe360fb90a9de5f7 /media-sound/id3/id3-0.15.ebuild
parentVersion bump (diff)
downloadgentoo-2-9dd66c9bccacbc80c31a1b15cd4b8054d6f99438.tar.gz
gentoo-2-9dd66c9bccacbc80c31a1b15cd4b8054d6f99438.tar.bz2
gentoo-2-9dd66c9bccacbc80c31a1b15cd4b8054d6f99438.zip
Stop pre-stripping id3 binary.
(Portage version: 2.1.3.6)
Diffstat (limited to 'media-sound/id3/id3-0.15.ebuild')
-rw-r--r--media-sound/id3/id3-0.15.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/media-sound/id3/id3-0.15.ebuild b/media-sound/id3/id3-0.15.ebuild
index e8bbe85685dd..a10e18e99702 100644
--- a/media-sound/id3/id3-0.15.ebuild
+++ b/media-sound/id3/id3-0.15.ebuild
@@ -1,24 +1,30 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/id3/id3-0.15.ebuild,v 1.1 2006/11/12 16:02:58 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/id3/id3-0.15.ebuild,v 1.2 2007/08/19 15:50:18 drac Exp $
inherit toolchain-funcs
-IUSE=""
-
DESCRIPTION="changes the id3 tag in an mp3 file"
-HOMEPAGE="http://lly.org/~rcw/abcde/page/"
+HOMEPAGE="http://lly.org/~rcw/abcde/page"
SRC_URI="http://lly.org/~rcw/id3/${PN}_${PV}.orig.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s:-s::" Makefile
+}
src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die "emake failed."
}
src_install() {
- emake install DESTDIR=${D} || die
+ emake DESTDIR="${D}" install || die "emake install failed."
dodoc README
}