summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-05-22 20:24:55 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-05-22 20:24:55 +0000
commitb720ab13d070a0d0918ad257ef9f02360bf7edc9 (patch)
tree98ed83ad04c560b9290ee0d7eaf9cbda1a4052c2 /media-sound/id3v2/id3v2-0.1.7.ebuild
parentMasked the new revision of pppd - need kernel support first. (diff)
downloadgentoo-2-b720ab13d070a0d0918ad257ef9f02360bf7edc9.tar.gz
gentoo-2-b720ab13d070a0d0918ad257ef9f02360bf7edc9.tar.bz2
gentoo-2-b720ab13d070a0d0918ad257ef9f02360bf7edc9.zip
Initial ebuild. Closes bug #1124.
Diffstat (limited to 'media-sound/id3v2/id3v2-0.1.7.ebuild')
-rw-r--r--media-sound/id3v2/id3v2-0.1.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/id3v2/id3v2-0.1.7.ebuild b/media-sound/id3v2/id3v2-0.1.7.ebuild
new file mode 100644
index 000000000000..47e6efdb4a3e
--- /dev/null
+++ b/media-sound/id3v2/id3v2-0.1.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-sound/id3v2/id3v2-0.1.7.ebuild,v 1.1 2002/05/22 20:24:55 agenkin Exp $
+
+DESCRIPTION="A command line editor for id3v2 tags."
+HOMEPAGE="http://id3v2.sourceforge.net/"
+
+DEPEND="media-libs/id3lib"
+
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/id3v2/${P}.tar.gz"
+S=${WORKDIR}/${P}
+
+src_unpack()
+{
+ unpack "${A}"
+ cd "${S}"
+ # The tarball came with a compiled binary. ;^)
+ make clean
+ sed -e "/g++/ s|-g|${CFLAGS}|" < Makefile > Makefile.hacked
+ mv Makefile.hacked Makefile
+}
+
+src_compile()
+{
+ emake || die
+}
+
+src_install ()
+{
+ dobin id3v2
+ doman id3v2.1
+ dodoc COPYING INSTALL README
+}