summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-10-15 09:18:03 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-10-15 09:18:03 +0000
commit361736a36020db667980a77a362a7941f11bb3ba (patch)
tree83d7bae885eb6f919b97334ebac0cd19fbc0f9ae /media-sound/k3guitune
parentDEPEND on arts to make sure that noatun was built with kdemultimedia. (Manife... (diff)
downloadgentoo-2-361736a36020db667980a77a362a7941f11bb3ba.tar.gz
gentoo-2-361736a36020db667980a77a362a7941f11bb3ba.tar.bz2
gentoo-2-361736a36020db667980a77a362a7941f11bb3ba.zip
Added arts as a dependency because you can't build without mcopidl.
Diffstat (limited to 'media-sound/k3guitune')
-rw-r--r--media-sound/k3guitune/ChangeLog5
-rw-r--r--media-sound/k3guitune/files/digest-k3guitune-0.41
-rw-r--r--media-sound/k3guitune/k3guitune-0.4.1.ebuild10
-rw-r--r--media-sound/k3guitune/k3guitune-0.4.ebuild27
4 files changed, 10 insertions, 33 deletions
diff --git a/media-sound/k3guitune/ChangeLog b/media-sound/k3guitune/ChangeLog
index 7a85ac59cd5f..62256de46165 100644
--- a/media-sound/k3guitune/ChangeLog
+++ b/media-sound/k3guitune/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/k3guitune
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/k3guitune/ChangeLog,v 1.6 2004/09/14 16:36:52 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/k3guitune/ChangeLog,v 1.7 2004/10/15 09:18:03 eradicator Exp $
+
+ 15 Oct 2004; Jeremy Huddleston <eradicator@gentoo.org> :
+ Added arts as a dependency because you can't build without mcopidl.
14 Sep 2004; Jeremy Huddleston <eradicator@gentoo.org>
k3guitune-0.4.1.ebuild:
diff --git a/media-sound/k3guitune/files/digest-k3guitune-0.4 b/media-sound/k3guitune/files/digest-k3guitune-0.4
deleted file mode 100644
index ebd7d2b13cb5..000000000000
--- a/media-sound/k3guitune/files/digest-k3guitune-0.4
+++ /dev/null
@@ -1 +0,0 @@
-MD5 d724ed651f377116d08760e571f89cfb k3guitune-0.4.tar.bz2 308322
diff --git a/media-sound/k3guitune/k3guitune-0.4.1.ebuild b/media-sound/k3guitune/k3guitune-0.4.1.ebuild
index 6da88f5e220c..36ed77992646 100644
--- a/media-sound/k3guitune/k3guitune-0.4.1.ebuild
+++ b/media-sound/k3guitune/k3guitune-0.4.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/k3guitune/k3guitune-0.4.1.ebuild,v 1.4 2004/09/14 16:36:52 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/k3guitune/k3guitune-0.4.1.ebuild,v 1.5 2004/10/15 09:18:03 eradicator Exp $
+
+IUSE="alsa oss debug xinerama"
DESCRIPTION="A program for KDE 3 that lets you tune musical instruments."
HOMEPAGE="http://home.planet.nl/~lamer024/k3guitune.html"
@@ -9,19 +11,19 @@ SRC_URI="http://home.planet.nl/~lamer024/files/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc amd64"
-IUSE="alsa arts oss debug xinerama"
DEPEND=">=kde-base/kdelibs-3
+ kde-base/arts
alsa? ( media-libs/alsa-lib )"
src_compile() {
local myconf
- myconf="$(use_enable alsa) $(use_enable arts) $(use_enable oss) $(use_enable debug) $(use_with xinerama)"
+ myconf="$(use_enable alsa) $(use_enable oss) $(use_enable debug) $(use_with xinerama)"
econf ${myconf} || die
emake || die
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
dodoc AUTHORS COPYING ChangeLog INSTALL README TODO
}
diff --git a/media-sound/k3guitune/k3guitune-0.4.ebuild b/media-sound/k3guitune/k3guitune-0.4.ebuild
deleted file mode 100644
index 93c0818ba478..000000000000
--- a/media-sound/k3guitune/k3guitune-0.4.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/k3guitune/k3guitune-0.4.ebuild,v 1.3 2004/08/24 20:09:38 pkdawson Exp $
-
-DESCRIPTION="A program for KDE 3 that lets you tune musical instruments."
-HOMEPAGE="http://home.planet.nl/~lamer024/k3guitune.html"
-SRC_URI="http://home.planet.nl/~lamer024/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="alsa arts oss"
-
-DEPEND=">=kde-base/kdelibs-3
- alsa? ( media-libs/alsa-lib )"
-
-src_compile() {
- local myconf
- myconf="$(use_enable alsa) $(use_enable arts) $(use_enable oss)"
- econf ${myconf} || die
- emake || die
-}
-
-src_install() {
- make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING ChangeLog INSTALL README TODO
-}