summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Shepherd <masterdriverz@gentoo.org>2006-12-09 12:37:48 +0000
committerCharlie Shepherd <masterdriverz@gentoo.org>2006-12-09 12:37:48 +0000
commitac1f6498fae5b70a7604f20fc1d2093fbc24c165 (patch)
tree779744ecfd9a6421c85e4c2bab9878a1f5e666f8 /media-sound/kid3
parentMarked stable on x86. (diff)
downloadgentoo-2-ac1f6498fae5b70a7604f20fc1d2093fbc24c165.tar.gz
gentoo-2-ac1f6498fae5b70a7604f20fc1d2093fbc24c165.tar.bz2
gentoo-2-ac1f6498fae5b70a7604f20fc1d2093fbc24c165.zip
Bump to 0.8.1; thanks to Paolo Pedroni; bug 156020
(Portage version: 2.1.2_rc2-r2)
Diffstat (limited to 'media-sound/kid3')
-rw-r--r--media-sound/kid3/ChangeLog8
-rw-r--r--media-sound/kid3/files/digest-kid3-0.8.13
-rw-r--r--media-sound/kid3/kid3-0.8.1.ebuild34
3 files changed, 44 insertions, 1 deletions
diff --git a/media-sound/kid3/ChangeLog b/media-sound/kid3/ChangeLog
index f9f0f376820e..c70c481ae963 100644
--- a/media-sound/kid3/ChangeLog
+++ b/media-sound/kid3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/kid3
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/ChangeLog,v 1.20 2006/10/05 06:52:28 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/ChangeLog,v 1.21 2006/12/09 12:37:48 masterdriverz Exp $
+
+*kid3-0.8.1 (09 Dec 2006)
+
+ 09 Dec 2006; Charlie Shepherd <masterdriverz@gentoo.org>
+ +kid3-0.8.1.ebuild:
+ Bump to 0.8.1; thanks to Paolo Pedroni; bug 156020
*kid3-0.7 (05 Oct 2006)
diff --git a/media-sound/kid3/files/digest-kid3-0.8.1 b/media-sound/kid3/files/digest-kid3-0.8.1
new file mode 100644
index 000000000000..bf77ebc5b1e0
--- /dev/null
+++ b/media-sound/kid3/files/digest-kid3-0.8.1
@@ -0,0 +1,3 @@
+MD5 df03e94061330e3ec088911727f85059 kid3-0.8.1.tar.gz 871390
+RMD160 6054aa27b2df3aba7c4f5302c1954241710aaa2b kid3-0.8.1.tar.gz 871390
+SHA256 fe922e75078d608df0b69c05b3130c03ffffab226ff1723271bf9dd8f9c3c3ba kid3-0.8.1.tar.gz 871390
diff --git a/media-sound/kid3/kid3-0.8.1.ebuild b/media-sound/kid3/kid3-0.8.1.ebuild
new file mode 100644
index 000000000000..35d72230a5de
--- /dev/null
+++ b/media-sound/kid3/kid3-0.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-0.8.1.ebuild,v 1.1 2006/12/09 12:37:48 masterdriverz Exp $
+
+inherit kde
+
+DESCRIPTION="A simple ID3 tag editor for QT/KDE."
+HOMEPAGE="http://kid3.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kid3/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="flac vorbis"
+
+DEPEND=">=media-libs/id3lib-3.8.3
+ vorbis? ( media-libs/libvorbis )
+ flac? ( media-libs/flac )"
+RDEPEND="${DEPEND}"
+
+need-kde 3
+
+# Support for the KDE libraries is optional,
+# but the configure step that detects them
+# cannot be avoided. So KDE support is forced on.
+
+src_compile() {
+ local myconf="--with-kde
+ $(use_with vorbis)
+ $(use_with flac)
+ --without-musicbrainz"
+
+ kde_src_compile
+}