summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Dawson <pkdawson@gentoo.org>2004-08-26 00:34:50 +0000
committerPatrick Dawson <pkdawson@gentoo.org>2004-08-26 00:34:50 +0000
commitaf13edf46c662cb10023fd610dfc321c803c6f89 (patch)
tree1054d91acf114834e90841cb155106615eded854 /media-sound/kmp
parentpatches made it into upstream (Manifest recommit) (diff)
downloadgentoo-2-af13edf46c662cb10023fd610dfc321c803c6f89.tar.gz
gentoo-2-af13edf46c662cb10023fd610dfc321c803c6f89.tar.bz2
gentoo-2-af13edf46c662cb10023fd610dfc321c803c6f89.zip
gcc34 fix + cleanup
Diffstat (limited to 'media-sound/kmp')
-rw-r--r--media-sound/kmp/ChangeLog5
-rw-r--r--media-sound/kmp/files/kmp-0.01-gcc34.patch12
-rw-r--r--media-sound/kmp/kmp-0.01.ebuild12
3 files changed, 24 insertions, 5 deletions
diff --git a/media-sound/kmp/ChangeLog b/media-sound/kmp/ChangeLog
index eea7053020bf..7797d54bf1e8 100644
--- a/media-sound/kmp/ChangeLog
+++ b/media-sound/kmp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/kmp
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kmp/ChangeLog,v 1.1 2004/08/08 00:40:59 pkdawson Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kmp/ChangeLog,v 1.2 2004/08/26 00:34:50 pkdawson Exp $
+
+ 25 Aug 2004; Patrick Dawson <pkdawson@gentoo.org> kmp-0.01.ebuild :
+ Added a fix for gcc-3.4.
*kmp-0.01 (07 Aug 2004)
diff --git a/media-sound/kmp/files/kmp-0.01-gcc34.patch b/media-sound/kmp/files/kmp-0.01-gcc34.patch
new file mode 100644
index 000000000000..91205f086e81
--- /dev/null
+++ b/media-sound/kmp/files/kmp-0.01-gcc34.patch
@@ -0,0 +1,12 @@
+diff -ur kmp-0.01.orig/linkedlist.h kmp-0.01/linkedlist.h
+--- kmp-0.01.orig/linkedlist.h 2004-08-25 16:05:47.366049280 +0000
++++ kmp-0.01/linkedlist.h 2004-08-25 16:06:16.632600088 +0000
+@@ -121,7 +121,7 @@
+ int linkedList<ItemType>::add(ItemType Item, int location) {
+ node* parent;
+ node* nextspot;
+- if(!find(location, root_, parent)) return 0;
++ if(!find(location, root, parent)) return 0;
+ nextspot = parent->next;
+ parent->next = new node;
+ parent->next->next = nextspot;
diff --git a/media-sound/kmp/kmp-0.01.ebuild b/media-sound/kmp/kmp-0.01.ebuild
index af1a537a3fdb..5abd1dd7a2d5 100644
--- a/media-sound/kmp/kmp-0.01.ebuild
+++ b/media-sound/kmp/kmp-0.01.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kmp/kmp-0.01.ebuild,v 1.1 2004/08/08 00:40:59 pkdawson Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kmp/kmp-0.01.ebuild,v 1.2 2004/08/26 00:34:50 pkdawson Exp $
-inherit eutils
+inherit eutils kde-functions
+
+need-qt 3
DESCRIPTION="An MPD client that uses Qt"
HOMEPAGE="http://www.threadbox.net/kmp.php"
@@ -13,13 +15,15 @@ SLOT="0"
KEYWORDS="~x86"
IUSE=""
-DEPEND=">=x11-libs/qt-3.0"
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/kmp-0.01-gcc34.patch
+}
src_compile() {
echo QMAKE_CFLAGS_RELEASE=${CFLAGS} >> kmp.pro
echo QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS} >> kmp.pro
- addwrite ${QTDIR}/etc/settings
econf || die
emake || die
}