summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-07-26 04:55:07 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-07-26 04:55:07 +0000
commit711e1a21e51398a2a5669164f8bf6c008d5eee43 (patch)
tree9c18139b1f769904dae4e8f0b7d16512e2c42efd /media-sound/lame
parentVersion bump (Manifest recommit) (diff)
downloadgentoo-2-711e1a21e51398a2a5669164f8bf6c008d5eee43.tar.gz
gentoo-2-711e1a21e51398a2a5669164f8bf6c008d5eee43.tar.bz2
gentoo-2-711e1a21e51398a2a5669164f8bf6c008d5eee43.zip
Version bump for upstream bugfix release.
Diffstat (limited to 'media-sound/lame')
-rw-r--r--media-sound/lame/ChangeLog7
-rw-r--r--media-sound/lame/files/digest-lame-3.96.11
-rw-r--r--media-sound/lame/lame-3.96.1.ebuild63
3 files changed, 70 insertions, 1 deletions
diff --git a/media-sound/lame/ChangeLog b/media-sound/lame/ChangeLog
index ffe89cb99b38..31ea78e4262b 100644
--- a/media-sound/lame/ChangeLog
+++ b/media-sound/lame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/lame
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.46 2004/07/26 04:02:57 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.47 2004/07/26 04:55:07 eradicator Exp $
+
+*lame-3.96.1 (25 Jul 2004)
+
+ 25 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> +lame-3.96.1.ebuild:
+ Version bump for upstream bugfix release.
25 Jul 2004; Lina Pezzella <j4rg0n@gentoo.org>
Fixed Manifest.
diff --git a/media-sound/lame/files/digest-lame-3.96.1 b/media-sound/lame/files/digest-lame-3.96.1
new file mode 100644
index 000000000000..658480491ffd
--- /dev/null
+++ b/media-sound/lame/files/digest-lame-3.96.1
@@ -0,0 +1 @@
+MD5 e1206c46a5e276feca11a7149e2fc6ac lame-3.96.1.tar.gz 1255629
diff --git a/media-sound/lame/lame-3.96.1.ebuild b/media-sound/lame/lame-3.96.1.ebuild
new file mode 100644
index 000000000000..f901433a8288
--- /dev/null
+++ b/media-sound/lame/lame-3.96.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.96.1.ebuild,v 1.1 2004/07/26 04:55:07 eradicator Exp $
+
+IUSE="gtk debug"
+
+inherit flag-o-matic gcc eutils
+
+DESCRIPTION="LAME Ain't an Mp3 Encoder"
+HOMEPAGE="http://lame.sourceforge.net"
+SRC_URI="mirror://sourceforge/lame/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64 ~mips"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ gtk? ( =x11-libs/gtk+-1.2* )"
+
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+src_compile() {
+ # take out -fomit-frame-pointer from CFLAGS if k6-2
+ is-flag "-march=k6-3" && filter-flags "-fomit-frame-pointer"
+ is-flag "-march=k6-2" && filter-flags "-fomit-frame-pointer"
+ is-flag "-march=k6" && filter-flags "-fomit-frame-pointer"
+
+ [ "`gcc-fullversion`" == "3.3.2" ] && replace-flags -march=2.0 -march=1.0
+
+ local myconf=""
+ if use gtk; then
+ myconf="${myconf} --enable-mp3x"
+ fi
+
+ # as of 3.95.1 changed from "yes" to "norm" ("alot" is also accepted)
+ use debug \
+ && myconf="${myconf} --enable-debug=norm" \
+ || myconf="${myconf} --enable-debug=no"
+
+ # The user sets compiler optimizations... But if you'd like
+ # lame to choose it's own... uncomment one of these (experiMENTAL)
+ # myconf="${myconf} --enable-expopt=full \
+ # myconf="${myconf} --enable-expopt=norm \
+
+ econf \
+ --enable-shared \
+ `use_enable x86 nasm` \
+ --enable-mp3rtp \
+ ${myconf} || die
+
+ # Parallel make isn't happy
+ emake -j1 || die
+}
+
+src_install() {
+ make DESTDIR="${D}" pkghtmldir="/usr/share/doc/${PF}/html" install || die
+
+ dodoc API ChangeLog HACKING PRESETS.draft README* STYLEGUIDE TODO USAGE
+ dohtml misc/lameGUI.html Dll/LameDLLInterface.htm
+
+ dobin ${S}/misc/mlame
+}