summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-10-21 21:56:10 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-10-21 21:56:10 +0000
commit772c0a96a0060abf21a922760b93f1fad85667d8 (patch)
tree22960c4669a8d70979dcb3dfefca99ee142563c8 /media-sound/lame
parentVersion bump, bug #365179. Thanks to Christopher Robin Elmersson <robin@girlp... (diff)
downloadgentoo-2-772c0a96a0060abf21a922760b93f1fad85667d8.tar.gz
gentoo-2-772c0a96a0060abf21a922760b93f1fad85667d8.tar.bz2
gentoo-2-772c0a96a0060abf21a922760b93f1fad85667d8.zip
Version bump.
(Portage version: 2.2.0_alpha70/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/lame')
-rw-r--r--media-sound/lame/ChangeLog7
-rw-r--r--media-sound/lame/lame-3.99.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/media-sound/lame/ChangeLog b/media-sound/lame/ChangeLog
index 9e23cad68cd1..163c51c6f86c 100644
--- a/media-sound/lame/ChangeLog
+++ b/media-sound/lame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/lame
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.132 2011/07/10 15:09:54 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.133 2011/10/21 21:56:10 ssuominen Exp $
+
+*lame-3.99 (21 Oct 2011)
+
+ 21 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> +lame-3.99.ebuild:
+ Version bump.
10 Jul 2011; Raúl Porcel <armin76@gentoo.org> lame-3.98.4.ebuild:
sh/sparc stable wrt #365273
diff --git a/media-sound/lame/lame-3.99.ebuild b/media-sound/lame/lame-3.99.ebuild
new file mode 100644
index 000000000000..988872ec7c39
--- /dev/null
+++ b/media-sound/lame/lame-3.99.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.99.ebuild,v 1.1 2011/10/21 21:56:10 ssuominen Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="LAME Ain't an MP3 Encoder"
+HOMEPAGE="http://lame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug mmx mp3rtp sndfile static-libs"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ sndfile? ( >=media-libs/libsndfile-1.0.2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ mmx? ( dev-lang/nasm )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-3.96-ccc.patch \
+ "${FILESDIR}"/${PN}-3.98-gtk-path.patch
+
+ mkdir libmp3lame/i386/.libs || die #workaround parallel build with nasm
+
+ sed -i -e '/define sp/s/+/ + /g' libmp3lame/i386/nasm.h || die
+
+ AT_M4DIR=${S} eautoreconf
+ epunt_cxx #74498
+}
+
+src_configure() {
+ local myconf
+ use sndfile && myconf="--with-fileio=sndfile"
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug debug norm) \
+ $(use_enable mmx nasm) \
+ --disable-mp3x \
+ $(use_enable mp3rtp) \
+ --enable-dynamic-frontends \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkghtmldir="${EPREFIX}/usr/share/doc/${PF}/html" install
+ dobin misc/mlame
+
+ dodoc API ChangeLog HACKING README STYLEGUIDE TODO USAGE
+ dohtml misc/lameGUI.html Dll/LameDLLInterface.htm
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}