summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-22 19:03:13 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-22 19:03:13 +0000
commitac0f70d5748c8fa8085c6da51ff4288fe2b57412 (patch)
tree05bb31243f0dd2376b8bfdd26ac887b9cb388e42 /media-sound/lame
parent- keyword ~arm (diff)
downloadgentoo-2-ac0f70d5748c8fa8085c6da51ff4288fe2b57412.tar.gz
gentoo-2-ac0f70d5748c8fa8085c6da51ff4288fe2b57412.tar.bz2
gentoo-2-ac0f70d5748c8fa8085c6da51ff4288fe2b57412.zip
Support stdin and stdout with sndfile wrt #274255, thanks to Naohiro Aota and Jérôme Poulin.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/lame')
-rw-r--r--media-sound/lame/ChangeLog9
-rw-r--r--media-sound/lame/files/lame-3.98.2-get_audio.patch23
-rw-r--r--media-sound/lame/lame-3.98.2-r2.ebuild88
3 files changed, 119 insertions, 1 deletions
diff --git a/media-sound/lame/ChangeLog b/media-sound/lame/ChangeLog
index 63bd2da916a6..26aa812a5cd3 100644
--- a/media-sound/lame/ChangeLog
+++ b/media-sound/lame/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/lame
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.117 2009/06/25 17:30:18 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.118 2009/07/22 19:03:13 ssuominen Exp $
+
+*lame-3.98.2-r2 (22 Jul 2009)
+
+ 22 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +lame-3.98.2-r2.ebuild, +files/lame-3.98.2-get_audio.patch:
+ Support stdin and stdout with sndfile wrt #274255, thanks to Naohiro Aota
+ and Jérôme Poulin.
25 Jun 2009; Raúl Porcel <armin76@gentoo.org> lame-3.98.2-r1.ebuild:
arm/ia64/sh/sparc stable
diff --git a/media-sound/lame/files/lame-3.98.2-get_audio.patch b/media-sound/lame/files/lame-3.98.2-get_audio.patch
new file mode 100644
index 000000000000..7b53b317aa62
--- /dev/null
+++ b/media-sound/lame/files/lame-3.98.2-get_audio.patch
@@ -0,0 +1,23 @@
+--- lame-398-2.orig/frontend/get_audio.c 2009-06-17 00:45:34.000000000 +0900
++++ lame-398-2/frontend/get_audio.c 2009-06-17 00:48:58.000000000 +0900
+@@ -605,12 +605,17 @@
+ }
+ #endif
+ #ifdef HAVE_MPGLIB
+- if ((musicin = fopen(lpszFileName, "rb")) == NULL) {
++ if (!strcmp(lpszFileName, "-")) {
++ lame_set_stream_binary_mode(musicin = stdin); /* Read from standard input. */
++ }
++ else {
++ if ((musicin = fopen(lpszFileName, "rb")) == NULL) {
+ if (silent < 10) {
+- error_printf("Could not find \"%s\".\n", lpszFileName);
++ error_printf("Could not find \"%s\".\n", lpszFileName);
+ }
+ exit(1);
+- }
++ }
++ }
+ if (-1 == lame_decode_initfile(musicin, &mp3input_data, enc_delay, enc_padding)) {
+ if (silent < 10) {
+ error_printf("Error reading headers in mp3 input file %s.\n", lpszFileName);
diff --git a/media-sound/lame/lame-3.98.2-r2.ebuild b/media-sound/lame/lame-3.98.2-r2.ebuild
new file mode 100644
index 000000000000..534f8365b0eb
--- /dev/null
+++ b/media-sound/lame/lame-3.98.2-r2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.98.2-r2.ebuild,v 1.1 2009/07/22 19:03:13 ssuominen Exp $
+
+inherit flag-o-matic toolchain-funcs eutils autotools versionator
+
+DESCRIPTION="LAME Ain't an MP3 Encoder"
+HOMEPAGE="http://lame.sourceforge.net"
+
+MY_PV=$(replace_version_separator 1 '')
+[ ${MY_PV/.} = ${MY_PV} ] || MY_PV=$(replace_version_separator 1 '-' ${MY_PV})
+S=${WORKDIR}/${PN}-${MY_PV}
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug mmx mp3rtp sndfile"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ sndfile? ( >=media-libs/libsndfile-1.0.2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ mmx? ( dev-lang/nasm )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # The frontened tries to link staticly, but we prefer shared libs
+ epatch "${FILESDIR}"/${PN}-3.98-shared-frontend.patch
+
+ # If ccc (alpha compiler) is installed on the system, the default
+ # configure is broken, fix it to respect CC. This is only
+ # directly broken for ARCH=alpha but would affect anybody with a
+ # ccc binary in their PATH. Bug #41908 (26 Jul 2004 agriffis)
+ epatch "${FILESDIR}"/${PN}-3.96-ccc.patch
+
+ # Patch gtk stuff, otherwise eautoreconf dies
+ epatch "${FILESDIR}"/${PN}-3.98-gtk-path.patch
+
+ # Fix for ffmpeg-0.5, bug 265830
+ epatch "${FILESDIR}"/${PN}-3.98.2-ffmpeg-0.5.patch
+
+ # Read and write from std* when sndfile is used
+ epatch "${FILESDIR}"/${PN}-3.98.2-get_audio.patch
+
+ # It fails parallel make otherwise when enabling nasm...
+ mkdir "${S}/libmp3lame/i386/.libs" || die
+
+ AT_M4DIR="${S}" eautoreconf
+ epunt_cxx # embedded bug #74498
+}
+
+src_compile() {
+ use sndfile && myconf="--with-fileio=sndfile"
+ # The user sets compiler optimizations... But if you'd like
+ # lame to choose it's own... uncomment one of these (experiMENTAL)
+ # myconf="${myconf} --enable-expopt=full \
+ # myconf="${myconf} --enable-expopt=norm \
+
+ econf \
+ --enable-shared \
+ $(use_enable debug debug norm) \
+ --disable-mp3x \
+ $(use_enable mmx nasm) \
+ $(use_enable mp3rtp) \
+ ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkghtmldir="/usr/share/doc/${PF}/html" install || die
+
+ dodoc API ChangeLog HACKING README* STYLEGUIDE TODO USAGE || die
+ dohtml misc/lameGUI.html Dll/LameDLLInterface.htm || die
+
+ dobin "${S}"/misc/mlame || die
+}
+
+pkg_postinst(){
+ if use mp3rtp ; then
+ ewarn "Warning, support for the encode-to-RTP program, 'mp3rtp'"
+ ewarn "is broken as of August 2001."
+ ewarn " "
+ fi
+}