summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-02-17 20:07:27 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-02-17 20:07:27 +0000
commit0d81a65395dafe70c03eddeb491ef39436bee9f1 (patch)
treeef70b17b60a6b91477ae4cd5370e4b6b8949ff21 /media-sound/lastfmplayer
parentAdded ~x86 (diff)
downloadgentoo-2-0d81a65395dafe70c03eddeb491ef39436bee9f1.tar.gz
gentoo-2-0d81a65395dafe70c03eddeb491ef39436bee9f1.tar.bz2
gentoo-2-0d81a65395dafe70c03eddeb491ef39436bee9f1.zip
Fixed bug #258862, ebuild clean up
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/lastfmplayer')
-rw-r--r--media-sound/lastfmplayer/ChangeLog11
-rw-r--r--media-sound/lastfmplayer/files/makefile-qt45.patch12
-rw-r--r--media-sound/lastfmplayer/lastfmplayer-1.5.1.31879-r2.ebuild88
3 files changed, 109 insertions, 2 deletions
diff --git a/media-sound/lastfmplayer/ChangeLog b/media-sound/lastfmplayer/ChangeLog
index f81c7694dec1..feb2def4e65b 100644
--- a/media-sound/lastfmplayer/ChangeLog
+++ b/media-sound/lastfmplayer/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/lastfmplayer
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/ChangeLog,v 1.34 2008/12/11 23:32:16 yngwin Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/ChangeLog,v 1.35 2009/02/17 20:07:23 hwoarang Exp $
+
+*lastfmplayer-1.5.1.31879-r2 (17 Feb 2009)
+
+ 17 Feb 2009; Markos Chandras <hwoarang@gentoo.org>
+ +files/makefile-qt45.patch, +lastfmplayer-1.5.1.31879-r2.ebuild:
+ Use EAPI2,fixed doc installation, fixed Qt4 dependencies, fixed bug
+ #258862
*lastfmplayer-1.5.1.31879-r1 (11 Dec 2008)
diff --git a/media-sound/lastfmplayer/files/makefile-qt45.patch b/media-sound/lastfmplayer/files/makefile-qt45.patch
new file mode 100644
index 000000000000..c7db8aca7f09
--- /dev/null
+++ b/media-sound/lastfmplayer/files/makefile-qt45.patch
@@ -0,0 +1,12 @@
+Index: lastfm-1.5.1.31879.dfsg/src/Makefile
+===================================================================
+--- lastfm-1.5.1.31879.dfsg.orig/src/Makefile
++++ lastfm-1.5.1.31879.dfsg/src/Makefile
+@@ -959,6 +959,7 @@ compiler_uic_clean:
+ ../build/ui_playcontrols.h: playcontrols.ui \
+ volumeslider.h
+ /usr/bin/uic playcontrols.ui -o ../build/ui_playcontrols.h
++ sed -i "s/phonon\/Phonon::VolumeSlider/volumeslider.h/" ../build/ui_playcontrols.h
+
+ ../build/ui_failedlogindialog.h: failedlogindialog.ui
+ /usr/bin/uic failedlogindialog.ui -o ../build/ui_failedlogindialog.h
diff --git a/media-sound/lastfmplayer/lastfmplayer-1.5.1.31879-r2.ebuild b/media-sound/lastfmplayer/lastfmplayer-1.5.1.31879-r2.ebuild
new file mode 100644
index 000000000000..51b67efac83e
--- /dev/null
+++ b/media-sound/lastfmplayer/lastfmplayer-1.5.1.31879-r2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/lastfmplayer-1.5.1.31879-r2.ebuild,v 1.1 2009/02/17 20:07:23 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils multilib qt4
+
+MY_P="${P/lastfmplayer/lastfm}.dfsg"
+
+DESCRIPTION="A player for last.fm radio streams"
+HOMEPAGE="http://www.last.fm/help/player"
+SRC_URI="mirror://debian/pool/main/l/lastfm/lastfm_${PV}.dfsg.orig.tar.gz
+ mirror://debian/pool/main/l/lastfm/lastfm_${PV}.dfsg-1.diff.gz"
+#http://cdn.last.fm/client/src/${MY_P}.src.tar.bz2
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ipod"
+RESTRICT="mirror"
+
+RDEPEND="|| ( ( x11-libs/qt-gui:4 x11-libs/qt-sql:4 ) x11-libs/qt:4 )
+ media-libs/libsamplerate
+ sci-libs/fftw
+ media-libs/libmad
+ ipod? ( >=media-libs/libgpod-0.5.2 )
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ app-arch/sharutils"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cd "${WORKDIR}"
+ epatch lastfm_${PV}.dfsg-1.diff
+ cd "${S}"
+ for i in $(< debian/patches/series); do
+ epatch debian/patches/$i
+ done
+ if ! use ipod ; then
+ sed -i '/src\/mediadevices\/ipod/d' LastFM.pro || die "sed failed"
+ fi
+}
+
+src_compile() {
+ emake src/Makefile || die "emake src/Makefile failed"
+ epatch "${FILESDIR}/makefile-qt45.patch"
+ emake || die "emake failed"
+ cd i18n; lrelease *.ts
+}
+
+src_install() {
+ # Docs
+ dodoc ChangeLog README debian/README.source || die "dodoc failed"
+ doman debian/lastfm.1 || die "doman failed"
+
+ # Copied from debian/rules
+ uudecode -o - debian/icons.tar.gz.uu | tar -xzf -
+ uudecode -o - debian/trayicons22.tar.gz.uu | tar -xzf -
+ insinto /usr/share
+ doins -r icons
+ insinto /usr/share/lastfm/icons
+ doins user_*.png
+
+ sed -i -e "s,/usr/lib,/usr/$(get_libdir),g" debian/lastfm.install
+ # make directories
+ for i in $(<debian/lastfm.install); do [ ${i:0:1} == / ] && dodir $i; done
+ # debian installation
+ sed -i -e "s:^:mv :" -e 's: /:${D}/:' debian/lastfm.install
+ bash debian/lastfm.install
+
+ # copied..
+ mv "${D}"/usr/bin/lastfm.sh "${D}"/usr/bin/lastfm
+ fperms 755 /usr/bin/lastfm
+ rm -f "${D}"/usr/share/lastfm/icons/{*profile24,systray_mac}.png
+}
+
+pkg_postinst() {
+ elog "To use the Last.fm player with a mozilla based browser:"
+ elog " 1. Go to about:config in the browser"
+ elog " 2. Right-click on the page"
+ elog " 3. Select New and then String"
+ elog " 4. For the name: network.protocol-handler.app.lastfm"
+ elog " 5. For the value: /usr/bin/lastfm"
+ elog
+ elog "If you experience awkward fonts or widgets, try running qtconfig."
+}