summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-07-26 18:40:36 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-07-26 18:40:36 +0000
commita6d22da9adfc8598dfc6a8c34386e32bee61d8fd (patch)
treef7eabe3b4de06507af919a0b68e0179656d58b54 /media-sound/lilypond
parentAdded ~ppc64; bug #186188 (diff)
downloadgentoo-2-a6d22da9adfc8598dfc6a8c34386e32bee61d8fd.tar.gz
gentoo-2-a6d22da9adfc8598dfc6a8c34386e32bee61d8fd.tar.bz2
gentoo-2-a6d22da9adfc8598dfc6a8c34386e32bee61d8fd.zip
add 2.11.28
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'media-sound/lilypond')
-rw-r--r--media-sound/lilypond/ChangeLog7
-rw-r--r--media-sound/lilypond/files/digest-lilypond-2.11.283
-rw-r--r--media-sound/lilypond/lilypond-2.11.28.ebuild122
3 files changed, 131 insertions, 1 deletions
diff --git a/media-sound/lilypond/ChangeLog b/media-sound/lilypond/ChangeLog
index 9660f3675f8c..58483d9f7d53 100644
--- a/media-sound/lilypond/ChangeLog
+++ b/media-sound/lilypond/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/lilypond
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/ChangeLog,v 1.61 2007/06/27 13:50:04 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/ChangeLog,v 1.62 2007/07/26 18:40:36 hkbst Exp $
+
+*lilypond-2.11.28 (26 Jul 2007)
+
+ 26 Jul 2007; Marijn Schouten <hkBst@gentoo.org> +lilypond-2.11.28.ebuild:
+ add 2.11.28
27 Jun 2007; Marijn Schouten <hkBst@gentoo.org> -lilypond-2.10.25.ebuild,
lilypond-2.10.25-r1.ebuild, -lilypond-2.11.26.ebuild,
diff --git a/media-sound/lilypond/files/digest-lilypond-2.11.28 b/media-sound/lilypond/files/digest-lilypond-2.11.28
new file mode 100644
index 000000000000..2f7187ba6f97
--- /dev/null
+++ b/media-sound/lilypond/files/digest-lilypond-2.11.28
@@ -0,0 +1,3 @@
+MD5 d0bbf0748f955af35ff13c449aa34410 lilypond-2.11.28.tar.gz 3261554
+RMD160 3bdebcaee3b289c783c92b4a6cfff7b54d15547a lilypond-2.11.28.tar.gz 3261554
+SHA256 c08845028b99bc861e0f2185407a05bd67ed7632ed2b38933e1b111b32821518 lilypond-2.11.28.tar.gz 3261554
diff --git a/media-sound/lilypond/lilypond-2.11.28.ebuild b/media-sound/lilypond/lilypond-2.11.28.ebuild
new file mode 100644
index 000000000000..490ec783fae6
--- /dev/null
+++ b/media-sound/lilypond/lilypond-2.11.28.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-2.11.28.ebuild,v 1.1 2007/07/26 18:40:36 hkbst Exp $
+
+inherit eutils versionator toolchain-funcs elisp-common
+
+DESCRIPTION="GNU Music Typesetter"
+SRC_URI="http://download.linuxaudio.org/lilypond/sources/v$(get_version_component_range 1-2)/${P}.tar.gz"
+HOMEPAGE="http://lilypond.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+#LANGS="cs da de es fi fr it ja nl ru rw sv tr zh_TW"
+IUSE="debug emacs profile"
+#IUSE="debug doc emacs gtk profile vim"
+
+#for X in ${LANGS} ; do
+# IUSE="${IUSE} linguas_${X/-/_}"
+#done
+
+# guile with deprecated and regex
+RDEPEND="
+ >=media-libs/freetype-2
+ media-libs/fontconfig
+ >=x11-libs/pango-1.12.3
+ >=dev-scheme/guile-1.8.1
+ >=dev-lang/python-2.4
+ || ( >=app-text/ghostscript-gnu-8.15
+ >=app-text/ghostscript-gpl-8.15
+ >=app-text/ghostscript-esp-8.15 )
+ emacs? ( virtual/emacs )"
+# >=app-text/ghostscript-gnu-8.55"
+
+# virtual/tetex
+
+
+DEPEND="${RDEPEND}
+ >=media-gfx/fontforge-20070501
+ >=app-text/mftrace-1.2.9
+ >=sys-apps/texinfo-4.8
+ sys-devel/make
+ sys-devel/gettext
+ sys-devel/flex
+ dev-lang/perl
+ >=sys-devel/bison-2.0"
+# doc? ( media-libs/netpbm
+# media-gfx/imagemagick )"
+
+pkg_setup() {
+ if has_version =dev-scheme/guile-1.8*; then
+ local flags="deprecated regex"
+ built_with_use dev-scheme/guile ${flags} || die "guile must be built with \"${flags}\" use flags"
+ fi
+}
+
+src_compile() {
+ if [[ $(gcc-major-version) -lt 4 ]]; then
+ eerror "You need GCC 4.x to build this software."
+ die "you need to compile with gcc-4 or later"
+ fi
+
+ econf \
+ $(use_enable debug debugging) \
+ $(use_enable profile profiling) \
+ --disable-gui \
+ --disable-documentation
+# $(use_enable doc documentation) \
+
+
+ # without -j1 it will not fail, but building docs later will
+ emake -j1 || die "emake failed"
+
+# if use doc; then
+# emake -j1 web || die "emake web failed"
+# fi
+
+ if use emacs; then
+ elisp-compile elisp/lilypond-{font-lock,indent,mode,what-beat}.el \
+ || die "elisp-compile failed"
+ fi
+}
+
+# lilypond doesn't include the answers to the tests.
+# You are supposed to build those yourself with an
+# earlier version. Then running tests will compare the
+# results of the tests against the results from the
+# earlier version. As such, tests seem mostly useless
+# for our purposes.
+RESTRICT=test
+
+src_install () {
+ emake DESTDIR=${D} vimdir=/usr/share/vim/vimfiles install || die "emake install failed"
+
+# if use doc; then
+# # Note: installs .html docs, .pdf docs and examples
+# emake out=www web-install DESTDIR=${D} \
+# webdir=/usr/share/doc/${PF}/html || die "emake web-install failed"
+# fi
+
+ # remove elisp files since they are in the wrong directory
+ rm -r "${D}"/usr/share/emacs
+
+ if use emacs; then
+ elisp-install ${PN} elisp/*.{el,elc} elisp/out/*.el \
+ || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
+ fi
+
+ dodoc AUTHORS.txt ChangeLog DEDICATION NEWS.txt README.txt THANKS
+
+# use vim || rm -r ${D}/usr/share/vim
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}