summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-07-29 20:49:39 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-07-29 20:49:39 +0000
commitd5e54b00cf4546af09c6105951e5bee26460f714 (patch)
tree5c35f980fc94aad0cf129e4b5feb6bd699496b61 /media-sound/lilypond
parentThere's no package called alsa-patch-bay in portage anymore. (diff)
downloadgentoo-2-d5e54b00cf4546af09c6105951e5bee26460f714.tar.gz
gentoo-2-d5e54b00cf4546af09c6105951e5bee26460f714.tar.bz2
gentoo-2-d5e54b00cf4546af09c6105951e5bee26460f714.zip
Fix build w/ glibc-2.10. (bug #270718)
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/lilypond')
-rw-r--r--media-sound/lilypond/ChangeLog6
-rw-r--r--media-sound/lilypond/files/lilypond-2.12.2-glibc-2.10.patch21
-rw-r--r--media-sound/lilypond/lilypond-2.12.2.ebuild8
3 files changed, 33 insertions, 2 deletions
diff --git a/media-sound/lilypond/ChangeLog b/media-sound/lilypond/ChangeLog
index 2280fe5e3a90..f0ff00ae7752 100644
--- a/media-sound/lilypond/ChangeLog
+++ b/media-sound/lilypond/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/lilypond
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/ChangeLog,v 1.97 2009/05/26 05:56:51 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/ChangeLog,v 1.98 2009/07/29 20:49:39 dirtyepic Exp $
+
+ 29 Jul 2009; Ryan Hill <dirtyepic@gentoo.org> lilypond-2.12.2.ebuild,
+ +files/lilypond-2.12.2-glibc-2.10.patch:
+ Fix build w/ glibc-2.10. (bug #270718)
26 May 2009; Peter Volkov <pva@gentoo.org> lilypond-2.10.33.ebuild,
lilypond-2.11.50.ebuild, lilypond-2.11.51.ebuild, lilypond-2.11.52.ebuild,
diff --git a/media-sound/lilypond/files/lilypond-2.12.2-glibc-2.10.patch b/media-sound/lilypond/files/lilypond-2.12.2-glibc-2.10.patch
new file mode 100644
index 000000000000..d1e34087881d
--- /dev/null
+++ b/media-sound/lilypond/files/lilypond-2.12.2-glibc-2.10.patch
@@ -0,0 +1,21 @@
+diff -Naurp lilypond-2.12.2-orig/lily/relocate.cc lilypond-2.12.2/lily/relocate.cc
+--- lilypond-2.12.2-orig/lily/relocate.cc 2009-01-18 18:04:57.000000000 -0600
++++ lilypond-2.12.2/lily/relocate.cc 2009-07-29 14:31:12.908541341 -0600
+@@ -276,13 +276,13 @@ expand_environment_variables (string ori
+ string out;
+ while (ptr < start_ptr + len)
+ {
+- char *dollar = strchr (ptr, '$');
++ const char *dollar = strchr (ptr, '$');
+
+ if (dollar != NULL)
+ {
+- char *start_var = dollar + 1;
+- char *end_var = start_var;
+- char *start_next = end_var;
++ const char *start_var = dollar + 1;
++ const char *end_var = start_var;
++ const char *start_next = end_var;
+
+ out += string (ptr, dollar - ptr);
+ ptr = dollar;
diff --git a/media-sound/lilypond/lilypond-2.12.2.ebuild b/media-sound/lilypond/lilypond-2.12.2.ebuild
index 41612c7130f3..b4547bc1e90f 100644
--- a/media-sound/lilypond/lilypond-2.12.2.ebuild
+++ b/media-sound/lilypond/lilypond-2.12.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-2.12.2.ebuild,v 1.2 2009/05/26 05:56:51 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-2.12.2.ebuild,v 1.3 2009/07/29 20:49:39 dirtyepic Exp $
inherit eutils versionator toolchain-funcs elisp-common
@@ -53,6 +53,12 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+}
+
src_compile() {
if [[ $(gcc-major-version) -lt 4 ]]; then
eerror "You need GCC 4.x to build this software."