summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-03-17 10:53:37 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-03-17 10:53:37 +0000
commit9d7769b8d31afbb1468122578d1b9dbd9ad1464e (patch)
tree1bb82d172d42996bcdad36034f893230c4fa81e2 /media-sound/lmms
parentfix hard blocker on mongo-3.0.0 (diff)
downloadgentoo-2-9d7769b8d31afbb1468122578d1b9dbd9ad1464e.tar.gz
gentoo-2-9d7769b8d31afbb1468122578d1b9dbd9ad1464e.tar.bz2
gentoo-2-9d7769b8d31afbb1468122578d1b9dbd9ad1464e.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-sound/lmms')
-rw-r--r--media-sound/lmms/ChangeLog9
-rw-r--r--media-sound/lmms/lmms-1.1.3.ebuild66
2 files changed, 73 insertions, 2 deletions
diff --git a/media-sound/lmms/ChangeLog b/media-sound/lmms/ChangeLog
index 179bdabb65e2..b343780af504 100644
--- a/media-sound/lmms/ChangeLog
+++ b/media-sound/lmms/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/lmms
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lmms/ChangeLog,v 1.36 2014/07/29 16:06:31 polynomial-c Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lmms/ChangeLog,v 1.37 2015/03/17 10:53:37 aballier Exp $
+
+*lmms-1.1.3 (17 Mar 2015)
+
+ 17 Mar 2015; Alexis Ballier <aballier@gentoo.org> +lmms-1.1.3.ebuild:
+ version bump
*lmms-1.0.3 (29 Jul 2014)
diff --git a/media-sound/lmms/lmms-1.1.3.ebuild b/media-sound/lmms/lmms-1.1.3.ebuild
new file mode 100644
index 000000000000..88193cc5dd0c
--- /dev/null
+++ b/media-sound/lmms/lmms-1.1.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lmms/lmms-1.1.3.ebuild,v 1.1 2015/03/17 10:53:37 aballier Exp $
+
+EAPI=5
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Free alternative to popular programs such as Fruityloops, Cubase and Logic"
+HOMEPAGE="http://lmms.sourceforge.net/"
+SRC_URI="https://github.com/LMMS/lmms/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="alsa debug fluidsynth jack ogg portaudio pulseaudio sdl stk vst"
+
+RDEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4[accessibility]
+ >=media-libs/libsamplerate-0.1.8
+ >=media-libs/libsndfile-1.0.11
+ sci-libs/fftw:3.0
+ sys-libs/zlib
+ >=x11-libs/fltk-1.3.0_rc3:1
+ alsa? ( media-libs/alsa-lib )
+ fluidsynth? ( media-sound/fluidsynth )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.99.0 )
+ ogg? ( media-libs/libvorbis
+ media-libs/libogg )
+ portaudio? ( >=media-libs/portaudio-19_pre )
+ pulseaudio? ( media-sound/pulseaudio )
+ sdl? ( media-libs/libsdl
+ >=media-libs/sdl-sound-1.0.1 )
+ stk? ( media-libs/stk )
+ vst? ( app-emulation/wine )"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.5"
+RDEPEND="${RDEPEND}
+ media-plugins/swh-plugins
+ media-plugins/caps-plugins
+ media-plugins/tap-plugins
+ media-libs/ladspa-cmt"
+
+DOCS="README AUTHORS TODO"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ -DWANT_SYSTEM_SR=TRUE
+ -DWANT_CAPS=FALSE
+ -DWANT_TAP=FALSE
+ -DWANT_SWH=FALSE
+ -DWANT_CMT=FALSE
+ -DWANT_CALF=TRUE
+ -DCMAKE_INSTALL_LIBDIR=$(get_libdir)
+ $(cmake-utils_use_want alsa ALSA)
+ $(cmake-utils_use_want jack JACK)
+ $(cmake-utils_use_want ogg OGGVORBIS)
+ $(cmake-utils_use_want portaudio PORTAUDIO)
+ $(cmake-utils_use_want pulseaudio PULSEAUDIO)
+ $(cmake-utils_use_want sdl SDL)
+ $(cmake-utils_use_want stk STK)
+ $(cmake-utils_use_want vst VST)
+ $(cmake-utils_use_want fluidsynth SF2)"
+ cmake-utils_src_configure
+}