summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-11-10 11:29:36 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-11-10 11:29:36 +0000
commitba53db3f4c628ef6518af045541eb9ec77bc6464 (patch)
tree45207a1ebf1fe0122e77452cc02856d719eeac2f /media-sound/lmms
parentia64 stable wrt #239130 (diff)
downloadgentoo-2-ba53db3f4c628ef6518af045541eb9ec77bc6464.tar.gz
gentoo-2-ba53db3f4c628ef6518af045541eb9ec77bc6464.tar.bz2
gentoo-2-ba53db3f4c628ef6518af045541eb9ec77bc6464.zip
version bump, by Thomas 'gimpel' Kuther, bug #246150
(Portage version: 2.2_rc13/cvs/Linux 2.6.27.5 x86_64)
Diffstat (limited to 'media-sound/lmms')
-rw-r--r--media-sound/lmms/ChangeLog7
-rw-r--r--media-sound/lmms/lmms-0.4.0.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/media-sound/lmms/ChangeLog b/media-sound/lmms/ChangeLog
index cc29b22abf56..e54e94be1454 100644
--- a/media-sound/lmms/ChangeLog
+++ b/media-sound/lmms/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/lmms
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lmms/ChangeLog,v 1.3 2008/10/02 17:58:43 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lmms/ChangeLog,v 1.4 2008/11/10 11:29:36 aballier Exp $
+
+*lmms-0.4.0 (10 Nov 2008)
+
+ 10 Nov 2008; Alexis Ballier <aballier@gentoo.org> +lmms-0.4.0.ebuild:
+ version bump, by Thomas 'gimpel' Kuther, bug #246150
02 Oct 2008; Alexis Ballier <aballier@gentoo.org> lmms-0.4.0_rc2.ebuild:
We need qt4 with the accessibility useflag turned on, bug #239294, fix by
diff --git a/media-sound/lmms/lmms-0.4.0.ebuild b/media-sound/lmms/lmms-0.4.0.ebuild
new file mode 100644
index 000000000000..6fed2234bb77
--- /dev/null
+++ b/media-sound/lmms/lmms-0.4.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lmms/lmms-0.4.0.ebuild,v 1.1 2008/11/10 11:29:36 aballier Exp $
+
+EAPI="2"
+
+inherit eutils cmake-utils
+
+DESCRIPTION="free alternative to popular programs such as Fruityloops, Cubase and Logic"
+HOMEPAGE="http://lmms.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="alsa debug fftw fluidsynth jack ogg pulseaudio sdl stk vst"
+#portaudio: disabled upstream
+
+RDEPEND="|| ( (
+ x11-libs/qt-core
+ x11-libs/qt-gui[accessibility]
+ ) >=x11-libs/qt-4.3.0:4[accessibility] )
+ >=media-libs/libsndfile-1.0.11
+ media-libs/libsamplerate
+ alsa? ( media-libs/alsa-lib )
+ fftw? ( =sci-libs/fftw-3* )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.99.0 )
+ ogg? ( media-libs/libvorbis
+ media-libs/libogg )
+ fluidsynth? ( media-sound/fluidsynth )
+ pulseaudio? ( media-sound/pulseaudio )
+ sdl? ( media-libs/libsdl
+ >=media-libs/sdl-sound-1.0.1 )
+ stk? ( media-libs/stk )
+ vst? ( app-emulation/wine )"
+# portaudio? ( media-libs/portaudio )
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.5"
+
+DOCS="README AUTHORS ChangeLog TODO"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ -DWANT_SYSTEM_SR=TRUE
+ -DWANT_CAPS=TRUE
+ -DWANT_TAP=TRUE
+ $(cmake-utils_use_want alsa ALSA)
+ $(cmake-utils_use_want fftw FFTW3F)
+ $(cmake-utils_use_want jack JACK)
+ $(cmake-utils_use_want ogg OGGVORBIS)
+ $(cmake-utils_use_want pulseaudio PULSEAUDIO)
+ $(cmake-utils_use_want sdl SDL)
+ $(cmake-utils_use_want stk STK)
+ $(cmake-utils_use_want vst VST)
+ $(cmake-utils_use_want fluidsynth SF2)"
+ #$(cmake-utils_use_want portaudio PORTAUDIO)
+ cmake-utils_src_configure
+}