summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2003-08-18 10:57:49 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2003-08-18 10:57:49 +0000
commit938588e57c3546d785f79f36600ab938f301b62f (patch)
tree320a9648753fe7e596e9c153f5343cee3b072ea5 /media-sound/madplay/madplay-0.15.0b-r1.ebuild
parentAlsa is broken. Removed alsa code from the ebuild. See bug #25783 (diff)
downloadgentoo-2-938588e57c3546d785f79f36600ab938f301b62f.tar.gz
gentoo-2-938588e57c3546d785f79f36600ab938f301b62f.tar.bz2
gentoo-2-938588e57c3546d785f79f36600ab938f301b62f.zip
Alsa is broken. Removed alsa code from the ebuild. See bug #25783
Diffstat (limited to 'media-sound/madplay/madplay-0.15.0b-r1.ebuild')
-rw-r--r--media-sound/madplay/madplay-0.15.0b-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-sound/madplay/madplay-0.15.0b-r1.ebuild b/media-sound/madplay/madplay-0.15.0b-r1.ebuild
new file mode 100644
index 000000000000..49aaa5f53ad3
--- /dev/null
+++ b/media-sound/madplay/madplay-0.15.0b-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/madplay/madplay-0.15.0b-r1.ebuild,v 1.1 2003/08/18 10:57:45 g2boojum Exp $
+
+IUSE="debug nls"
+
+DESCRIPTION="The MAD audio player"
+HOMEPAGE="http://mad.sourceforge.net"
+SRC_URI="mirror://sourceforge/mad/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa"
+
+DEPEND="virtual/glibc
+ ~media-libs/libmad-${PV}
+ ~media-libs/libid3tag-${PV}
+ nls? ( >=sys-devel/gettext-0.11.2 )"
+
+src_compile() {
+ local myconf
+
+ myconf="--with-gnu-ld"
+ # --enable-profiling generate profiling code
+ # --enable-experimental enable experimental code
+ # --with-esd use Enlightened Sound Daemon (EsounD)
+ # as default
+
+ use debug && myconf="${myconf} --enable-debugging" \
+ || myconf="${myconf} --disable-debugging"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+
+ dodoc CHANGES COPYRIGHT CREDITS README TODO VERSION
+}