summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-10-16 23:26:38 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-10-16 23:26:38 +0000
commit57d9ba69868a06b9c97081c330dafea838a62d28 (patch)
tree0defdce4564fece67d7210496b0412798f98fdcd /media-sound/mpc/mpc-0.11.2-r1.ebuild
parentversion bump (diff)
downloadgentoo-2-57d9ba69868a06b9c97081c330dafea838a62d28.tar.gz
gentoo-2-57d9ba69868a06b9c97081c330dafea838a62d28.tar.bz2
gentoo-2-57d9ba69868a06b9c97081c330dafea838a62d28.zip
Added nls USE flag to the ebuild and --disable-dependency-tracking to econf. Closes bug #108822, reported by Natanael Copa <natanael.copa at gmail.com>.
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'media-sound/mpc/mpc-0.11.2-r1.ebuild')
-rw-r--r--media-sound/mpc/mpc-0.11.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-sound/mpc/mpc-0.11.2-r1.ebuild b/media-sound/mpc/mpc-0.11.2-r1.ebuild
new file mode 100644
index 000000000000..daa5a4442030
--- /dev/null
+++ b/media-sound/mpc/mpc-0.11.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpc/mpc-0.11.2-r1.ebuild,v 1.1 2005/10/16 23:26:38 ticho Exp $
+
+inherit bash-completion
+
+DESCRIPTION="A commandline client for Music Player Daemon (media-sound/mpd)"
+SRC_URI="mirror://sourceforge/musicpd/${P}.tar.gz http://mercury.chem.pitt.edu/~shank/${P}.tar.gz"
+HOMEPAGE="http://www.musicpd.org"
+IUSE="nls"
+
+KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~hppa"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/libc
+ nls? ( || ( sys-libs/glibc dev-libs/libiconv ) )"
+
+src_compile() {
+ econf --disable-dependency-tracking \
+ $(use_enable nls iconv) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ mv ${D}/usr/share/doc/mpc/ ${D}/usr/share/doc/${PF}
+
+ dobashcompletion doc/mpc-bashrc
+}