summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-10-16 21:11:44 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-10-16 21:11:44 +0000
commit68c6cb6c8a20400ed7d9b4777f3f28a906eda64c (patch)
treebd8a9362040a46e9e3b6459ad73ceec748d0d392 /media-sound/mpd/mpd-0.11.5.ebuild
parentClean out old versions. (diff)
downloadgentoo-2-68c6cb6c8a20400ed7d9b4777f3f28a906eda64c.tar.gz
gentoo-2-68c6cb6c8a20400ed7d9b4777f3f28a906eda64c.tar.bz2
gentoo-2-68c6cb6c8a20400ed7d9b4777f3f28a906eda64c.zip
Modify installed initscript to need alsasound if alsa USE flag is set. Closes bug #99969 by Mike Kelly <pioto01 at gmail.com>. Change ogg USE flag to vorbis, bug #101877. Removed conditional dependency on libogg, as libvorbis itself depends on it. 'use netmount' in initscript depend(), closes bug #103458, by Nikolay Pashenkov <wildfire at ufanet.ru>.
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'media-sound/mpd/mpd-0.11.5.ebuild')
-rw-r--r--media-sound/mpd/mpd-0.11.5.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/media-sound/mpd/mpd-0.11.5.ebuild b/media-sound/mpd/mpd-0.11.5.ebuild
index 73d161e96ce2..041da8286f12 100644
--- a/media-sound/mpd/mpd-0.11.5.ebuild
+++ b/media-sound/mpd/mpd-0.11.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/mpd-0.11.5.ebuild,v 1.7 2005/05/28 12:36:00 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/mpd-0.11.5.ebuild,v 1.8 2005/10/16 21:11:44 ticho Exp $
inherit eutils
@@ -11,7 +11,7 @@ SRC_URI="http://mercury.chem.pitt.edu/~shank/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 hppa ppc sparc x86"
-IUSE="aac alsa audiofile flac ipv6 mad mikmod ogg unicode"
+IUSE="aac alsa audiofile flac ipv6 mad mikmod unicode vorbis"
DEPEND=">=media-libs/libao-0.8.4
!media-sound/mpd-svn
@@ -23,8 +23,7 @@ DEPEND=">=media-libs/libao-0.8.4
mad? ( media-libs/libmad
media-libs/libid3tag )
mikmod? ( media-libs/libmikmod )
- ogg? ( media-libs/libogg
- media-libs/libvorbis )"
+ vorbis? ( media-libs/libvorbis )"
pkg_setup() {
enewuser mpd '' '' '' audio || die "problem adding user mpd"
@@ -42,9 +41,9 @@ src_compile() {
$(use_enable !mad id3tag) \
$(use_enable mikmod libmikmodtest) \
$(use_enable mikmod mod) \
- $(use_enable ogg) \
- $(use_enable ogg oggtest) \
- $(use_enable ogg vorbistest) \
+ $(use_enable vorbis ogg) \
+ $(use_enable vorbis oggtest) \
+ $(use_enable vorbis vorbistest) \
|| die "could not configure"
emake || die "emake failed"
@@ -84,14 +83,14 @@ src_install() {
insopts -m0640 -o mpd -g audio
newins ${T}/blah mpd.log
newins ${T}/blah mpd.error.log
+
+ use alsa && \
+ dosed 's:need :need alsasound :' /etc/init.d/mpd
}
pkg_postinst() {
- einfo "libao prior to 0.8.4 has issues with the ALSA drivers"
- einfo "please refer to the FAQ"
- einfo "http://www.musicpd.org/wiki/moin.cgi/MpdFAQ if you are having"
- einfo "problems."
- einfo
+ echo
einfo "The default config now binds the daemon strictly to localhost,"
einfo "rather then all available IPs."
+ echo
}