summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-11-09 08:42:57 +0000
committerChristoph Mende <angelos@gentoo.org>2008-11-09 08:42:57 +0000
commit6dc8bd4560fdf46bd54ff105323da9c31f7a547f (patch)
tree4226a8e02957dbb5b79c979ea7c5e40d092c4ee0 /media-sound/mpd
parentAdd back wrongly dropped m4 patch. (diff)
downloadgentoo-2-6dc8bd4560fdf46bd54ff105323da9c31f7a547f.tar.gz
gentoo-2-6dc8bd4560fdf46bd54ff105323da9c31f7a547f.tar.bz2
gentoo-2-6dc8bd4560fdf46bd54ff105323da9c31f7a547f.zip
Improve icecast logic and add missing glib dependency
(Portage version: 2.2_rc13/cvs/Linux 2.6.28-rc3 x86_64)
Diffstat (limited to 'media-sound/mpd')
-rw-r--r--media-sound/mpd/ChangeLog5
-rw-r--r--media-sound/mpd/mpd-0.14_alpha1.ebuild11
2 files changed, 11 insertions, 5 deletions
diff --git a/media-sound/mpd/ChangeLog b/media-sound/mpd/ChangeLog
index e4b5f2b6a4d4..8e78da3480ae 100644
--- a/media-sound/mpd/ChangeLog
+++ b/media-sound/mpd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/mpd
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/ChangeLog,v 1.132 2008/11/07 13:28:51 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/ChangeLog,v 1.133 2008/11/09 08:42:57 angelos Exp $
+
+ 09 Nov 2008; Christoph Mende <angelos@gentoo.org> mpd-0.14_alpha1.ebuild:
+ Improve icecast logic and add missing glib dependency
*mpd-0.14_alpha1 (07 Nov 2008)
diff --git a/media-sound/mpd/mpd-0.14_alpha1.ebuild b/media-sound/mpd/mpd-0.14_alpha1.ebuild
index 46c96733351e..1edbe02ebe2b 100644
--- a/media-sound/mpd/mpd-0.14_alpha1.ebuild
+++ b/media-sound/mpd/mpd-0.14_alpha1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/mpd-0.14_alpha1.ebuild,v 1.1 2008/11/07 13:28:51 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/mpd-0.14_alpha1.ebuild,v 1.2 2008/11/09 08:42:57 angelos Exp $
+
+EAPI=1
inherit eutils
@@ -14,6 +16,7 @@ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="aac alsa ao audiofile curl ffmpeg flac icecast iconv ipv6 jack lame libsamplerate mad mikmod musepack ogg oss pulseaudio unicode vorbis wavpack zeroconf"
DEPEND="!sys-cluster/mpich2
+ >=dev-libs/glib-2.4:2
aac? ( >=media-libs/faad2-2.0_rc2 )
alsa? ( media-sound/alsa-utils )
ao? ( >=media-libs/libao-0.8.4 )
@@ -45,8 +48,8 @@ pkg_setup() {
die "Missing libOggFLAC library."
fi
- if use shoutcast && ! use mad && ! use ogg; then
- ewarn "USE=shoutcast enabled but mad and ogg disabled,"
+ if use shoutcast && ! use lame && ! use vorbis; then
+ ewarn "USE=shoutcast enabled but lame and vorbis disabled,"
ewarn "disabling shoutcast"
fi
@@ -77,7 +80,7 @@ src_compile() {
fi
if use icecast; then
- myconf+=" $(use_enable ogg shout_ogg) $(use_enable mad shout_mp3)"
+ myconf+=" $(use_enable vorbis shout_ogg) $(use_enable lame shout_mp3)"
else
myconf+=" --disable-shout_ogg --disable-shout_mp3"
fi