summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-20 18:16:36 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-20 18:16:36 +0000
commit240902e6b69e48b40bcae22942c03b5576ab62e6 (patch)
treee4f0deedd2372da4fa77a1b01f16ce1239858d72 /media-sound/mpfc/files
parentgcc 4.3 build fix by Peter Alfredsen <peter.alfredsen@gmail.com> in bug #218425 (diff)
downloadgentoo-2-240902e6b69e48b40bcae22942c03b5576ab62e6.tar.gz
gentoo-2-240902e6b69e48b40bcae22942c03b5576ab62e6.tar.bz2
gentoo-2-240902e6b69e48b40bcae22942c03b5576ab62e6.zip
Add a patch to fix building with --as-needed, also patch pre-autotools files and run eautoreconf rather than patching post-autotools files which might lead to unexpected results.
(Portage version: 2.1.5_rc5)
Diffstat (limited to 'media-sound/mpfc/files')
-rw-r--r--media-sound/mpfc/files/mpfc-1.3.7-asneeded.patch26
-rw-r--r--media-sound/mpfc/files/mpfc-1.3.7-libdir.patch113
-rw-r--r--media-sound/mpfc/files/mpfc-1.3.7-mathlib.patch20
-rw-r--r--media-sound/mpfc/files/mpfc-mathlib.patch20
4 files changed, 159 insertions, 20 deletions
diff --git a/media-sound/mpfc/files/mpfc-1.3.7-asneeded.patch b/media-sound/mpfc/files/mpfc-1.3.7-asneeded.patch
new file mode 100644
index 000000000000..d681e8784f74
--- /dev/null
+++ b/media-sound/mpfc/files/mpfc-1.3.7-asneeded.patch
@@ -0,0 +1,26 @@
+Index: mpfc-1.3.7/libmpfc/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/libmpfc/Makefile.am
++++ mpfc-1.3.7/libmpfc/Makefile.am
+@@ -18,6 +18,6 @@ libmpfc_la_SOURCES = cfg.c charset.c fil
+ song_info.c string.c vfs.c logger.c cfg_rcfile.c \
+ plugin.c plugin_general.c command.c \
+ $(libmpfchdr_HEADERS)
+-libmpfc_la_LIBADD = @COMMON_LIBS@ @RESOLV_LIBS@
++libmpfc_la_LIBADD = @COMMON_LIBS@ @RESOLV_LIBS@ @DL_LIBS@
+ INCLUDES = -I$(top_builddir)/src -I$(top_builddir)/libmpfcwnd
+ localedir = $(datadir)/locale
+Index: mpfc-1.3.7/src/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/src/Makefile.am
++++ mpfc-1.3.7/src/Makefile.am
+@@ -13,6 +13,7 @@ localedir = $(datadir)/locale
+ DEFS = -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"$(libdir)\" \
+ -DSYSCONFDIR=\"$(sysconfdir)\" @DEFS@
+ INCLUDES = -I$(top_builddir)/libmpfcwnd/
+-mpfc_LDADD = @COMMON_LIBS@ @PTHREAD_LIBS@ @DL_LIBS@ @MATH_LIBS@ \
++mpfc_LDADD = \
+ $(top_builddir)/libmpfc/libmpfc.la \
+- $(top_builddir)/libmpfcwnd/libmpfcwnd.la
++ $(top_builddir)/libmpfcwnd/libmpfcwnd.la \
++ @COMMON_LIBS@ @PTHREAD_LIBS@ @DL_LIBS@ @MATH_LIBS@
diff --git a/media-sound/mpfc/files/mpfc-1.3.7-libdir.patch b/media-sound/mpfc/files/mpfc-1.3.7-libdir.patch
new file mode 100644
index 000000000000..52a318463154
--- /dev/null
+++ b/media-sound/mpfc/files/mpfc-1.3.7-libdir.patch
@@ -0,0 +1,113 @@
+Index: mpfc-1.3.7/libmpfc/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/libmpfc/Makefile.am
++++ mpfc-1.3.7/libmpfc/Makefile.am
+@@ -1,7 +1,5 @@
+ lib_LTLIBRARIES = libmpfc.la
+
+-libdir = $(prefix)/lib/
+-
+ libmpfchdrdir = $(prefix)/include/mpfc
+ libmpfchdr_HEADERS = ../mpfc-config.h ../src/types.h ../src/cfg.h \
+ ../src/charset.h \
+Index: mpfc-1.3.7/libmpfcwnd/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/libmpfcwnd/Makefile.am
++++ mpfc-1.3.7/libmpfcwnd/Makefile.am
+@@ -1,5 +1,4 @@
+ lib_LTLIBRARIES = libmpfcwnd.la
+-libdir = $(prefix)/lib/
+ libmpfcwndhdrdir = $(prefix)/include/mpfc/libmpfcwnd
+ libmpfcwndhdr_HEADERS = wnd.h wnd_print.h wnd_msg.h wnd_kbd.h \
+ wnd_def_handlers.h wnd_root.h wnd_mouse.h wnd_types.h \
+Index: mpfc-1.3.7/plugins/input/audiocd/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/plugins/input/audiocd/Makefile.am
++++ mpfc-1.3.7/plugins/input/audiocd/Makefile.am
+@@ -1,6 +1,6 @@
+-lib_LTLIBRARIES = libaudiocd.la
++plugin_LTLIBRARIES = libaudiocd.la
+
+-libdir = $(prefix)/lib/mpfc/input
++plugindir = $(libdir)/mpfc/input
+
+ libaudiocd_la_SOURCES = audiocd.c audiocd.h cddb.c cddb.h
+ libaudiocd_la_LIBADD = @COMMON_LIBS@ @RESOLV_LIBS@
+Index: mpfc-1.3.7/plugins/input/mp3/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/plugins/input/mp3/Makefile.am
++++ mpfc-1.3.7/plugins/input/mp3/Makefile.am
+@@ -1,6 +1,6 @@
+-lib_LTLIBRARIES = libmp3.la
++plugin_LTLIBRARIES = libmp3.la
+
+-libdir = $(prefix)/lib/mpfc/input
++plugindir = $(libdir)/mpfc/input
+
+ libmp3_la_SOURCES = mp3.c mp3.h
+ INCLUDES = -I$(top_builddir)/src -I$(top_builddir)/libmpfcwnd
+Index: mpfc-1.3.7/plugins/input/ogg/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/plugins/input/ogg/Makefile.am
++++ mpfc-1.3.7/plugins/input/ogg/Makefile.am
+@@ -1,6 +1,6 @@
+-lib_LTLIBRARIES = libogg_vorbis.la
++plugin_LTLIBRARIES = libogg_vorbis.la
+
+-libdir = $(prefix)/lib/mpfc/input
++plugindir = $(libdir)/mpfc/input
+
+ libogg_vorbis_la_SOURCES = ogg.c vcedit.c vcedit.h
+ INCLUDES = -I$(top_builddir)/src -I$(top_builddir)/libmpfcwnd
+Index: mpfc-1.3.7/plugins/input/wav/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/plugins/input/wav/Makefile.am
++++ mpfc-1.3.7/plugins/input/wav/Makefile.am
+@@ -1,6 +1,6 @@
+-lib_LTLIBRARIES = libwav.la
++plugin_LTLIBRARIES = libwav.la
+
+-libdir = $(prefix)/lib/mpfc/input
++plugindir = $(libdir)/mpfc/input
+
+ libwav_la_SOURCES = wav.c wav.h
+ libwav_la_LIBADD = @COMMON_LIBS@
+Index: mpfc-1.3.7/plugins/output/alsa/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/plugins/output/alsa/Makefile.am
++++ mpfc-1.3.7/plugins/output/alsa/Makefile.am
+@@ -1,6 +1,6 @@
+-lib_LTLIBRARIES = libalsa.la
++plugin_LTLIBRARIES = libalsa.la
+
+-libdir = $(prefix)/lib/mpfc/output
++plugindir = $(libdir)/mpfc/output
+
+ libalsa_la_SOURCES = alsa.c
+ INCLUDES = -I$(top_builddir)/src -I$(top_builddir)/libmpfcwnd
+Index: mpfc-1.3.7/plugins/output/disk_writer/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/plugins/output/disk_writer/Makefile.am
++++ mpfc-1.3.7/plugins/output/disk_writer/Makefile.am
+@@ -1,6 +1,6 @@
+-lib_LTLIBRARIES = libdisk_writer.la
++plugin_LTLIBRARIES = libdisk_writer.la
+
+-libdir = $(prefix)/lib/mpfc/output
++plugindir = $(libdir)/mpfc/output
+
+ libdisk_writer_la_SOURCES = writer.c
+ libdisk_writer_la_LIBADD = @COMMON_LIBS@
+Index: mpfc-1.3.7/plugins/output/oss/Makefile.am
+===================================================================
+--- mpfc-1.3.7.orig/plugins/output/oss/Makefile.am
++++ mpfc-1.3.7/plugins/output/oss/Makefile.am
+@@ -1,6 +1,6 @@
+-lib_LTLIBRARIES = liboss.la
++plugin_LTLIBRARIES = liboss.la
+
+-libdir = $(prefix)/lib/mpfc/output
++plugindir = $(libdir)/mpfc/output
+
+ liboss_la_SOURCES = oss.c
+ liboss_la_LIBADD = @COMMON_LIBS@
diff --git a/media-sound/mpfc/files/mpfc-1.3.7-mathlib.patch b/media-sound/mpfc/files/mpfc-1.3.7-mathlib.patch
new file mode 100644
index 000000000000..09471407398b
--- /dev/null
+++ b/media-sound/mpfc/files/mpfc-1.3.7-mathlib.patch
@@ -0,0 +1,20 @@
+Index: mpfc-1.3.7/configure.in
+===================================================================
+--- mpfc-1.3.7.orig/configure.in
++++ mpfc-1.3.7/configure.in
+@@ -66,7 +66,6 @@ LIBS=$LIBS_save
+ AC_ARG_ENABLE(mp3,
+ [ --disable-mp3 Disable mp3 input plugin [default=enabled]],,
+ enable_mp3="yes")
+-if test "x$enable_mp3" = xyes; then
+ # Check for math lib
+ LIBS_save=$LIBS
+ AC_CHECK_HEADERS([math.h],,[AC_MSG_ERROR(*** Can't find math header ***)])
+@@ -75,6 +74,7 @@ if test "x$enable_mp3" = xyes; then
+ AC_SUBST(MATH_LIBS)
+ LIBS=$LIBS_save
+
++if test "x$enable_mp3" = xyes; then
+ # Check for libmad
+ LIBS_save=$LIBS
+ AC_CHECK_HEADERS([mad.h],,[AC_MSG_ERROR(*** Can't find libmad header ***)])
diff --git a/media-sound/mpfc/files/mpfc-mathlib.patch b/media-sound/mpfc/files/mpfc-mathlib.patch
deleted file mode 100644
index 011ce696e327..000000000000
--- a/media-sound/mpfc/files/mpfc-mathlib.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Index: mpfc-1.3.7/configure
-===================================================================
---- mpfc-1.3.7.orig/configure
-+++ mpfc-1.3.7/configure
-@@ -27004,7 +27004,6 @@ if test "${enable_mp3+set}" = set; then
- else
- enable_mp3="yes"
- fi;
--if test "x$enable_mp3" = xyes; then
- # Check for math lib
- LIBS_save=$LIBS
-
-@@ -27242,6 +27241,7 @@ fi
- MATH_LIBS="-lm"
-
- LIBS=$LIBS_save
-+if test "x$enable_mp3" = xyes; then
-
- # Check for libmad
- LIBS_save=$LIBS