summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-25 10:58:51 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-25 10:58:51 +0000
commit06ba750e09836e6f42597842908cd2f60be65265 (patch)
treedd35abb2383dc3714a4827b1d1b5d1918e84f7d6 /media-sound/mt-daapd
parentDrop 3.3 versions. (diff)
downloadgentoo-2-06ba750e09836e6f42597842908cd2f60be65265.tar.gz
gentoo-2-06ba750e09836e6f42597842908cd2f60be65265.tar.bz2
gentoo-2-06ba750e09836e6f42597842908cd2f60be65265.zip
New nightlie.
(Portage version: 2.1.1_pre3-r3)
Diffstat (limited to 'media-sound/mt-daapd')
-rw-r--r--media-sound/mt-daapd/ChangeLog8
-rw-r--r--media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre13153
-rw-r--r--media-sound/mt-daapd/mt-daapd-0.3.0_pre1315.ebuild143
3 files changed, 153 insertions, 1 deletions
diff --git a/media-sound/mt-daapd/ChangeLog b/media-sound/mt-daapd/ChangeLog
index 15cc9d5ecb0a..4d2787bc82a9 100644
--- a/media-sound/mt-daapd/ChangeLog
+++ b/media-sound/mt-daapd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/mt-daapd
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/ChangeLog,v 1.41 2006/07/21 16:48:50 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/ChangeLog,v 1.42 2006/07/25 10:58:51 flameeyes Exp $
+
+*mt-daapd-0.3.0_pre1315 (25 Jul 2006)
+
+ 25 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -mt-daapd-0.3.0_pre1311.ebuild, +mt-daapd-0.3.0_pre1315.ebuild:
+ New nightlie.
*mt-daapd-0.3.0_pre1311 (21 Jul 2006)
diff --git a/media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre1315 b/media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre1315
new file mode 100644
index 000000000000..90fed0a2866e
--- /dev/null
+++ b/media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre1315
@@ -0,0 +1,3 @@
+MD5 a8c67def2bd2fdfcc7b05581cca61381 mt-daapd-svn-1315.tar.gz 1129742
+RMD160 eed035e007e04b2b9a3945f07f4b6611d1f6657c mt-daapd-svn-1315.tar.gz 1129742
+SHA256 3136d05c8ef9538ed788d911467280831309309a31a7c05631f3d72347d04802 mt-daapd-svn-1315.tar.gz 1129742
diff --git a/media-sound/mt-daapd/mt-daapd-0.3.0_pre1315.ebuild b/media-sound/mt-daapd/mt-daapd-0.3.0_pre1315.ebuild
new file mode 100644
index 000000000000..f1b003a433f9
--- /dev/null
+++ b/media-sound/mt-daapd/mt-daapd-0.3.0_pre1315.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/mt-daapd-0.3.0_pre1315.ebuild,v 1.1 2006/07/25 10:58:51 flameeyes Exp $
+
+inherit eutils flag-o-matic base
+
+SVN="${PV#*pre}"
+
+if [[ -n ${SVN} ]] ; then
+ MY_P="${PN}-svn-${SVN}"
+ SRC_URI="http://nightlies.mt-daapd.org/${MY_P}.tar.gz"
+else
+ MY_P="${P/_/-}"
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+fi
+
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A multi-threaded implementation of Apple's DAAP server"
+HOMEPAGE="http://www.mt-daapd.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sh ~sparc ~x86"
+IUSE="howl vorbis avahi sqlite3 flac ffmpeg"
+
+DEPEND="sys-libs/zlib
+ media-libs/libid3tag
+ !sqlite3? ( =dev-db/sqlite-2* )
+ sqlite3? ( =dev-db/sqlite-3* )
+ howl? ( !avahi? ( >=net-misc/howl-0.9.2 )
+ avahi? ( net-dns/avahi ) )
+ vorbis? ( media-libs/libvorbis )
+ flac? ( media-libs/flac )
+ ffmpeg? ( media-video/ffmpeg )"
+
+pkg_setup() {
+ if use howl && use avahi && ! built_with_use net-dns/avahi howl-compat; then
+ eerror "You requested avahi support, but this package requires"
+ eerror "the howl-compat support enabled in net-dns/avahi to work"
+ eerror "with it."
+ eerror
+ eerror "Please recompile net-dns/avahi with +howl-compat."
+ die "Missing howl-compat support in avahi."
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ local howlincludes
+
+ append-flags -fno-strict-aliasing
+
+ # howl support?
+ if use howl; then
+ use avahi && \
+ howlincludes="/usr/include/avahi-compat-howl" || \
+ howlincludes="/usr/include/howl"
+
+ myconf="${myconf}
+ --enable-howl
+ --with-howl-libs=/usr/$(get_libdir)
+ --with-howl-includes=${howlincludes}"
+ fi
+
+ # Bug 65723
+ if use vorbis; then
+ myconf="${myconf} --enable-oggvorbis"
+ fi
+
+ econf \
+ $(use_enable vorbis oggvorbis) \
+ $(use_enable flac) \
+ $(use_enable !sqlite3 sqlite) \
+ $(use_enable sqlite3) \
+ $(use_enable ffmpeg) \
+ --with-ffmpeg-includes=${ROOT}/usr/include/ffmpeg \
+ ${myconf} || die "configure failed"
+ emake || die "make failed"
+
+ cp ${FILESDIR}/${PN}.init.2 ${WORKDIR}/initd
+ if ! use howl; then
+ sed -i -e '/#USEHOWL/d' ${WORKDIR}/initd
+ elif ! use avahi; then
+ sed -i -e 's:#USEHOWL ::' ${WORKDIR}/initd
+ else
+ sed -i -e 's:#USEHOWL ::; s:mDNSResponder:avahi-daemon:' ${WORKDIR}/initd
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ insinto /etc
+ newins ${FILESDIR}/mt-daapd.conf.example mt-daapd.conf.example
+ doins contrib/mt-daapd.playlist
+
+ newinitd ${WORKDIR}/initd ${PN}
+
+ keepdir /var/cache/mt-daapd /etc/mt-daapd.d
+
+ dodoc AUTHORS CREDITS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ einfo
+ elog "You have to configure your mt-daapd.conf following"
+ elog "/etc/mt-daapd.conf.example file."
+ einfo
+
+ if use howl; then
+ use avahi && \
+ howlservice="avahi-daemon" || \
+ howlservice="mDNSResponder"
+
+ einfo
+ elog "Since you want to use howl instead of the internal mdnsd"
+ elog "you need to make sure that you have ${howlservice} configured"
+ elog "and running to use mt-daapd."
+ einfo
+
+ if use avahi; then
+ elog "Avahi support is currently experimental, it does not work"
+ elog "as intended when using more than one mt-daapd instance."
+ elog "If you want to run more than one mt-daapd, just use the"
+ elog "internal mdnsd by building with -howl flag."
+ fi
+ fi
+
+ if use vorbis; then
+ einfo
+ elog "You need to edit you extensions list in /etc/mt-daapd.conf"
+ elog "if you want your mt-daapd to serve ogg files."
+ einfo
+ fi
+
+ einfo
+ elog "If you want to start more than one ${PN} service, symlink"
+ elog "/etc/init.d/${PN} to /etc/init.d/${PN}.<name>, and it will"
+ elog "load the data from /etc/${PN}.d/<name>.conf."
+ elog "Make sure that you have different cache directories for them."
+ einfo
+}