summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-01-20 17:14:43 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-01-20 17:14:43 +0000
commit971317253870635345b3b0e7b59d78041a779a28 (patch)
treeb28012f1c39332acb40e33550d633bcba60718b3 /media-sound/mumble
parenttypo fix: gspca->gspcav1 (diff)
downloadgentoo-2-971317253870635345b3b0e7b59d78041a779a28.tar.gz
gentoo-2-971317253870635345b3b0e7b59d78041a779a28.tar.bz2
gentoo-2-971317253870635345b3b0e7b59d78041a779a28.zip
Add Gorch patch for missing typedefs on gcc 3, wrt bug #162912.
(Portage version: 2.1.2)
Diffstat (limited to 'media-sound/mumble')
-rw-r--r--media-sound/mumble/ChangeLog8
-rw-r--r--media-sound/mumble/files/mumble-0.9.4-missing_typedefs.patch14
-rw-r--r--media-sound/mumble/mumble-0.9.4.ebuild5
3 files changed, 23 insertions, 4 deletions
diff --git a/media-sound/mumble/ChangeLog b/media-sound/mumble/ChangeLog
index bf7e9f3bd91a..03529e0e446b 100644
--- a/media-sound/mumble/ChangeLog
+++ b/media-sound/mumble/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/mumble
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mumble/ChangeLog,v 1.1 2006/11/25 11:39:57 drizzt Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mumble/ChangeLog,v 1.2 2007/01/20 17:14:43 drizzt Exp $
+
+ 20 Jan 2007; Timothy Redaelli <drizzt@gentoo.org>
+ +files/mumble-0.9.4-missing_typedefs.patch, mumble-0.9.4.ebuild:
+ Add Gorch patch for missing typedefs on gcc 3, wrt bug #162912.
*mumble-0.9.4 (25 Nov 2006)
diff --git a/media-sound/mumble/files/mumble-0.9.4-missing_typedefs.patch b/media-sound/mumble/files/mumble-0.9.4-missing_typedefs.patch
new file mode 100644
index 000000000000..9f8ef06ee5bb
--- /dev/null
+++ b/media-sound/mumble/files/mumble-0.9.4-missing_typedefs.patch
@@ -0,0 +1,14 @@
+diff -Naur mumble-0.9.4.orig/AudioStats.cpp mumble-0.9.4/AudioStats.cpp
+--- mumble-0.9.4.orig/AudioStats.cpp 2006-10-30 12:20:38.000000000 +0100
++++ mumble-0.9.4/AudioStats.cpp 2006-11-17 14:12:55.000000000 +0100
+@@ -38,7 +38,10 @@
+ typedef float spx_word16_t;
+ typedef float spx_word32_t;
+ typedef float spx_float_t;
++typedef long int spx_int32_t;
++typedef short int spx_int16_t;
+ typedef spx_word32_t spx_mem_t;
++
+ /** Speex echo cancellation state. */
+ struct CloneSpeexEchoState {
+ int frame_size; /**< Number of samples processed each time */
diff --git a/media-sound/mumble/mumble-0.9.4.ebuild b/media-sound/mumble/mumble-0.9.4.ebuild
index 2d6892c586aa..a62618e2f557 100644
--- a/media-sound/mumble/mumble-0.9.4.ebuild
+++ b/media-sound/mumble/mumble-0.9.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mumble/mumble-0.9.4.ebuild,v 1.1 2006/11/25 11:39:57 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mumble/mumble-0.9.4.ebuild,v 1.2 2007/01/20 17:14:43 drizzt Exp $
inherit eutils toolchain-funcs
@@ -35,6 +35,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-path.patch
+ epatch "${FILESDIR}"/${P}-missing_typedefs.patch
}
src_compile() {