summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrank van de Pol <fvdpol@gentoo.org>2005-02-01 22:51:32 +0000
committerFrank van de Pol <fvdpol@gentoo.org>2005-02-01 22:51:32 +0000
commit9156fe1b7acce492e53747592b69824efbd7b318 (patch)
treef8f96c736584b8442685efe4ba1055140894fd0e /media-sound/museseq/museseq-0.7.1.ebuild
parentfixed gcc34 patch, devfs check, ebuild stops if PPP is missing in kernel conf... (diff)
downloadgentoo-2-9156fe1b7acce492e53747592b69824efbd7b318.tar.gz
gentoo-2-9156fe1b7acce492e53747592b69824efbd7b318.tar.bz2
gentoo-2-9156fe1b7acce492e53747592b69824efbd7b318.zip
Version bump to 0.7.1.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'media-sound/museseq/museseq-0.7.1.ebuild')
-rw-r--r--media-sound/museseq/museseq-0.7.1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/media-sound/museseq/museseq-0.7.1.ebuild b/media-sound/museseq/museseq-0.7.1.ebuild
new file mode 100644
index 000000000000..a1a8dc2576b3
--- /dev/null
+++ b/media-sound/museseq/museseq-0.7.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/museseq/museseq-0.7.1.ebuild,v 1.1 2005/02/01 22:51:32 fvdpol Exp $
+
+inherit kde-functions gcc virtualx eutils
+need-qt 3
+
+MY_P=${P/museseq/muse}
+MY_P=${MY_P/_/}
+
+DESCRIPTION="The Linux (midi) MUSic Editor (a sequencer)"
+SRC_URI="mirror://sourceforge/lmuse/${MY_P}.tar.bz2"
+HOMEPAGE="http://lmuse.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc ladcca debug"
+
+DEPEND=">=x11-libs/qt-3.2.0
+ >=media-libs/alsa-lib-0.9.0
+ media-sound/fluidsynth
+ doc? ( app-text/openjade
+ app-doc/doxygen
+ media-gfx/graphviz )
+ dev-lang/perl
+ >=media-libs/libsndfile-1.0.1
+ >=media-libs/libsamplerate-0.1.0
+ >=media-sound/jack-audio-connection-kit-0.98.0
+ ladcca? ( >=media-libs/ladcca-0.4.0 )"
+
+src_compile() {
+ cd ${WORKDIR}/${MY_P}
+ local myconf
+ myconf="--disable-suid-build" # instead, use CONFIG_RTC and realtime-lsm
+ use ladcca || myconf="${myconf} --disable-ladcca"
+ use debug && myconf="${myconf} --enable-debug"
+ Xeconf ${myconf} || die "configure failed"
+
+ emake || die
+}
+
+src_install() {
+ cd ${WORKDIR}/${MY_P}
+ make DESTDIR=${D} install || die "install failed"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README SECURITY README.*
+ mv ${D}/usr/bin/muse ${D}/usr/bin/museseq
+}
+
+pkg_postinst() {
+ einfo "You must have the realtime module loaded to use MusE 0.7.x"
+ einfo "Additionally, configure your Linux Kernel for non-generic"
+ einfo "Real Time Clock support enabled or loaded as a module."
+ einfo "User must have read/write access to /dev/misc/rtc device."
+ einfo "Realtime LSM: http://sourceforge.net/projects/realtime-lsm/"
+}
+