summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Anderson <gentoofan23@gentoo.org>2009-01-11 13:21:32 +0000
committerThomas Anderson <gentoofan23@gentoo.org>2009-01-11 13:21:32 +0000
commit240e8c10e327b85237774b47936ecbb5f8455475 (patch)
tree6be2826492487c015cd02570d6be92a67a93da1c /media-sound/ncmpc/ncmpc-0.13.ebuild
parentVersion bump (diff)
downloadgentoo-2-240e8c10e327b85237774b47936ecbb5f8455475.tar.gz
gentoo-2-240e8c10e327b85237774b47936ecbb5f8455475.tar.bz2
gentoo-2-240e8c10e327b85237774b47936ecbb5f8455475.zip
Version bump, add configure option for multilib fix for amd64.
(Portage version: 2.1.6.1/cvs/Linux 2.6.25.9 x86_64)
Diffstat (limited to 'media-sound/ncmpc/ncmpc-0.13.ebuild')
-rw-r--r--media-sound/ncmpc/ncmpc-0.13.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-sound/ncmpc/ncmpc-0.13.ebuild b/media-sound/ncmpc/ncmpc-0.13.ebuild
new file mode 100644
index 000000000000..a11654c4f769
--- /dev/null
+++ b/media-sound/ncmpc/ncmpc-0.13.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ncmpc/ncmpc-0.13.ebuild,v 1.1 2009/01/11 13:21:32 gentoofan23 Exp $
+
+EAPI="2"
+inherit multilib
+
+DESCRIPTION="A ncurses client for the Music Player Daemon (MPD)"
+HOMEPAGE="http://mpd.wikia.com/wiki/Client:Ncmpc"
+SRC_URI="http://downloads.sourceforge.net/musicpd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="artist-screen colors debug +help-screen key-screen lirc lyrics-screen
+mouse nls search-screen song-screen"
+
+RDEPEND=">=dev-libs/glib-2.4
+ dev-libs/popt
+ sys-libs/ncurses
+ lirc? ( app-misc/lirc )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ ##The use_with lyrics-screen is for multilib
+ econf \
+ $(use_enable artist-screen) \
+ $(use_enable colors) \
+ $(use_enable debug) \
+ $(use_enable help-screen) \
+ $(use_enable key-screen) \
+ $(use_enable lirc) \
+ $(use_enable lyrics-screen) \
+ $(use_with lyrics-screen lyrics-plugin-dir /usr/$(get_libdir)/ncmpc/lyrics) \
+ $(use_enable mouse) \
+ $(use_enable nls) \
+ $(use_enable nls locale) \
+ $(use_enable nls multibyte) \
+ $(use_enable search-screen) \
+ $(use_enable song-screen)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}