summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-10-27 10:17:52 +0000
committerTim Harder <radhermit@gentoo.org>2011-10-27 10:17:52 +0000
commit34e3572c50f3f9709bca140f5324c9204686e590 (patch)
treedb6228ad462b360f8d975457be82cc796f4fbd41 /media-sound/normalize
parentRemanifest as the current one fails checksums. (diff)
downloadgentoo-2-34e3572c50f3f9709bca140f5324c9204686e590.tar.gz
gentoo-2-34e3572c50f3f9709bca140f5324c9204686e590.tar.bz2
gentoo-2-34e3572c50f3f9709bca140f5324c9204686e590.zip
Revbump to fix build issue with audiofile-0.3.1 (bug #385317 by SpanKY).
(Portage version: 2.2.0_alpha70/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/normalize')
-rw-r--r--media-sound/normalize/ChangeLog9
-rw-r--r--media-sound/normalize/files/normalize-0.7.7-audiofile-pkgconfig.patch55
-rw-r--r--media-sound/normalize/normalize-0.7.7-r1.ebuild39
3 files changed, 101 insertions, 2 deletions
diff --git a/media-sound/normalize/ChangeLog b/media-sound/normalize/ChangeLog
index e88e06e7dbaa..9fac9574d410 100644
--- a/media-sound/normalize/ChangeLog
+++ b/media-sound/normalize/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/normalize
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/normalize/ChangeLog,v 1.28 2007/10/15 14:39:12 corsair Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/normalize/ChangeLog,v 1.29 2011/10/27 10:17:51 radhermit Exp $
+
+*normalize-0.7.7-r1 (27 Oct 2011)
+
+ 27 Oct 2011; Tim Harder <radhermit@gentoo.org> +normalize-0.7.7-r1.ebuild:
+ Revbump to fix build issue with audiofile-0.3.1 (bug #385317 by SpanKY).
15 Oct 2007; Markus Rothe <corsair@gentoo.org> normalize-0.7.7.ebuild:
Stable on ppc64
diff --git a/media-sound/normalize/files/normalize-0.7.7-audiofile-pkgconfig.patch b/media-sound/normalize/files/normalize-0.7.7-audiofile-pkgconfig.patch
new file mode 100644
index 000000000000..09f211cdfb66
--- /dev/null
+++ b/media-sound/normalize/files/normalize-0.7.7-audiofile-pkgconfig.patch
@@ -0,0 +1,55 @@
+Use pkgconfig to check for audiofile since the audiofile-config script was
+removed from >=audiofile-0.3.0.
+
+--- normalize-0.7.7/configure.ac.orig
++++ normalize-0.7.7/configure.ac
+@@ -248,33 +248,16 @@
+
+
+ dnl *** Stuff for audiofile library ***
+-dnl v0.2.1 and before have bugs with 24-bit LE files
+-AM_PATH_AUDIOFILE([ 0.2.2 ], [ have_audiofile=true ])
+-dnl AC_CHECK_LIB(audiofile, afSetVirtualSampleFormat, have_audiofile=true)
++AC_ARG_WITH(audiofile, AC_HELP_STRING([--with-audiofile],
++ [use the audiofile library (default yes)]))
+ AH_TEMPLATE([USE_AUDIOFILE],
+ [Define if you want to use the audiofile library.])
+-AC_ARG_WITH(audiofile,
+- AC_HELP_STRING([--with-audiofile],
+- [use the audiofile library (default yes)]),
+- [ case "$withval" in
+- no) with_audiofile=false ;;
+- *) with_audiofile=true ;;
+- esac ])
+
+-use_audiofile=false
+-if test x$with_audiofile != xfalse; then
+- if test x$have_audiofile = xtrue; then
+- AC_DEFINE(USE_AUDIOFILE)
+- use_audiofile=true
+-dnl AUDIOFILELIBS="-laudiofile"
+- elif test x$with_audiofile = xtrue; then
+- AC_MSG_ERROR([--with-audiofile specified, but audiofile library not found])
+- fi
+-fi
+-dnl AC_SUBST(AUDIOFILELIBS)
+-test x$use_audiofile = xfalse && AUDIOFILE_LIBS=
+-test x$use_audiofile = xfalse && AUDIOFILE_CFLAGS=
+-AM_CONDITIONAL(AUDIOFILE, test x$use_audiofile = xtrue)
++AS_IF([test "x$with_audiofile" = "xyes"], [
++ PKG_CHECK_MODULES([AUDIOFILE], [audiofile])
++ AC_DEFINE(USE_AUDIOFILE)
++])
++AM_CONDITIONAL(AUDIOFILE, test x$with_audiofile = xyes)
+
+
+ dnl *** Stuff for mad mpeg audio decoder library ***
+@@ -330,7 +313,7 @@
+
+ echo
+ echo "Configuration:"
+-echo " audiofile library: $use_audiofile"
++echo " audiofile library: $with_audiofile"
+ echo " mpeg audio support: $use_mad"
+ echo " xmms volume adjust plugin: $use_xmms"
+ echo
diff --git a/media-sound/normalize/normalize-0.7.7-r1.ebuild b/media-sound/normalize/normalize-0.7.7-r1.ebuild
new file mode 100644
index 000000000000..bd00f3d08f34
--- /dev/null
+++ b/media-sound/normalize/normalize-0.7.7-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/normalize/normalize-0.7.7-r1.ebuild,v 1.1 2011/10/27 10:17:51 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils autotools
+
+DESCRIPTION="Audio file volume normalizer"
+HOMEPAGE="http://normalize.nongnu.org/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.bz2
+ http://dev.gentoo.org/~radhermit/distfiles/${P}-m4.patch.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="audiofile mad nls userland_BSD"
+
+RDEPEND="mad? ( media-libs/libmad )
+ audiofile? ( >=media-libs/audiofile-0.3.1 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( dev-util/intltool )"
+
+src_prepare() {
+ use userland_BSD && sed -i -e 's/md5sum/md5/' "${S}"/test/*.sh
+
+ epatch "${FILESDIR}"/${P}-audiofile-pkgconfig.patch
+ epatch "${WORKDIR}"/${P}-m4.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with audiofile) \
+ $(use_with mad) \
+ $(use_enable nls) \
+ --disable-xmms
+}