summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2006-10-18 20:57:46 +0000
committerAlexis Ballier <aballier@gentoo.org>2006-10-18 20:57:46 +0000
commitefc496e525dcd40be53500239eda51aef2f41ccb (patch)
tree233b2c9b4b9815bf922e348f0cd66fec890919f8 /media-sound/orpheus
parentadd generic 2-clause BSD license - www-servers/varnish will use it (among oth... (diff)
downloadgentoo-2-efc496e525dcd40be53500239eda51aef2f41ccb.tar.gz
gentoo-2-efc496e525dcd40be53500239eda51aef2f41ccb.tar.bz2
gentoo-2-efc496e525dcd40be53500239eda51aef2f41ccb.zip
Adding a patch to compile on amd64 with gcc 4.1, bug #142684
(Portage version: 2.1.2_pre2-r9)
Diffstat (limited to 'media-sound/orpheus')
-rw-r--r--media-sound/orpheus/ChangeLog8
-rw-r--r--media-sound/orpheus/files/1.5-amd64.patch31
-rw-r--r--media-sound/orpheus/files/digest-orpheus-1.52
-rw-r--r--media-sound/orpheus/orpheus-1.5.ebuild7
4 files changed, 43 insertions, 5 deletions
diff --git a/media-sound/orpheus/ChangeLog b/media-sound/orpheus/ChangeLog
index 859b8bb00fe8..f03b3890f944 100644
--- a/media-sound/orpheus/ChangeLog
+++ b/media-sound/orpheus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/orpheus
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/orpheus/ChangeLog,v 1.18 2005/09/14 07:42:17 agriffis Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/orpheus/ChangeLog,v 1.19 2006/10/18 20:57:46 aballier Exp $
+
+ 18 Oct 2006; Alexis Ballier <aballier@gentoo.org> +files/1.5-amd64.patch,
+ orpheus-1.5.ebuild:
+ Adding a patch to compile on amd64 with gcc 4.1, bug #142684
14 Sep 2005; Aron Griffis <agriffis@gentoo.org> orpheus-1.5.ebuild:
Mark 1.5 stable on alpha
diff --git a/media-sound/orpheus/files/1.5-amd64.patch b/media-sound/orpheus/files/1.5-amd64.patch
new file mode 100644
index 000000000000..eac0ab0a2c61
--- /dev/null
+++ b/media-sound/orpheus/files/1.5-amd64.patch
@@ -0,0 +1,31 @@
+--- orpheus-1.5/kkstrtext-0.1/kkstrtext.cc 2004-01-15 21:25:31.000000000 +0100
++++ orpheus-1.5-new/kkstrtext-0.1/kkstrtext.cc 2006-08-28 11:48:36.926598598 +0200
+@@ -431,7 +431,7 @@
+ }
+
+ int intcompare(void *s1, void *s2) {
+- return (int) s1 != (int) s2;
++ return (long) s1 != (long) s2;
+ }
+
+ string i2str(int i) {
+@@ -885,7 +885,7 @@
+ #ifdef HAVE_ICONV
+ iconv_t cd = iconv_open(tocs.c_str(), fromcs.c_str());
+
+- if(((int) cd) != -1) {
++ if(((long) cd) != -1) {
+ string r, text(atext);
+ size_t inleft, outleft, soutleft;
+ char *inbuf, *outbuf, *sinbuf, *soutbuf;
+--- orpheus-1.5/kkconsui-0.1/src/texteditor.cc 2003-09-09 23:51:33.000000000 +0200
++++ orpheus-1.5-new/kkconsui-0.1/src/texteditor.cc 2006-08-28 11:56:10.082753610 +0200
+@@ -1940,7 +1940,7 @@
+ }
+
+ int texteditor::findint(void *p1, void *p2) {
+- return *(int *) p1 != (int) p2;
++ return *(long *) p1 != (long) p2;
+ }
+
+ int texteditor::findhighline(void *p1, void *p2) {
diff --git a/media-sound/orpheus/files/digest-orpheus-1.5 b/media-sound/orpheus/files/digest-orpheus-1.5
index 5024212e96ab..4059f22e5ed3 100644
--- a/media-sound/orpheus/files/digest-orpheus-1.5
+++ b/media-sound/orpheus/files/digest-orpheus-1.5
@@ -1 +1,3 @@
MD5 f578f16b0d9e7c88174ed1b7146c3813 orpheus-1.5.tar.gz 340984
+RMD160 8836e03d6f386f816373829e96f3acf262cef0dd orpheus-1.5.tar.gz 340984
+SHA256 6b1a15c4bd6819c2098c49128fbb2c8a37406af145ac798e5f6d5727a28ff110 orpheus-1.5.tar.gz 340984
diff --git a/media-sound/orpheus/orpheus-1.5.ebuild b/media-sound/orpheus/orpheus-1.5.ebuild
index 03ac217500df..96ccbe835e89 100644
--- a/media-sound/orpheus/orpheus-1.5.ebuild
+++ b/media-sound/orpheus/orpheus-1.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/orpheus/orpheus-1.5.ebuild,v 1.12 2005/09/14 07:42:17 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/orpheus/orpheus-1.5.ebuild,v 1.13 2006/10/18 20:57:46 aballier Exp $
inherit eutils toolchain-funcs
@@ -24,7 +24,8 @@ src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/${PV}-gcc34.patch
+ epatch "${FILESDIR}/${PV}-gcc34.patch"
+ epatch "${FILESDIR}/${PV}-amd64.patch"
#if use nas; then
# cd src