summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-07-24 15:35:54 +0000
committerSamuli Suominen <drac@gentoo.org>2007-07-24 15:35:54 +0000
commit6eed0054fc5c47d5dd2751da63f0efe7196d8c8d (patch)
tree650bb0de257d37f6af8a430c205700b158792cf2 /media-sound/playspc_gtk/playspc_gtk-0.2.7.8.ebuild
parentAdd ~amd64, bug 181080 (diff)
downloadgentoo-2-6eed0054fc5c47d5dd2751da63f0efe7196d8c8d.tar.gz
gentoo-2-6eed0054fc5c47d5dd2751da63f0efe7196d8c8d.tar.bz2
gentoo-2-6eed0054fc5c47d5dd2751da63f0efe7196d8c8d.zip
Version bump for bug 96492, thanks to qube99 for reporting. Install menu entry, use correct CC, and more.
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'media-sound/playspc_gtk/playspc_gtk-0.2.7.8.ebuild')
-rw-r--r--media-sound/playspc_gtk/playspc_gtk-0.2.7.8.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/playspc_gtk/playspc_gtk-0.2.7.8.ebuild b/media-sound/playspc_gtk/playspc_gtk-0.2.7.8.ebuild
new file mode 100644
index 000000000000..19849afcb9b3
--- /dev/null
+++ b/media-sound/playspc_gtk/playspc_gtk-0.2.7.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/playspc_gtk/playspc_gtk-0.2.7.8.ebuild,v 1.1 2007/07/24 15:35:54 drac Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Playspc_gtk is a gtk program utilizing the SNeSe SPC core to play SPC files. RAR support is well integrated."
+HOMEPAGE="http://playspc.sourceforge.net"
+SRC_URI="mirror://sourceforge/playspc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+# -*: Contains x86 assembly
+KEYWORDS="-* ~x86"
+IUSE=""
+
+RDEPEND="=x11-libs/gtk+-1.2*"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}
+
+src_compile() {
+ cd "${S}"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed."
+}
+
+src_install() {
+ dolib.so libopenspc/libopenspc.so
+ dobin ${PN} spccore
+ dodoc CHANGELOG README TODO
+ doicon playspc-icon.png
+ make_desktop_entry ${PN} ${PN} playspc-icon.png
+}