summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Hildebrand <zypher@gentoo.org>2004-06-29 14:30:58 +0000
committerMarc Hildebrand <zypher@gentoo.org>2004-06-29 14:30:58 +0000
commit3e633aeb1d6865b0e60b961d22596cff4541e072 (patch)
treef001dd41fa1a2cf08edbe639a0866f4849c2f73a /media-sound/protux
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-3e633aeb1d6865b0e60b961d22596cff4541e072.tar.gz
gentoo-2-3e633aeb1d6865b0e60b961d22596cff4541e072.tar.bz2
gentoo-2-3e633aeb1d6865b0e60b961d22596cff4541e072.zip
version bump
Diffstat (limited to 'media-sound/protux')
-rw-r--r--media-sound/protux/Manifest6
-rw-r--r--media-sound/protux/files/digest-protux-0.20.21
-rw-r--r--media-sound/protux/protux-0.20.2.ebuild34
3 files changed, 39 insertions, 2 deletions
diff --git a/media-sound/protux/Manifest b/media-sound/protux/Manifest
index d235d971eb6d..727151a84078 100644
--- a/media-sound/protux/Manifest
+++ b/media-sound/protux/Manifest
@@ -1,10 +1,12 @@
-MD5 443cb532ce17cb9d1458e48b70770ad5 protux-0.20.1.ebuild 846
MD5 4a0db854c812ead285289dfe0a12a709 protux-0.16.0.ebuild 889
MD5 2958d1721eab56afdbef1ac8e49f6d72 protux-0.17.8.ebuild 889
+MD5 443cb532ce17cb9d1458e48b70770ad5 protux-0.20.1.ebuild 846
+MD5 aecc55a155be5017563d0d137db335d4 protux-0.20.2.ebuild 763
MD5 fc8f573548909605396e49ff6c765235 protux-0.20.0.ebuild 844
MD5 a21826e2e1348dc3e8d45303be2fc0e4 ChangeLog 1609
MD5 d0d7ea03e238a808414b4426394c100f metadata.xml 221
+MD5 c4d75b6d370a9e848f5dd0e5a87b2d02 files/digest-protux-0.20.2 65
MD5 e2dd10b4d2a0c95521fdf87252684258 files/digest-protux-0.16.0 65
+MD5 2ef4161f2da38462aeb9b3ef66c67442 files/digest-protux-0.20.1 65
MD5 8f21b8a7e61479e2c48c22ffa7de96e2 files/digest-protux-0.17.8 65
MD5 b705aa6b0a2ea796649316d5378f9642 files/digest-protux-0.20.0 65
-MD5 2ef4161f2da38462aeb9b3ef66c67442 files/digest-protux-0.20.1 65
diff --git a/media-sound/protux/files/digest-protux-0.20.2 b/media-sound/protux/files/digest-protux-0.20.2
new file mode 100644
index 000000000000..b3d07d4b7685
--- /dev/null
+++ b/media-sound/protux/files/digest-protux-0.20.2
@@ -0,0 +1 @@
+MD5 1d5a69af52e989e6f9edf866da5fb98f protux-0.20.2.tar.gz 486398
diff --git a/media-sound/protux/protux-0.20.2.ebuild b/media-sound/protux/protux-0.20.2.ebuild
new file mode 100644
index 000000000000..8eb32bc93192
--- /dev/null
+++ b/media-sound/protux/protux-0.20.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/protux/protux-0.20.2.ebuild,v 1.1 2004/06/29 14:30:58 zypher Exp $
+
+inherit kde-functions
+
+DESCRIPTION="Professional Audio Tools for GNU/Linux"
+HOMEPAGE="http://www.nongnu.org/protux"
+SRC_URI="http://vt.shuis.tudelft.nl/~remon/protux/stable/version-${PV}/${P}.tar.gz"
+
+IUSE="static"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="virtual/x11
+ >=x11-libs/qt-3
+ >=media-libs/libmustux-0.20.2"
+
+set-qtdir 3
+
+src_compile() {
+ export QT_MOC=${QTDIR}/bin/moc
+ local myconf
+ myconf="--with-gnu-ld"
+ use static || myconf="${myconf} --enable-static=no"
+ econf ${myconf} || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYRIGHT ChangeLog FAQ README TODO
+}