summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2012-03-28 18:44:16 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2012-03-28 18:44:16 +0000
commit20259420d3781d5727e177f9df5b0d4ee88d5dea (patch)
tree96e727d7f208593cb35c7b6323f319073381e8d7 /media-sound/pulseaudio/pulseaudio-9999.ebuild
parentwebrtc-audio-processing is only supported on x86/amd64. Possibly arm can be a... (diff)
downloadgentoo-2-20259420d3781d5727e177f9df5b0d4ee88d5dea.tar.gz
gentoo-2-20259420d3781d5727e177f9df5b0d4ee88d5dea.tar.bz2
gentoo-2-20259420d3781d5727e177f9df5b0d4ee88d5dea.zip
Add a 2.0 RC2 ebuild. Lots of features and fixes (sample rate switching, new echo canceller, jack detection, virtual surround module, Xen support and lots more). Packaging-wise: add support a new echo canceller on-by-default, drop esound support, make ALSA plugins work out of the box.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/pulseaudio/pulseaudio-9999.ebuild')
-rw-r--r--media-sound/pulseaudio/pulseaudio-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/media-sound/pulseaudio/pulseaudio-9999.ebuild b/media-sound/pulseaudio/pulseaudio-9999.ebuild
index e7d86af80620..5b331207251a 100644
--- a/media-sound/pulseaudio/pulseaudio-9999.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-9999.ebuild,v 1.20 2012/03/20 23:49:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-9999.ebuild,v 1.21 2012/03/28 18:44:16 ford_prefect Exp $
EAPI=4
@@ -18,7 +18,7 @@ EGIT_REPO_URI="git://anongit.freedesktop.org/pulseaudio/pulseaudio.git"
LICENSE="!gdbm? ( LGPL-2.1 ) gdbm? ( GPL-2 )"
SLOT="0"
KEYWORDS=""
-IUSE="+alsa avahi +caps equalizer jack lirc oss tcpd +X dbus libsamplerate gnome bluetooth +asyncns +glib test doc +udev ipv6 system-wide realtime +orc ssl +gdbm"
+IUSE="+alsa avahi +caps equalizer jack lirc oss tcpd +X dbus libsamplerate gnome bluetooth +asyncns +glib test doc +udev ipv6 system-wide realtime +orc ssl +gdbm +webrtc-aec"
RDEPEND=">=media-libs/libsndfile-1.0.20
X? (
@@ -51,6 +51,7 @@ RDEPEND=">=media-libs/libsndfile-1.0.20
ssl? ( dev-libs/openssl )
>=media-libs/speex-1.2_rc1
gdbm? ( sys-libs/gdbm )
+ webrtc-aec? ( media-libs/webrtc-audio-processing )
dev-libs/json-c
>=sys-devel/libtool-2.2.4" # it's a valid RDEPEND, libltdl.so is used
@@ -126,6 +127,8 @@ src_configure() {
$(use_enable ssl openssl) \
$(use_with caps) \
$(use_with equalizer fftw) \
+ $(use_with webrtc-aec) \
+ --disable-adrian-aec \
--disable-esound \
--localstatedir="${EPREFIX}"/var \
--with-udev-rules-dir="${EPREFIX}/lib/udev/rules.d" \