summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-11-23 15:47:46 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-11-23 15:47:46 +0000
commit0adf1ed27ebc359a292f10ef164ec6ef7906b7cc (patch)
tree0a2ab1611be107403be9da705fdaf83fc3b02bce /media-sound/pulseaudio
parentStable on ppc64; bug #198536 (diff)
downloadgentoo-2-0adf1ed27ebc359a292f10ef164ec6ef7906b7cc.tar.gz
gentoo-2-0adf1ed27ebc359a292f10ef164ec6ef7906b7cc.tar.bz2
gentoo-2-0adf1ed27ebc359a292f10ef164ec6ef7906b7cc.zip
Fix build when HAL is disabled but Bluetooth support is enabled.
(Portage version: 2.1.4_rc1)
Diffstat (limited to 'media-sound/pulseaudio')
-rw-r--r--media-sound/pulseaudio/ChangeLog7
-rw-r--r--media-sound/pulseaudio/files/pulseaudio-0.9.8-bt-nohal.patch28
-rw-r--r--media-sound/pulseaudio/pulseaudio-0.9.8-r1.ebuild15
-rw-r--r--media-sound/pulseaudio/pulseaudio-0.9.8.ebuild13
4 files changed, 55 insertions, 8 deletions
diff --git a/media-sound/pulseaudio/ChangeLog b/media-sound/pulseaudio/ChangeLog
index 37894beaa164..d5f6a88e7de5 100644
--- a/media-sound/pulseaudio/ChangeLog
+++ b/media-sound/pulseaudio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/pulseaudio
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.75 2007/11/23 14:16:03 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.76 2007/11/23 15:47:45 flameeyes Exp $
+
+ 23 Nov 2007; Diego Pettenò <flameeyes@gentoo.org>
+ +files/pulseaudio-0.9.8-bt-nohal.patch, pulseaudio-0.9.8.ebuild,
+ pulseaudio-0.9.8-r1.ebuild:
+ Fix build when HAL is disabled but Bluetooth support is enabled.
23 Nov 2007; Samuli Suominen <drac@gentoo.org> pulseaudio-0.9.7.ebuild:
amd64 stable wrt #197126, thanks to Angelo Arrifano for testing
diff --git a/media-sound/pulseaudio/files/pulseaudio-0.9.8-bt-nohal.patch b/media-sound/pulseaudio/files/pulseaudio-0.9.8-bt-nohal.patch
new file mode 100644
index 000000000000..95ffbb5d3335
--- /dev/null
+++ b/media-sound/pulseaudio/files/pulseaudio-0.9.8-bt-nohal.patch
@@ -0,0 +1,28 @@
+Index: pulseaudio-0.9.8/configure.ac
+===================================================================
+--- pulseaudio-0.9.8.orig/configure.ac
++++ pulseaudio-0.9.8/configure.ac
+@@ -836,7 +836,7 @@ if test "x$HAVE_HAL" = x1 ; then
+ dbus=yes
+ fi
+
+-if test "x${dbus}" != xno ; then
++if test "x${dbus}" != xno || test "x${bluez}" != xno || "x${hal}" != xno ; then
+
+ PKG_CHECK_MODULES(DBUS, [ dbus-1 >= 1.0.0 ],
+ [
+Index: pulseaudio-0.9.8/src/Makefile.am
+===================================================================
+--- pulseaudio-0.9.8.orig/src/Makefile.am
++++ pulseaudio-0.9.8/src/Makefile.am
+@@ -1424,8 +1424,8 @@ module_jack_source_la_CFLAGS = $(AM_CFLA
+ # HAL
+ libdbus_util_la_SOURCES = modules/dbus-util.c modules/dbus-util.h
+ libdbus_util_la_LDFLAGS = -avoid-version
+-libdbus_util_la_LIBADD = $(AM_LIBADD) $(HAL_LIBS) libpulsecore.la
+-libdbus_util_la_CFLAGS = $(AM_CFLAGS) $(HAL_CFLAGS)
++libdbus_util_la_LIBADD = $(AM_LIBADD) $(DBUS_LIBS) libpulsecore.la
++libdbus_util_la_CFLAGS = $(AM_CFLAGS) $(DBUS_CFLAGS)
+
+ module_hal_detect_la_SOURCES = modules/module-hal-detect.c
+ module_hal_detect_la_LDFLAGS = -module -avoid-version
diff --git a/media-sound/pulseaudio/pulseaudio-0.9.8-r1.ebuild b/media-sound/pulseaudio/pulseaudio-0.9.8-r1.ebuild
index db045bfadf04..a7de23858ca3 100644
--- a/media-sound/pulseaudio/pulseaudio-0.9.8-r1.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-0.9.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-0.9.8-r1.ebuild,v 1.1 2007/11/23 13:09:30 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-0.9.8-r1.ebuild,v 1.2 2007/11/23 15:47:45 flameeyes Exp $
inherit eutils libtool autotools
@@ -28,11 +28,17 @@ RDEPEND="X? ( x11-libs/libX11 )
lirc? ( app-misc/lirc )
dbus? ( >=sys-apps/dbus-1.0.0 )
gnome? ( >=gnome-base/gconf-2.4.0 )
- hal? ( >=sys-apps/hal-0.5.7 )
- >=sys-apps/baselayout-2.0_rc5
+ hal? (
+ >=sys-apps/hal-0.5.7
+ >=sys-apps/dbus-1.0.0
+ )
app-admin/eselect-esd
- bluetooth? ( >=net-wireless/bluez-libs-3 )
+ bluetooth? (
+ >=net-wireless/bluez-libs-3
+ >=sys-apps/dbus-1.0.0
+ )
policykit? ( sys-auth/policykit )
+ >=sys-apps/baselayout-2.0_rc5
>=sys-devel/libtool-1.5.24" # it's a valid RDEPEND, libltdl.so is used
DEPEND="${RDEPEND}
dev-libs/libatomic_ops
@@ -68,6 +74,7 @@ src_unpack() {
epatch "${FILESDIR}/${P}-svn2074.patch"
epatch "${FILESDIR}/${P}-polkit.patch"
+ epatch "${FILESDIR}/${P}-bt-nohal.patch"
eautoreconf
elibtoolize
diff --git a/media-sound/pulseaudio/pulseaudio-0.9.8.ebuild b/media-sound/pulseaudio/pulseaudio-0.9.8.ebuild
index 0107ead5854d..0d716a559da3 100644
--- a/media-sound/pulseaudio/pulseaudio-0.9.8.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-0.9.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-0.9.8.ebuild,v 1.1 2007/11/23 13:09:30 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-0.9.8.ebuild,v 1.2 2007/11/23 15:47:45 flameeyes Exp $
inherit eutils libtool autotools
@@ -28,9 +28,15 @@ RDEPEND="X? ( x11-libs/libX11 )
lirc? ( app-misc/lirc )
dbus? ( >=sys-apps/dbus-1.0.0 )
gnome? ( >=gnome-base/gconf-2.4.0 )
- hal? ( >=sys-apps/hal-0.5.7 )
+ hal? (
+ >=sys-apps/hal-0.5.7
+ >=sys-apps/dbus-1.0.0
+ )
app-admin/eselect-esd
- bluetooth? ( >=net-wireless/bluez-libs-3 )
+ bluetooth? (
+ >=net-wireless/bluez-libs-3
+ >=sys-apps/dbus-1.0.0
+ )
policykit? ( sys-auth/policykit )
>=sys-devel/libtool-1.5.24" # it's a valid RDEPEND, libltdl.so is used
DEPEND="${RDEPEND}
@@ -66,6 +72,7 @@ src_unpack() {
epatch "${FILESDIR}/${P}-svn2074.patch"
epatch "${FILESDIR}/${P}-polkit.patch"
+ epatch "${FILESDIR}/${P}-bt-nohal.patch"
eautoreconf
elibtoolize