summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-10-18 21:48:35 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-10-18 21:48:35 +0000
commit8ffa2374a67eff7dd63faf28add2e942aaa8311e (patch)
tree31c4be52ebdd3cf51e4d54378718676c0716cf10 /media-sound/pympd/pympd-0.05.ebuild
parentDo not attempt to redirect output to /dev/tty, this makes no sense. Closes bu... (diff)
downloadgentoo-2-8ffa2374a67eff7dd63faf28add2e942aaa8311e.tar.gz
gentoo-2-8ffa2374a67eff7dd63faf28add2e942aaa8311e.tar.bz2
gentoo-2-8ffa2374a67eff7dd63faf28add2e942aaa8311e.zip
Version bump. Added a desktop entry. Closes bug #109700, by Anton Romanov <theli@ukr.net>.
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'media-sound/pympd/pympd-0.05.ebuild')
-rw-r--r--media-sound/pympd/pympd-0.05.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-sound/pympd/pympd-0.05.ebuild b/media-sound/pympd/pympd-0.05.ebuild
new file mode 100644
index 000000000000..2864f1f24cdd
--- /dev/null
+++ b/media-sound/pympd/pympd-0.05.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pympd/pympd-0.05.ebuild,v 1.1 2005/10/18 21:48:35 ticho Exp $
+
+inherit distutils
+
+DESCRIPTION="a Rhythmbox-like PyGTK+ client for Music Player Daemon"
+HOMEPAGE="http://sourceforge.net/projects/pympd"
+SRC_URI="http://pympd.sourceforge.net/files/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+
+IUSE="gnome"
+RDEPEND=">=virtual/python-2.4
+ >=dev-python/pygtk-2
+ gnome? ( dev-python/gnome-python-extras )"
+
+DOCS="README"
+
+src_install() {
+ distutils_src_install
+
+ use gnome || cd ${D} && find -iname trayicon.* | xargs rm
+
+ dodir /usr/share/pixmaps
+ insinto /usr/share/pixmaps
+
+ cd ${S}
+ newins src/glade/pixmaps/icon.png pympd.png
+ make_desktop_entry "pympd" "pympd" "pympd.png" "Audio"
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/pympd
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}