summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-12-08 08:56:36 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-12-08 08:56:36 +0000
commit0f66780987637f5f65296633a922b0ceaad8c0bc (patch)
treebedc1607c47ff39ca95209d697095b571a87d3c4 /media-sound/qjackctl
parentbump to final 3.11.0 (diff)
downloadgentoo-2-0f66780987637f5f65296633a922b0ceaad8c0bc.tar.gz
gentoo-2-0f66780987637f5f65296633a922b0ceaad8c0bc.tar.bz2
gentoo-2-0f66780987637f5f65296633a922b0ceaad8c0bc.zip
version bump
(Portage version: 2.2_rc17/cvs/Linux 2.6.27.7 x86_64)
Diffstat (limited to 'media-sound/qjackctl')
-rw-r--r--media-sound/qjackctl/ChangeLog7
-rw-r--r--media-sound/qjackctl/qjackctl-0.3.4.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/media-sound/qjackctl/ChangeLog b/media-sound/qjackctl/ChangeLog
index 53753cfe2073..aa26431a55a5 100644
--- a/media-sound/qjackctl/ChangeLog
+++ b/media-sound/qjackctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/qjackctl
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.58 2008/10/10 12:28:39 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.59 2008/12/08 08:56:36 aballier Exp $
+
+*qjackctl-0.3.4 (08 Dec 2008)
+
+ 08 Dec 2008; Alexis Ballier <aballier@gentoo.org> +qjackctl-0.3.4.ebuild:
+ version bump
*qjackctl-0.3.3-r1 (10 Oct 2008)
diff --git a/media-sound/qjackctl/qjackctl-0.3.4.ebuild b/media-sound/qjackctl/qjackctl-0.3.4.ebuild
new file mode 100644
index 000000000000..a6a97aca4b79
--- /dev/null
+++ b/media-sound/qjackctl/qjackctl-0.3.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/qjackctl-0.3.4.ebuild,v 1.1 2008/12/08 08:56:36 aballier Exp $
+
+EAPI=2
+
+inherit eutils qt4
+
+DESCRIPTION="A Qt application to control the JACK Audio Connection Kit and ALSA sequencer connections."
+HOMEPAGE="http://qjackctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+IUSE="alsa debug"
+
+DEPEND="alsa? ( media-libs/alsa-lib[midi] )
+ || ( (
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ ) =x11-libs/qt-4.3*:4 )
+ media-sound/jack-audio-connection-kit"
+
+src_configure() {
+ econf \
+ $(use_enable alsa alsa-seq) \
+ $(use_enable debug) \
+ || die "econf failed"
+
+ # Emulate what the Makefile does, so that we can get the correct
+ # compiler used.
+ eqmake4 ${PN}.pro -o ${PN}.mak || die "eqmake4 failed"
+}
+
+src_compile() {
+ emake -f ${PN}.mak || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ rm "${D}/usr/share/applications/qjackctl.desktop"
+
+ # Upstream desktop file is invalid, better stick with our for now.
+ make_desktop_entry "${PN}" "QjackCtl" "${PN}"
+
+ dodoc README ChangeLog TODO AUTHORS
+}