summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-05-31 01:04:34 +0000
committerBen de Groot <yngwin@gentoo.org>2008-05-31 01:04:34 +0000
commit6687d9c500a822780704112034196ce895154edb (patch)
tree65fa2b9ddf13e762affb574aed423c84af5afdc4 /media-sound/qtscrobbler
parentCommitting build-time fix for bug 214137; SRCDIR was getting passed to the eb... (diff)
downloadgentoo-2-6687d9c500a822780704112034196ce895154edb.tar.gz
gentoo-2-6687d9c500a822780704112034196ce895154edb.tar.bz2
gentoo-2-6687d9c500a822780704112034196ce895154edb.zip
Initial import of QtScrobbler - a last.fm committer for portable devices
(Portage version: 2.1.5.2)
Diffstat (limited to 'media-sound/qtscrobbler')
-rw-r--r--media-sound/qtscrobbler/ChangeLog10
-rw-r--r--media-sound/qtscrobbler/Manifest4
-rw-r--r--media-sound/qtscrobbler/metadata.xml5
-rw-r--r--media-sound/qtscrobbler/qtscrobbler-0.8.ebuild56
4 files changed, 75 insertions, 0 deletions
diff --git a/media-sound/qtscrobbler/ChangeLog b/media-sound/qtscrobbler/ChangeLog
new file mode 100644
index 000000000000..21885ae7b9f9
--- /dev/null
+++ b/media-sound/qtscrobbler/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-sound/qtscrobbler
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qtscrobbler/ChangeLog,v 1.1 2008/05/31 01:04:34 yngwin Exp $
+
+*qtscrobbler-0.8 (31 May 2008)
+
+ 31 May 2008; Ben de Groot <yngwin@gentoo.org> +qtscrobbler-0.8.ebuild:
+ Initial import. Ebuild based on the one in ephemeral overlay. Fixes bug
+ 140738.
+
diff --git a/media-sound/qtscrobbler/Manifest b/media-sound/qtscrobbler/Manifest
new file mode 100644
index 000000000000..d2ca4ad97fde
--- /dev/null
+++ b/media-sound/qtscrobbler/Manifest
@@ -0,0 +1,4 @@
+DIST qtscrob-0.8.tar.bz2 126583 RMD160 e37c9bb69943f00375ec51c67b49c5b774fca257 SHA1 9f8305a2775183b063d0bdd6ca8b202c17bb1e12 SHA256 2d52dcff4b50ca5c75ba3c309e087ab80ecf2d6e3f1cd2f5acbcb55c4de915ec
+EBUILD qtscrobbler-0.8.ebuild 1281 RMD160 0810f28865ac25640bc72538d1719f1c17fe6544 SHA1 bcb768634a0918910724cf16d61edda8daeafa57 SHA256 42088ba86c49c78f9d4639f607226202745b1cba89728124cbfa6e6d596108e1
+MISC ChangeLog 314 RMD160 9cc785e53461f71181a84d4726cc3884b9fc4196 SHA1 fdbfa57b5df085b21a7383898513d1413cce9799 SHA256 1e5b80bb9a122fca9abb15c1b5e04b591e08f737fe8d57795264cdb72d262126
+MISC metadata.xml 160 RMD160 10be84fed28405abd22adc6689e87e5bb77e3501 SHA1 0c1bb16a7cc376ef35b87d8699ec9504718d36b9 SHA256 6bafe4a5c7b42309f124ebc2a9d78ebe5379aec4dcdc88c0bda2ab79c9851a6b
diff --git a/media-sound/qtscrobbler/metadata.xml b/media-sound/qtscrobbler/metadata.xml
new file mode 100644
index 000000000000..3bf6bcfeb512
--- /dev/null
+++ b/media-sound/qtscrobbler/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/qtscrobbler/qtscrobbler-0.8.ebuild b/media-sound/qtscrobbler/qtscrobbler-0.8.ebuild
new file mode 100644
index 000000000000..ae42ff88c918
--- /dev/null
+++ b/media-sound/qtscrobbler/qtscrobbler-0.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qtscrobbler/qtscrobbler-0.8.ebuild,v 1.1 2008/05/31 01:04:34 yngwin Exp $
+
+EAPI=1
+inherit eutils qt4
+
+MY_PN="qtscrob"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Updates a last.fm profile using information from a supported portable music player"
+HOMEPAGE="http://qtscrob.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="qt4"
+
+DEPEND="net-misc/curl
+ qt4? ( || ( x11-libs/qt-gui:4 >=x11-libs/qt-4.3:4 ) )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ # Makefile for cli prog does not read CFLAGS env var.
+ # This sed fixes this.
+ cd "${S}/src/cli"
+ sed -i -e "s:CFLAGS =.*:CFLAGS = \$(INCLUDE) `curl-config --cflags` ${CFLAGS}:" Makefile
+}
+
+
+src_compile() {
+ cd "${S}/src/cli"
+ emake || die "emake qtscrob cli failed"
+ if use qt4; then
+ cd "${S}/src/qt"
+ qmake "${MY_PN}.pro" || die "qmake qtscrob gui failed"
+ emake || die "emake qtscrob gui failed"
+ fi
+}
+
+src_install() {
+ cd "${S}/src/cli"
+ newbin scrobble-cli qtscrobbler-cli
+ if use qt4; then
+ cd "${S}/src/qt"
+ newbin qtscrob qtscrobbler
+ newicon resources/icons/128.png qtscrobbler.png
+ make_desktop_entry qtscrobbler QtScrobbler
+ fi
+ cd "${S}"
+ dodoc AUTHORS CHANGELOG README
+}