summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-08-18 23:41:36 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-08-18 23:41:36 +0000
commit7fa907b806b490a1775f25d408f53f8af901bd50 (patch)
tree08d31a30922f90c3134a6a208a9a4f0179d5dc5e /media-sound/rosegarden/rosegarden-1.2.4.ebuild
parentFix bug #134121, thanks to Christian Becke. (diff)
downloadgentoo-2-7fa907b806b490a1775f25d408f53f8af901bd50.tar.gz
gentoo-2-7fa907b806b490a1775f25d408f53f8af901bd50.tar.bz2
gentoo-2-7fa907b806b490a1775f25d408f53f8af901bd50.zip
Version bump. Major version 4 has been dropped upstream.
(Portage version: 2.1.1_pre5-r2)
Diffstat (limited to 'media-sound/rosegarden/rosegarden-1.2.4.ebuild')
-rw-r--r--media-sound/rosegarden/rosegarden-1.2.4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-sound/rosegarden/rosegarden-1.2.4.ebuild b/media-sound/rosegarden/rosegarden-1.2.4.ebuild
new file mode 100644
index 000000000000..cb9ffd91a384
--- /dev/null
+++ b/media-sound/rosegarden/rosegarden-1.2.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rosegarden/rosegarden-1.2.4.ebuild,v 1.1 2006/08/18 23:41:36 carlo Exp $
+
+inherit kde eutils flag-o-matic
+
+S="${WORKDIR}/${P}"
+
+DESCRIPTION="MIDI and audio sequencer and notation editor."
+HOMEPAGE="http://www.rosegardenmusic.com/"
+SRC_URI="mirror://sourceforge/rosegarden/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="lirc"
+
+RDEPEND="media-libs/alsa-lib
+ media-sound/jack-audio-connection-kit
+ media-libs/ladspa-sdk
+ >=media-libs/ladspa-cmt-1.14
+ media-libs/liblrdf
+ media-libs/dssi"
+DEPEND="${RDEPEND}
+ dev-util/scons"
+need-kde 3.4
+
+LANGS="ca cs cy de en_GB en es et fi fr it ja nl ru sv zh_CN"
+
+src_compile() {
+ [ -d "$QTDIR/etc/settings" ] && addwrite "$QTDIR/etc/settings"
+ addpredict "$QTDIR/etc/settings"
+
+ local myconf="kdeincludes=$(kde-config --prefix)/include prefix=${ROOT}/usr"
+ use amd64 && myconf="${myconf} libsuffix=64"
+ use lirc || myconf="${myconf} nolirc=1"
+
+ scons configure ${myconf} || die "configure failed"
+ scons ${MAKEOPTS} || die "scons failed"
+}
+
+src_install() {
+ scons install DESTDIR="${D}" languages="$(echo $(echo "${LINGUAS} ${LANGS}" | fmt -w 1 | sort | uniq -d))"
+ dodoc AUTHORS README TRANSLATORS
+}